summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaurice van der Pot <griffon26@gentoo.org>2005-04-12 18:31:24 +0000
committerMaurice van der Pot <griffon26@gentoo.org>2005-04-12 18:31:24 +0000
commit6627ebdfdb84b52964564849b5c7e22dbf517d7f (patch)
treed5794f1775b5c417636fccd0cd0fa350a2dc0814 /dev-util/valgrind/files
parentoops, forgot to commit the patch (diff)
downloadhistorical-6627ebdfdb84b52964564849b5c7e22dbf517d7f.tar.gz
historical-6627ebdfdb84b52964564849b5c7e22dbf517d7f.tar.bz2
historical-6627ebdfdb84b52964564849b5c7e22dbf517d7f.zip
Fixed valgrind 2.4.0 to build with PIE
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'dev-util/valgrind/files')
-rw-r--r--dev-util/valgrind/files/digest-valgrind-2.4.01
-rw-r--r--dev-util/valgrind/files/valgrind-2.4.0-pie-fix.patch54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-util/valgrind/files/digest-valgrind-2.4.0 b/dev-util/valgrind/files/digest-valgrind-2.4.0
index 2e60363a442d..cff9e3e31e50 100644
--- a/dev-util/valgrind/files/digest-valgrind-2.4.0
+++ b/dev-util/valgrind/files/digest-valgrind-2.4.0
@@ -1 +1,2 @@
MD5 1d0bd81d368789946d32d18a468ea0cf valgrind-2.4.0.tar.bz2 1072044
+MD5 bbdd3f02fb930c333413b6a3d155d73b valgrind-2.4.0-ppc-050407.tar.bz2 1113464
diff --git a/dev-util/valgrind/files/valgrind-2.4.0-pie-fix.patch b/dev-util/valgrind/files/valgrind-2.4.0-pie-fix.patch
new file mode 100644
index 000000000000..7c674a27f5ee
--- /dev/null
+++ b/dev-util/valgrind/files/valgrind-2.4.0-pie-fix.patch
@@ -0,0 +1,54 @@
+diff -ruN valgrind-2.4.0/corecheck/tests/Makefile.in valgrind-2.4.0-fixed/corecheck/tests/Makefile.in
+--- valgrind-2.4.0/corecheck/tests/Makefile.in 2005-03-24 03:30:27.000000000 +0100
++++ valgrind-2.4.0-fixed/corecheck/tests/Makefile.in 2005-04-12 18:53:56.686049352 +0200
+@@ -202,7 +202,7 @@
+ CCAS = @CCAS@
+ CCASFLAGS = @CCASFLAGS@
+ CCDEPMODE = @CCDEPMODE@
+-CFLAGS = @CFLAGS@
++CFLAGS = @CFLAGS@ -fno-pie
+ CPP = @CPP@
+ CPPFLAGS = @CPPFLAGS@
+ CXX = @CXX@
+diff -ruN valgrind-2.4.0/coregrind/x86-linux/syscalls.c valgrind-2.4.0-fixed/coregrind/x86-linux/syscalls.c
+--- valgrind-2.4.0/coregrind/x86-linux/syscalls.c 2005-03-23 11:22:03.000000000 +0100
++++ valgrind-2.4.0-fixed/coregrind/x86-linux/syscalls.c 2005-04-12 18:50:01.373822248 +0200
+@@ -259,10 +259,13 @@
+ We need to make sure we don't touch the stack between marking it
+ Empty and exiting. Hence the assembler. */
+ asm volatile (
++ "pushl %%ebx\n" /* save original ebx value */
+ "movl %1, %0\n" /* set tst->status = VgTs_Empty */
++ "movl %2, %%ebx\n" /* set ebx = tst->os_state.exitcode */
+ "int $0x80\n" /* exit(tst->os_state.exitcode) */
++ "popl %%ebx\n" /* restore original ebx value */
+ : "=m" (tst->status)
+- : "n" (VgTs_Empty), "a" (__NR_exit), "b" (tst->os_state.exitcode));
++ : "n" (VgTs_Empty), "a" (__NR_exit), "m" (tst->os_state.exitcode));
+
+ VG_(core_panic)("Thread exit failed?\n");
+ }
+diff -ruN valgrind-2.4.0/none/tests/Makefile.in valgrind-2.4.0-fixed/none/tests/Makefile.in
+--- valgrind-2.4.0/none/tests/Makefile.in 2005-03-24 03:30:45.000000000 +0100
++++ valgrind-2.4.0-fixed/none/tests/Makefile.in 2005-04-12 18:54:42.311113288 +0200
+@@ -322,7 +322,7 @@
+ CCAS = @CCAS@
+ CCASFLAGS = @CCASFLAGS@
+ CCDEPMODE = @CCDEPMODE@
+-CFLAGS = @CFLAGS@
++CFLAGS = @CFLAGS@ -fno-pie
+ CPP = @CPP@
+ CPPFLAGS = @CPPFLAGS@
+ CXX = @CXX@
+diff -ruN valgrind-2.4.0/none/tests/x86/Makefile.in valgrind-2.4.0-fixed/none/tests/x86/Makefile.in
+--- valgrind-2.4.0/none/tests/x86/Makefile.in 2005-03-24 03:30:45.000000000 +0100
++++ valgrind-2.4.0-fixed/none/tests/x86/Makefile.in 2005-04-12 18:55:25.859492928 +0200
+@@ -156,7 +156,7 @@
+ CCAS = @CCAS@
+ CCASFLAGS = @CCASFLAGS@
+ CCDEPMODE = @CCDEPMODE@
+-CFLAGS = @CFLAGS@
++CFLAGS = @CFLAGS@ -fno-pie
+ CPP = @CPP@
+ CPPFLAGS = @CPPFLAGS@
+ CXX = @CXX@