summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-07-03 18:30:42 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-07-03 18:30:42 +0000
commitd065f456eb9e020240a0eb1a491f99a344b5d63b (patch)
tree45ef5a362934f188bd868f8f03775a1ffdf01a6d /dev-util/re2c/re2c-0.9.7.ebuild
parentAdd missing dep on khotkeys, fixes bug 97773. (diff)
downloadhistorical-d065f456eb9e020240a0eb1a491f99a344b5d63b.tar.gz
historical-d065f456eb9e020240a0eb1a491f99a344b5d63b.tar.bz2
historical-d065f456eb9e020240a0eb1a491f99a344b5d63b.zip
Bug #95569, version bump. Stable 0.9.3. Add metadata with myself and lisa (who submitted the original package).
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'dev-util/re2c/re2c-0.9.7.ebuild')
-rw-r--r--dev-util/re2c/re2c-0.9.7.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-util/re2c/re2c-0.9.7.ebuild b/dev-util/re2c/re2c-0.9.7.ebuild
new file mode 100644
index 000000000000..f71311d514b5
--- /dev/null
+++ b/dev-util/re2c/re2c-0.9.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/re2c/re2c-0.9.7.ebuild,v 1.1 2005/07/03 18:30:42 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="tool for generating C-based recognizers from regular expressions"
+HOMEPAGE="http://re2c.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+
+DEPEND=">=dev-util/byacc-1.9"
+
+src_unpack() {
+ unpack ${A} || die
+ # Fix permissions
+ chmod -R u+rw ${S}
+}
+
+src_compile() {
+ econf || die
+ emake -e || die
+}
+
+src_install() {
+ dobin re2c || die "dobin failed"
+ doman re2c.1
+ dodoc README doc/*
+}