summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Harring <ferringb@gentoo.org>2011-04-25 03:11:35 +0000
committerBrian Harring <ferringb@gentoo.org>2011-04-25 03:11:35 +0000
commiteb0ad99b00a4eb2a6625db8978ff966ae642d336 (patch)
tree1aca68133be82b64a35677bbe0351980f74ab95f /dev-util/pkgcore-checks
parentadd pkgcore 0.6, with eapi4 support. (diff)
downloadhistorical-eb0ad99b00a4eb2a6625db8978ff966ae642d336.tar.gz
historical-eb0ad99b00a4eb2a6625db8978ff966ae642d336.tar.bz2
historical-eb0ad99b00a4eb2a6625db8978ff966ae642d336.zip
add 0.4.14
Package-Manager: portage-2.1.9.44/cvs/Linux x86_64
Diffstat (limited to 'dev-util/pkgcore-checks')
-rw-r--r--dev-util/pkgcore-checks/ChangeLog8
-rw-r--r--dev-util/pkgcore-checks/pkgcore-checks-0.4.14.ebuild45
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-util/pkgcore-checks/ChangeLog b/dev-util/pkgcore-checks/ChangeLog
index 56e00d14bcd9..f89fc902ef3f 100644
--- a/dev-util/pkgcore-checks/ChangeLog
+++ b/dev-util/pkgcore-checks/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/pkgcore-checks
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgcore-checks/ChangeLog,v 1.46 2011/03/22 06:30:30 ferringb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgcore-checks/ChangeLog,v 1.47 2011/04/25 03:11:35 ferringb Exp $
+
+*pkgcore-checks-0.4.14 (25 Apr 2011)
+
+ 25 Apr 2011; Brian Harring <ferringb@gentoo.org>
+ +pkgcore-checks-0.4.14.ebuild:
+ add 0.4.14; bugfixes and compatibility for snakeoil/pkgcore changes
22 Mar 2011; Brian Harring <ferringb@gentoo.org>
pkgcore-checks-0.4.13.ebuild:
diff --git a/dev-util/pkgcore-checks/pkgcore-checks-0.4.14.ebuild b/dev-util/pkgcore-checks/pkgcore-checks-0.4.14.ebuild
new file mode 100644
index 000000000000..53a7461e2e3d
--- /dev/null
+++ b/dev-util/pkgcore-checks/pkgcore-checks-0.4.14.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgcore-checks/pkgcore-checks-0.4.14.ebuild,v 1.1 2011/04/25 03:11:35 ferringb Exp $
+
+EAPI="3"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils
+
+DESCRIPTION="pkgcore developmental repoman replacement"
+HOMEPAGE="http://www.pkgcore.org/"
+SRC_URI="http://www.pkgcore.org/releases/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=sys-apps/pkgcore-0.5.9
+ >=dev-python/snakeoil-0.3.6"
+DEPEND="${RDEPEND}"
+
+DOCS="AUTHORS NEWS"
+PYTHON_MODNAME="pkgcore_checks"
+
+pkg_setup() {
+ # disable snakeoil 2to3 caching...
+ unset PY2TO3_CACHEDIR
+ python_pkg_setup
+}
+
+pkg_postinst() {
+ einfo "updating pkgcore plugin cache"
+ pplugincache pkgcore_checks.plugins pkgcore.plugins
+ distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ # Careful not to remove this on up/downgrades.
+ local sitep="${ROOT}$(python_get_sitedir)"
+ if [[ -e "${sitep}/pkgcore_checks/plugins/plugincache2" && ! -e "${sitep}/pkgcore_checks/base.py" ]]; then
+ rm "${sitep}/pkgcore_checks/plugins/plugincache2"
+ fi
+ distutils_pkg_postrm
+}