summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-05-01 18:05:00 +0000
committerMike Frysinger <vapier@gentoo.org>2012-05-01 18:05:00 +0000
commit10a0f1f802aff33bf6294bb0dccebb115a39ab65 (patch)
tree6a831b089e711cc5d0db4f69f6358862ee2ffa60 /dev-util/pkgconf/pkgconf-9999.ebuild
parentVersion bump. (diff)
downloadhistorical-10a0f1f802aff33bf6294bb0dccebb115a39ab65.tar.gz
historical-10a0f1f802aff33bf6294bb0dccebb115a39ab65.tar.bz2
historical-10a0f1f802aff33bf6294bb0dccebb115a39ab65.zip
Initial ebuild.
Package-Manager: portage-2.2.0_alpha100/cvs/Linux x86_64
Diffstat (limited to 'dev-util/pkgconf/pkgconf-9999.ebuild')
-rw-r--r--dev-util/pkgconf/pkgconf-9999.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-util/pkgconf/pkgconf-9999.ebuild b/dev-util/pkgconf/pkgconf-9999.ebuild
new file mode 100644
index 000000000000..ada2cff854ac
--- /dev/null
+++ b/dev-util/pkgconf/pkgconf-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconf/pkgconf-9999.ebuild,v 1.1 2012/05/01 18:05:00 vapier Exp $
+
+EAPI="4"
+
+inherit autotools vcs-snapshot
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/nenolod/pkgconf.git"
+ inherit git-2
+else
+ SRC_URI="https://github.com/nenolod/pkgconf/tarball/${P} -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+DESCRIPTION="pkg-config compatible replacement with no dependencies other than ANSI C89"
+HOMEPAGE="https://github.com/nenolod/pkgconf"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="pkg-config"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ pkg-config? (
+ !dev-util/pkgconfig
+ !dev-util/pkg-config-lite
+ )"
+
+src_prepare() {
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_install() {
+ default
+ use pkg-config \
+ && dosym pkgconf /usr/bin/pkg-config \
+ || rm "${ED}"/usr/share/aclocal/pkg.m4 \
+ || die
+}