summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2003-04-15 03:15:38 +0000
committerTavis Ormandy <taviso@gentoo.org>2003-04-15 03:15:38 +0000
commit908a6ffdead03f177f8d68e4f20cdc453df2a91f (patch)
treea28a214078025f958e82a1be5600dc8c0ad8caa9 /dev-util/ladebug
parentblah (diff)
downloadhistorical-908a6ffdead03f177f8d68e4f20cdc453df2a91f.tar.gz
historical-908a6ffdead03f177f8d68e4f20cdc453df2a91f.tar.bz2
historical-908a6ffdead03f177f8d68e4f20cdc453df2a91f.zip
Initial import of ladebug ebuild
Diffstat (limited to 'dev-util/ladebug')
-rw-r--r--dev-util/ladebug/ChangeLog9
-rw-r--r--dev-util/ladebug/files/50ladebug.el5
-rw-r--r--dev-util/ladebug/ladebug-4.0.67.ebuild99
3 files changed, 113 insertions, 0 deletions
diff --git a/dev-util/ladebug/ChangeLog b/dev-util/ladebug/ChangeLog
new file mode 100644
index 000000000000..bd48467df900
--- /dev/null
+++ b/dev-util/ladebug/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-util/ladebug
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ladebug/ChangeLog,v 1.1 2003/04/15 03:15:38 taviso Exp $
+
+*ladebug-4.0.67 (15 Apr 2003)
+
+ 15 Apr 2003; Tavis Ormandy <taviso@gentoo.org> ladebug-4.0.67.ebuild:
+ Initial import of ebuild, with optional emacs support.
+
diff --git a/dev-util/ladebug/files/50ladebug.el b/dev-util/ladebug/files/50ladebug.el
new file mode 100644
index 000000000000..4fb1c6f09b34
--- /dev/null
+++ b/dev-util/ladebug/files/50ladebug.el
@@ -0,0 +1,5 @@
+
+;;; ladebug confugration for gentoo
+
+(add-to-list 'load-path "/usr/share/emacs/site-lisp/ladebug")
+
diff --git a/dev-util/ladebug/ladebug-4.0.67.ebuild b/dev-util/ladebug/ladebug-4.0.67.ebuild
new file mode 100644
index 000000000000..7843695da1a5
--- /dev/null
+++ b/dev-util/ladebug/ladebug-4.0.67.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ladebug/ladebug-4.0.67.ebuild,v 1.1 2003/04/15 03:15:38 taviso Exp $
+#
+# Submitted By Tavis Ormandy <taviso@gentoo.org>
+#
+
+IUSE="emacs"
+
+inherit elisp
+
+DESCRIPTION="Linux port of the Famous Tru64 Debugger"
+HOMEPAGE="http://www.support.compaq.com/alpha-tools"
+#HOMEPAGE="ftp://ftp.compaq.com/pub/products/linuxdevtools/latest/downloads.html"
+#SRC_URI="ftp://ftp.compaq.com/pub/products/linuxdevtools/latest/ladebug-4.0.67-21.alpha.rpm"
+LICENSE="PLDSPv2"
+SLOT="0"
+# NOTE: ALPHA Only!
+KEYWORDS="-* ~alpha"
+DEPEND="virtual/glibc
+ app-arch/rpm2targz
+ dev-libs/libots
+ dev-libs/libcpml
+ emacs? ( virtual/emacs )"
+S=${WORKDIR}/${P}
+RELEASE="4.0.67-21"
+SITEFILE="50ladebug.el"
+
+src_unpack() {
+ # convert rpm into tar archive
+ local ladebug_rpm="ladebug-${RELEASE}.alpha.rpm"
+ if [ ! -f ${DISTDIR}/${ladebug_rpm} ]; then
+ eerror ""
+ eerror "Please download ${ladebug_rpm} from"
+ eerror "${HOMEPAGE}, and place it in"
+ eerror "${DISTDIR}"
+ eerror ""
+ eerror "Then resart this emerge."
+ eerror ""
+ die "Ladebug Distribution (${ladebug_rpm}) not found"
+ else
+ ebegin "Unpacking Ladebug Distribution..."
+ i=${DISTDIR}/${ladebug_rpm}
+ dd ibs=`rpmoffset < ${i}` skip=1 if=$i 2>/dev/null \
+ | gzip -dc | cpio -idmu 2>/dev/null \
+ && find usr -type d -print0 | xargs -0 chmod a+rx
+ eend ${?}
+ assert "Failed to extract ${ladebug_rpm%.rpm}.tar.gz"
+
+ eend ${?}
+ fi
+}
+
+src_compile() {
+ # remove emacs lisp files
+ if ! use emacs >/dev/null ; then
+ einfo "Removing emacs Ladebug integration (USE=\"-emacs\"?)..."
+ rm -rf ${WORKDIR}/usr/lib/emacs ${WORKDIR}/usr/lib/compaq/ladebug-V67/ladebug.el
+ else
+ einfo "Preparing emacs Ladebug integration (USE=\"emacs\"?)..."
+ rm -rf ${WORKDIR}/usr/lib/emacs
+ fi
+
+ # man pages are in the wrong place
+ einfo "Reorganising man structure..."
+ rm -rf ${WORKDIR}/usr/man
+ mkdir -p ${WORKDIR}/usr/share/man/man1
+ mv ${WORKDIR}/usr/lib/compaq/ladebug-V67/ladebug.1.gz ${WORKDIR}/usr/share/man/man1
+
+ einfo "Reorganising Documentation structure..."
+ mv ${WORKDIR}/usr/doc ${WORKDIR}/usr/share/
+ cp -r ${WORKDIR}/usr/share/locale/en_US ${WORKDIR}/usr/share/locale/C
+}
+
+src_install() {
+ # move files over
+ mv ${WORKDIR}/usr ${D} || die "Ladebug Installation Failed"
+
+ # prep manpages
+ prepman ${D}/usr/share/man/man1/ladebug.1.gz
+ prepalldocs
+ if use emacs >/dev/null ; then
+ elisp-install ${PN} ladebug.el
+ #FIXME: how does this work?
+ #elisp-site-file-install ${FILESDIR}/${SITEFILE}
+ cp ${FILESDIR}/${SITEFILE} ${D}/usr/share/emacs/site-lisp/
+ fi
+}
+
+pkg_postinst () {
+ einfo
+ einfo "Ladebug ${RELEASE} has been merged successfully"
+ einfo
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}