summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandy Westcott <brandy@gentoo.org>2003-10-30 12:34:49 +0000
committerBrandy Westcott <brandy@gentoo.org>2003-10-30 12:34:49 +0000
commitf42d34d42f3dfecc4684b0853ec57b76701587fa (patch)
treefcb4ef0b97ab681ec2a503584a5cc525cdc50490 /dev-util/diffstat
parentoptional gifs. (diff)
downloadhistorical-f42d34d42f3dfecc4684b0853ec57b76701587fa.tar.gz
historical-f42d34d42f3dfecc4684b0853ec57b76701587fa.tar.bz2
historical-f42d34d42f3dfecc4684b0853ec57b76701587fa.zip
Added patch to allow diffstat to handle hard-locale time format. Closes bug #31689.
Diffstat (limited to 'dev-util/diffstat')
-rw-r--r--dev-util/diffstat/ChangeLog6
-rw-r--r--dev-util/diffstat/Manifest5
-rw-r--r--dev-util/diffstat/diffstat-1.29.ebuild9
-rw-r--r--dev-util/diffstat/files/diffstat-1.29-hard-locale.patch15
4 files changed, 30 insertions, 5 deletions
diff --git a/dev-util/diffstat/ChangeLog b/dev-util/diffstat/ChangeLog
index aac9fcfb3031..1b5d252e2b93 100644
--- a/dev-util/diffstat/ChangeLog
+++ b/dev-util/diffstat/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/diffstat
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/diffstat/ChangeLog,v 1.5 2003/09/14 12:24:53 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/diffstat/ChangeLog,v 1.6 2003/10/30 12:34:39 brandy Exp $
+
+ 31 Oct 2003; Brandy Westcott brandy@gentoo.org diffstat-1.29.ebuild:
+ Added patch to allow diffstat to handle hard-locale time format. Thanks to
+ Doug Weimer <dweimer@socal.rr.com> for the patch; closes bug #31689.
14 Sep 2003; David Holm <dholm@gentoo.org> diffstat-1.29.ebuild:
Added to ~ppc, tested by Daniel Berlin <dberlin@dberlin.org>.
diff --git a/dev-util/diffstat/Manifest b/dev-util/diffstat/Manifest
index df1a9ba11322..e56e49f9bc5e 100644
--- a/dev-util/diffstat/Manifest
+++ b/dev-util/diffstat/Manifest
@@ -1,3 +1,4 @@
-MD5 6ee3c92df1fa84a7fd122e116476ea2d ChangeLog 889
-MD5 335a6affe9123f0e1ab3e290726f8727 diffstat-1.29.ebuild 782
+MD5 7a6eac8b20ad736c9d8491a031963ebc diffstat-1.29.ebuild 866
+MD5 209bc0fa00306ee9c882fe7237c8f224 ChangeLog 1110
+MD5 606bb7607a9bca7d057c43f5c356e43d files/diffstat-1.29-hard-locale.patch 503
MD5 3b60d99acd06fa78e550d401a9b92877 files/digest-diffstat-1.29 59
diff --git a/dev-util/diffstat/diffstat-1.29.ebuild b/dev-util/diffstat/diffstat-1.29.ebuild
index d27b26e940c1..c09b68777133 100644
--- a/dev-util/diffstat/diffstat-1.29.ebuild
+++ b/dev-util/diffstat/diffstat-1.29.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/diffstat/diffstat-1.29.ebuild,v 1.9 2003/09/14 12:24:53 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/diffstat/diffstat-1.29.ebuild,v 1.10 2003/10/30 12:34:39 brandy Exp $
S=${WORKDIR}/${P}
DESCRIPTION="diffstat reads the output of diff and displays a histogram of the insertions, deletions, and modifications per-file"
@@ -13,8 +13,13 @@ KEYWORDS="x86 sparc ~ppc"
DEPEND="sys-apps/diffutils"
-src_compile() {
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-hard-locale.patch
+}
+src_compile() {
econf || die
export CFLAGS="-Wshadow -Wconversion -Wstrict-prototypes -Wmissing-prototypes ${CFLAGS}"
make || die
diff --git a/dev-util/diffstat/files/diffstat-1.29-hard-locale.patch b/dev-util/diffstat/files/diffstat-1.29-hard-locale.patch
new file mode 100644
index 000000000000..8fd51e9c5439
--- /dev/null
+++ b/dev-util/diffstat/files/diffstat-1.29-hard-locale.patch
@@ -0,0 +1,15 @@
+--- diffstat-1.29/diffstat.old 2003-10-21 22:44:18.325067400 -0700
++++ diffstat-1.29/diffstat.c 2003-10-21 22:46:30.279007352 -0700
+@@ -528,6 +528,12 @@
+ && !version_num(fname)
+ && !contain_any(fname, "*")
+ && !edit_range(fname))
++ || (sscanf(buffer,
++ "*** %[^\t ]\t%d-%d-%d %d:%d:%d",
++ fname,
++ &year, &month, &day,
++ &hour, &minute, &second) == 7
++ && !version_num(fname))
+ ) {
+ s = merge_name(that, fname);
+ that = new_data(s);