summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFederico Ferri <mescalinum@gentoo.org>2009-08-08 02:25:55 +0000
committerFederico Ferri <mescalinum@gentoo.org>2009-08-08 02:25:55 +0000
commitc906d62585b24aa042fee7132ee8849c5e131e63 (patch)
tree1ec3e7d95d5148fbb1a65522dbb4075d441be602 /dev-tcltk/tclxml-expat/tclxml-expat-2.4-r1.ebuild
parentVersion bump, remove old (diff)
downloadhistorical-c906d62585b24aa042fee7132ee8849c5e131e63.tar.gz
historical-c906d62585b24aa042fee7132ee8849c5e131e63.tar.bz2
historical-c906d62585b24aa042fee7132ee8849c5e131e63.zip
bug 253515
Package-Manager: portage-2.2_rc36/cvs/Linux x86_64
Diffstat (limited to 'dev-tcltk/tclxml-expat/tclxml-expat-2.4-r1.ebuild')
-rw-r--r--dev-tcltk/tclxml-expat/tclxml-expat-2.4-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-tcltk/tclxml-expat/tclxml-expat-2.4-r1.ebuild b/dev-tcltk/tclxml-expat/tclxml-expat-2.4-r1.ebuild
new file mode 100644
index 000000000000..18d8377c1fe6
--- /dev/null
+++ b/dev-tcltk/tclxml-expat/tclxml-expat-2.4-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclxml-expat/tclxml-expat-2.4-r1.ebuild,v 1.1 2009/08/08 02:25:55 mescalinum Exp $
+
+inherit eutils
+
+DESCRIPTION="Tcl wrapper libraries for expat XML parser."
+HOMEPAGE="http://tclxml.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tclxml/tclxml-${PV}.tar.gz"
+IUSE=""
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~sparc ~x86"
+
+DEPEND=">=dev-lang/tcl-8.3.3
+ >=dev-libs/expat-1.95.4
+ =dev-tcltk/tclxml-${PV}*"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/tclxml-${PV}/expat
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # bug 253515 - bundles an internal copy of expat
+ pushd ..
+ epatch "${FILESDIR}"/${PN}-no-bundle.patch
+ rm -f "${S}"/xmlparse/xmlparse.[ch] "${S}"/xmltok/xmltok_ns.c \
+ "${S}"/xmltok/xmltok.[ch] "${S}"/xmltok/xmlrole.[ch]
+ popd
+}
+src_compile() {
+ econf --with-tcl=/usr/lib --with-Tclxml=/usr/lib || die
+ make || die
+}
+
+src_install() {
+ einstall || die
+ dohtml expat.html
+}