summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Aniszczyk <zx@gentoo.org>2004-04-05 13:10:46 +0000
committerChris Aniszczyk <zx@gentoo.org>2004-04-05 13:10:46 +0000
commitfb26b699243c6c0759479abb5f2b04f629feadce (patch)
tree1e13a8131d78e960152b97deb266ef83753908b6 /dev-tcltk/snack/snack-2.2.2.ebuild
parentMarked stable on hppa. (diff)
downloadhistorical-fb26b699243c6c0759479abb5f2b04f629feadce.tar.gz
historical-fb26b699243c6c0759479abb5f2b04f629feadce.tar.bz2
historical-fb26b699243c6c0759479abb5f2b04f629feadce.zip
Resurrecting 2.2.2 to fix clean up binge
Diffstat (limited to 'dev-tcltk/snack/snack-2.2.2.ebuild')
-rw-r--r--dev-tcltk/snack/snack-2.2.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-tcltk/snack/snack-2.2.2.ebuild b/dev-tcltk/snack/snack-2.2.2.ebuild
new file mode 100644
index 000000000000..d07a51969200
--- /dev/null
+++ b/dev-tcltk/snack/snack-2.2.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/snack/snack-2.2.2.ebuild,v 1.4 2004/04/05 13:10:46 zx Exp $
+
+IUSE="alsa oggvorbis"
+
+DESCRIPTION="The Snack Sound Toolkit (Tcl)"
+HOMEPAGE="http://www.speech.kth.se/snack/"
+SRC_URI="http://www.speech.kth.se/~kare/${PN}${PV}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~x86"
+SLOT="0"
+
+DEPEND=">dev-lang/tcl-8.0.5
+ >dev-lang/tk-8.0.5
+ oggvorbis? ( media-libs/libogg )"
+
+S=${WORKDIR}/${PN}${PV}/unix
+
+src_compile() {
+ local myconf="--enable-threads"
+
+ use alsa && myconf="${myconf} --enable-alsa"
+
+ use oggvorbis && myconf="${myconf} --enable-ogg"
+
+ econf ${myconf} || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D}usr install || die "make install failed"
+}