summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-04-30 20:19:37 +0000
committerHans de Graaff <graaff@gentoo.org>2010-04-30 20:19:37 +0000
commitc98f5a481d4ca466a923d7668558be0b719945c8 (patch)
tree50499d611d4a64eab00e3da641ad536024aea8ab /dev-ruby
parentAdd patch to fix one issue with Ruby 1.9 (tempfile behaviour); also apply to ... (diff)
downloadhistorical-c98f5a481d4ca466a923d7668558be0b719945c8.tar.gz
historical-c98f5a481d4ca466a923d7668558be0b719945c8.tar.bz2
historical-c98f5a481d4ca466a923d7668558be0b719945c8.zip
Deal with github changing their tarball generation.
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/ffi/ChangeLog6
-rw-r--r--dev-ruby/ffi/ffi-0.6.2.ebuild49
-rw-r--r--dev-ruby/ffi/files/ffi-0.6.2-genRakefile.patch29
-rw-r--r--dev-ruby/i18n/ChangeLog5
-rw-r--r--dev-ruby/i18n/i18n-0.1.3.ebuild5
-rw-r--r--dev-ruby/pdf-inspector/ChangeLog8
-rw-r--r--dev-ruby/pdf-inspector/pdf-inspector-0_pre20081022.ebuild7
7 files changed, 22 insertions, 87 deletions
diff --git a/dev-ruby/ffi/ChangeLog b/dev-ruby/ffi/ChangeLog
index b36163d3435f..4b365197cdbe 100644
--- a/dev-ruby/ffi/ChangeLog
+++ b/dev-ruby/ffi/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/ffi
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ffi/ChangeLog,v 1.5 2010/04/30 20:13:03 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ffi/ChangeLog,v 1.6 2010/04/30 20:14:09 graaff Exp $
+
+ 30 Apr 2010; Hans de Graaff <graaff@gentoo.org> -ffi-0.6.2.ebuild,
+ -files/ffi-0.6.2-genRakefile.patch:
+ Deal with github changing their tarball generation.
*ffi-0.6.3 (30 Apr 2010)
diff --git a/dev-ruby/ffi/ffi-0.6.2.ebuild b/dev-ruby/ffi/ffi-0.6.2.ebuild
deleted file mode 100644
index d9ebe3d30975..000000000000
--- a/dev-ruby/ffi/ffi-0.6.2.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ffi/ffi-0.6.2.ebuild,v 1.1 2010/02/16 11:01:26 flameeyes Exp $
-
-EAPI=2
-
-# jruby → unneeded, this is part of the standard JRuby distribution,
-# and would just install a dummy
-USE_RUBY="ruby18 ruby19"
-
-RUBY_FAKEGEM_TASK_TEST="spec"
-
-RUBY_FAKEGEM_TASK_DOC="doc:rdoc"
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Ruby extension for programmatically loading dynamic libraries"
-HOMEPAGE="http://wiki.github.com/ffi/ffi"
-
-SRC_URI="http://github.com/${PN}/${PN}/tarball/${PV} -> ${PN}-git-${PV}.tgz"
-S="${WORKDIR}/${PN}-${PN}-7abe057"
-
-IUSE=""
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="dev-libs/libffi"
-DEPEND="${RDEPEND}"
-
-ruby_add_bdepend dev-ruby/rake-compiler
-
-all_ruby_prepare() {
- epatch "${FILESDIR}"/${P}-genRakefile.patch
-}
-
-each_ruby_compile() {
- ${RUBY} -S rake compile || die "compile failed"
- ${RUBY} -S rake -f gen/Rakefile || die "types.conf generation failed"
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- docinto examples
- dodoc samples/* || die
-}
diff --git a/dev-ruby/ffi/files/ffi-0.6.2-genRakefile.patch b/dev-ruby/ffi/files/ffi-0.6.2-genRakefile.patch
deleted file mode 100644
index f18eea51aba0..000000000000
--- a/dev-ruby/ffi/files/ffi-0.6.2-genRakefile.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From 1d2ac1eae074af39b447a5bd7fe8a668e60517fd Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Diego=20Elio=20'Flameeyes'=20Petten=C3=B2?= <flameeyes@gmail.com>
-Date: Tue, 16 Feb 2010 11:48:22 +0100
-Subject: [PATCH 1/2] Use the __FILE__ value to find the proper path for the ffi code.
-
-This replace the old code that relied on the RUBYLIBDIR environment
-variable and the position of the current work directory.
----
- gen/Rakefile | 6 ++++--
- 1 files changed, 4 insertions(+), 2 deletions(-)
-
-diff --git a/gen/Rakefile b/gen/Rakefile
-index f97f845..2f5bdb9 100644
---- a/gen/Rakefile
-+++ b/gen/Rakefile
-@@ -1,6 +1,8 @@
- require 'fileutils'
--require "#{File.join(ENV['RUBYLIBDIR'], 'ffi', 'tools', 'types_generator.rb')}"
--types_conf = File.join(ENV['RUBYLIBDIR'], 'ffi', 'types.conf')
-+require 'pathname'
-+require Pathname.new(__FILE__).dirname + "../lib/ffi/tools/types_generator.rb"
-+types_conf = (Pathname.new(__FILE__).dirname + "../lib/ffi/types.conf").to_s
-+
- file types_conf do |task|
- options = {}
- FileUtils.mkdir_p(File.dirname(task.name), { :mode => 0755 })
---
-1.7.0
-
diff --git a/dev-ruby/i18n/ChangeLog b/dev-ruby/i18n/ChangeLog
index 875bb438c8ee..567da1a8a8ce 100644
--- a/dev-ruby/i18n/ChangeLog
+++ b/dev-ruby/i18n/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ruby/i18n
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/i18n/ChangeLog,v 1.9 2010/02/19 17:13:39 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/i18n/ChangeLog,v 1.10 2010/04/30 20:16:28 graaff Exp $
+
+ 30 Apr 2010; Hans de Graaff <graaff@gentoo.org> i18n-0.1.3.ebuild:
+ Deal with github changing their tarball generation.
19 Feb 2010; Fabian Groffen <grobian@gentoo.org> i18n-0.1.3.ebuild:
Marked ~x86-solaris
diff --git a/dev-ruby/i18n/i18n-0.1.3.ebuild b/dev-ruby/i18n/i18n-0.1.3.ebuild
index 5c34227fc61b..d2671930783d 100644
--- a/dev-ruby/i18n/i18n-0.1.3.ebuild
+++ b/dev-ruby/i18n/i18n-0.1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/i18n/i18n-0.1.3.ebuild,v 1.3 2010/02/19 17:13:39 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/i18n/i18n-0.1.3.ebuild,v 1.4 2010/04/30 20:16:28 graaff Exp $
EAPI=2
@@ -19,7 +19,8 @@ HOMEPAGE="http://rails-i18n.org/"
# version 0.1.3, unfortunately there is *no such official release* as
# the one bundled with activesupport. On the other hand, this seems to
# be it, minus some test changes.
-SRC_URI="http://github.com/svenfuchs/i18n/tarball/38d85ea3b8eec032c1b0898a30f8010917416d9d -> ${PN}-git-${PV}.tgz"
+#SRC_URI="http://github.com/svenfuchs/i18n/tarball/38d85ea3b8eec032c1b0898a30f8010917416d9d -> ${PN}-git-${PV}.tgz"
+SRC_URI="mirror://gentoo/${PN}-git-${PV}.tgz"
S="${WORKDIR}/svenfuchs-${PN}-38d85ea"
LICENSE="MIT"
diff --git a/dev-ruby/pdf-inspector/ChangeLog b/dev-ruby/pdf-inspector/ChangeLog
index aa17a2a7c402..27c0c69dceab 100644
--- a/dev-ruby/pdf-inspector/ChangeLog
+++ b/dev-ruby/pdf-inspector/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/pdf-inspector
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pdf-inspector/ChangeLog,v 1.1 2009/07/16 13:07:12 flameeyes Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pdf-inspector/ChangeLog,v 1.2 2010/04/30 20:19:37 graaff Exp $
+
+ 30 Apr 2010; Hans de Graaff <graaff@gentoo.org>
+ pdf-inspector-0_pre20081022.ebuild:
+ Deal with github changing their tarball generation.
*pdf-inspector-0_pre20081022 (16 Jul 2009)
diff --git a/dev-ruby/pdf-inspector/pdf-inspector-0_pre20081022.ebuild b/dev-ruby/pdf-inspector/pdf-inspector-0_pre20081022.ebuild
index b24c48adce45..c5ecc982722e 100644
--- a/dev-ruby/pdf-inspector/pdf-inspector-0_pre20081022.ebuild
+++ b/dev-ruby/pdf-inspector/pdf-inspector-0_pre20081022.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pdf-inspector/pdf-inspector-0_pre20081022.ebuild,v 1.1 2009/07/16 13:07:12 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pdf-inspector/pdf-inspector-0_pre20081022.ebuild,v 1.2 2010/04/30 20:19:37 graaff Exp $
EAPI=2
@@ -17,7 +17,8 @@ SLOT="0"
KEYWORDS="~amd64"
IUSE=""
-SRC_URI="http://github.com/${GITHUB_USER}/${PN}/tarball/${GITHUB_TREE} -> ${P}.tgz"
+#SRC_URI="http://github.com/${GITHUB_USER}/${PN}/tarball/${GITHUB_TREE} -> ${P}.tgz"
+SRC_URI="mirror://gentoo/${P}.tgz"
USE_RUBY="ruby18"