summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-09-18 16:27:08 +0000
committerHans de Graaff <graaff@gentoo.org>2010-09-18 16:27:08 +0000
commit5328fabe31d75f1523781b339ef401bc53a20e25 (patch)
treea846e34bbdab6bf2e27e8b2823c087bbb489aa06 /dev-ruby
parentAdd ~ia64 wrt #337113 (diff)
downloadhistorical-5328fabe31d75f1523781b339ef401bc53a20e25.tar.gz
historical-5328fabe31d75f1523781b339ef401bc53a20e25.tar.bz2
historical-5328fabe31d75f1523781b339ef401bc53a20e25.zip
Version bump.
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/hoe/ChangeLog7
-rw-r--r--dev-ruby/hoe/hoe-2.6.2.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/dev-ruby/hoe/ChangeLog b/dev-ruby/hoe/ChangeLog
index 9be52d339e52..19fd0db1b8a7 100644
--- a/dev-ruby/hoe/ChangeLog
+++ b/dev-ruby/hoe/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/hoe
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe/ChangeLog,v 1.90 2010/09/08 13:08:14 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe/ChangeLog,v 1.91 2010/09/18 16:27:08 graaff Exp $
+
+*hoe-2.6.2 (18 Sep 2010)
+
+ 18 Sep 2010; Hans de Graaff <graaff@gentoo.org> +hoe-2.6.2.ebuild:
+ Version bump.
08 Sep 2010; Christian Faulhammer <fauli@gentoo.org> hoe-2.6.0-r1.ebuild:
stable x86, bug 333947
diff --git a/dev-ruby/hoe/hoe-2.6.2.ebuild b/dev-ruby/hoe/hoe-2.6.2.ebuild
new file mode 100644
index 000000000000..cab83173850f
--- /dev/null
+++ b/dev-ruby/hoe/hoe-2.6.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe/hoe-2.6.2.ebuild,v 1.1 2010/09/18 16:27:08 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.txt Manifest.txt README.txt"
+
+RUBY_FAKEGEM_EXTRAINSTALL="template"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Hoe extends rake to provide full project automation."
+HOMEPAGE="http://seattlerb.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+RUBY_PATCHES=( "${PN}-2.6.1-test-file-ordering.patch" )
+
+# - also requires dev-ruby/hoe-seattlerb for 1.9;
+# - dev-ruby/gemcutter is an optional dependency at both runtime and
+# test-time, at least for us;
+# - rubyforge is loaded at runtime when needed, so we don't strictly
+# depend on it at runtime, but we need it for tests (for now);
+ruby_add_bdepend "test? ( dev-ruby/minitest >=dev-ruby/rubyforge-2.0.4 )"
+
+ruby_add_rdepend ">=dev-ruby/rake-0.8.7"