summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-05-23 22:35:47 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-05-23 22:35:47 +0000
commitfd4f8090d9987d9426546f6acfea02c98edd0c4b (patch)
treeb257c2a2df69f02df1f155a3ed201a7df97cdea6 /dev-ruby/yajl-ruby
parentInitial import in main tree of yajl, needed for yajl-ruby which is in turn op... (diff)
downloadhistorical-fd4f8090d9987d9426546f6acfea02c98edd0c4b.tar.gz
historical-fd4f8090d9987d9426546f6acfea02c98edd0c4b.tar.bz2
historical-fd4f8090d9987d9426546f6acfea02c98edd0c4b.zip
Initial import of the yajl bindings for Ruby, optionally used by the new versions of Rails.
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/yajl-ruby')
-rw-r--r--dev-ruby/yajl-ruby/ChangeLog12
-rw-r--r--dev-ruby/yajl-ruby/Manifest15
-rw-r--r--dev-ruby/yajl-ruby/files/yajl-ruby-0.7.6-gentoo.patch39
-rw-r--r--dev-ruby/yajl-ruby/metadata.xml5
-rw-r--r--dev-ruby/yajl-ruby/yajl-ruby-0.7.6.ebuild42
5 files changed, 113 insertions, 0 deletions
diff --git a/dev-ruby/yajl-ruby/ChangeLog b/dev-ruby/yajl-ruby/ChangeLog
new file mode 100644
index 000000000000..a276e8b75160
--- /dev/null
+++ b/dev-ruby/yajl-ruby/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for dev-ruby/yajl-ruby
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/yajl-ruby/ChangeLog,v 1.1 2010/05/23 22:35:47 flameeyes Exp $
+
+*yajl-ruby-0.7.6 (23 May 2010)
+
+ 23 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +yajl-ruby-0.7.6.ebuild, +files/yajl-ruby-0.7.6-gentoo.patch,
+ +metadata.xml:
+ Initial import of the yajl bindings for Ruby, optionally used by the new
+ versions of Rails.
+
diff --git a/dev-ruby/yajl-ruby/Manifest b/dev-ruby/yajl-ruby/Manifest
new file mode 100644
index 000000000000..5d41fec7d0fa
--- /dev/null
+++ b/dev-ruby/yajl-ruby/Manifest
@@ -0,0 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+AUX yajl-ruby-0.7.6-gentoo.patch 1103 RMD160 cbe85ddc923fa68c7a5d447252bf8d506ea8b306 SHA1 f6776977ce7a7195553ae4da1d8211eaaca3a51b SHA256 2d11ada45308c1aed0a43cb74b471add8c0b3ab1d4f957d2e51fb055ac039cd3
+DIST yajl-ruby-0.7.6.gem 554496 RMD160 6e03e2f20dfa8dedb5529fc708d2c0e034e1ddfe SHA1 71c2ea0285db289d7d7e42597adaff026d589783 SHA256 0e9e2e56b4667f2a02fa3233add0c662b7ecb7cb50c167d09fbb2cc923be3d01
+EBUILD yajl-ruby-0.7.6.ebuild 1000 RMD160 df5162c054c5cbf64650588ca658d1ad8d618728 SHA1 62d444ee268631b01c2be97e9915b1ed7a700abb SHA256 c72e1f81c9dfa41d7c5e83c5af38a34565418a8b546d448310e5921406b8e0b9
+MISC ChangeLog 478 RMD160 335b15fa6e004198609ebbd8aad9d9b66965c4c5 SHA1 4681028ef846e2043ec1cc1a1270cff63dc8e864 SHA256 3ae9baaa0ba312d07379ba9051b5aa3f166e4a3bffa3acd7c5d5ed424b24e966
+MISC metadata.xml 157 RMD160 5d9e2c7ecba96ffebd936d38acedf859cdea84e1 SHA1 8ce15dcc608eeb5616aeec610dc695cbe6f93e02 SHA256 11fba03a217e2d996f5cd8895493a5692ece8ddac2c1a2dfc71d0e830555121c
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.15 (GNU/Linux)
+
+iEYEARECAAYFAkv5rYYACgkQAiZjviIA2XgspgCdGTQoqot306Z7xCebKpRBTZ7y
+a3oAn0JnM2euM14HSvWZ833Ma1wddw4Z
+=Vwz8
+-----END PGP SIGNATURE-----
diff --git a/dev-ruby/yajl-ruby/files/yajl-ruby-0.7.6-gentoo.patch b/dev-ruby/yajl-ruby/files/yajl-ruby-0.7.6-gentoo.patch
new file mode 100644
index 000000000000..75012dc95f26
--- /dev/null
+++ b/dev-ruby/yajl-ruby/files/yajl-ruby-0.7.6-gentoo.patch
@@ -0,0 +1,39 @@
+diff --git a/Rakefile b/Rakefile
+index 2849894..50aba6b 100644
+--- a/Rakefile
++++ b/Rakefile
+@@ -18,6 +18,7 @@ rescue LoadError
+ puts "Jeweler, or one of its dependencies, is not available. Install it with: sudo gem install jeweler -s http://gems.github.com"
+ end
+
++begin
+ require 'rake'
+ require 'spec/rake/spectask'
+
+@@ -33,3 +34,6 @@ Spec::Rake::SpecTask.new('spec') do |t|
+ t.spec_files = FileList['spec/']
+ t.spec_opts << '--options' << 'spec/spec.opts'
+ end
+\ No newline at end of file
++rescue LoadError
++ puts "RSpec, or one of its dependencies, is not available. Install it with: sudo gem install rspec"
++end
+diff --git a/spec/spec_helper.rb b/spec/spec_helper.rb
+index b68e348..952531a 100644
+--- a/spec/spec_helper.rb
++++ b/spec/spec_helper.rb
+@@ -3,5 +3,13 @@ $LOAD_PATH.unshift File.expand_path(File.dirname(__FILE__) + '/../lib')
+
+ require 'rubygems'
+ require 'yajl'
+-require 'active_support/core_ext/kernel/reporting'
+ require 'date'
++
++module Kernel
++ def silence_warnings
++ old_verbose, $VERBOSE = $VERBOSE, nil
++ yield
++ ensure
++ $VERBOSE = old_verbose
++ end
++end
diff --git a/dev-ruby/yajl-ruby/metadata.xml b/dev-ruby/yajl-ruby/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/yajl-ruby/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/yajl-ruby/yajl-ruby-0.7.6.ebuild b/dev-ruby/yajl-ruby/yajl-ruby-0.7.6.ebuild
new file mode 100644
index 000000000000..adbf7a3b1917
--- /dev/null
+++ b/dev-ruby/yajl-ruby/yajl-ruby-0.7.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/yajl-ruby/yajl-ruby-0.7.6.ebuild,v 1.1 2010/05/23 22:35:47 flameeyes Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+# Needs jeweler for documentation building
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby C bindings to the Yajl JSON stream-based parser library"
+HOMEPAGE="http://github.com/brianmario/yajl-ruby"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/yajl"
+DEPEND="${RDEPEND}"
+
+ruby_add_bdepend "test? ( dev-ruby/rspec )"
+
+all_ruby_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake -Cext CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}" || die "make extension failed"
+ cp ext/yajl_ext.so lib || die
+}