summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-08-16 12:21:10 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-08-16 12:21:10 +0000
commit3dbfcbe9f813a662bb8c6c4d63c1574fc66c5991 (patch)
tree9505cbd5b9bf9ffb9144929a26ed22cec6c9aa75 /dev-ruby/uuidtools/uuidtools-2.1.1-r1.ebuild
parentBlock test-unit:2 for testing. (diff)
downloadhistorical-3dbfcbe9f813a662bb8c6c4d63c1574fc66c5991.tar.gz
historical-3dbfcbe9f813a662bb8c6c4d63c1574fc66c5991.tar.bz2
historical-3dbfcbe9f813a662bb8c6c4d63c1574fc66c5991.zip
Fix specs with Ruby 1.9.2 (bug #332973).
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/uuidtools/uuidtools-2.1.1-r1.ebuild')
-rw-r--r--dev-ruby/uuidtools/uuidtools-2.1.1-r1.ebuild14
1 files changed, 12 insertions, 2 deletions
diff --git a/dev-ruby/uuidtools/uuidtools-2.1.1-r1.ebuild b/dev-ruby/uuidtools/uuidtools-2.1.1-r1.ebuild
index 3eb002a79632..0eaa7756bc40 100644
--- a/dev-ruby/uuidtools/uuidtools-2.1.1-r1.ebuild
+++ b/dev-ruby/uuidtools/uuidtools-2.1.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/uuidtools/uuidtools-2.1.1-r1.ebuild,v 1.2 2010/05/22 14:00:07 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/uuidtools/uuidtools-2.1.1-r1.ebuild,v 1.3 2010/08/16 12:21:10 flameeyes Exp $
EAPI=2
@@ -23,4 +23,14 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-ruby_add_bdepend "test? ( >=dev-ruby/rspec-1.0.8 )"
+# Rakefile does not work without rspec (and is quite difficult to work
+# it around).
+ruby_add_bdepend "
+ doc? ( >=dev-ruby/rspec-1.0.8 )
+ test? ( >=dev-ruby/rspec-1.0.8 )"
+
+all_ruby_prepare() {
+ sed -i \
+ -e '1d; 2i require File.expand_path("../../spec_helper.rb", __FILE__)' \
+ "${S}"/spec/uuidtools/*.rb || die
+}