summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-02-19 08:31:12 +0000
committerHans de Graaff <graaff@gentoo.org>2011-02-19 08:31:12 +0000
commitb116ad28dc0d2e194b9c52d9e51a18f2a59a5c84 (patch)
tree0452df37d93b66ec9e09a3823b6ec56fe169cd76 /dev-ruby/ruby_parser
parentVersion bump (diff)
downloadhistorical-b116ad28dc0d2e194b9c52d9e51a18f2a59a5c84.tar.gz
historical-b116ad28dc0d2e194b9c52d9e51a18f2a59a5c84.tar.bz2
historical-b116ad28dc0d2e194b9c52d9e51a18f2a59a5c84.zip
Version bump.
Package-Manager: portage-2.1.9.25/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/ruby_parser')
-rw-r--r--dev-ruby/ruby_parser/ChangeLog7
-rw-r--r--dev-ruby/ruby_parser/ruby_parser-2.0.6.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/dev-ruby/ruby_parser/ChangeLog b/dev-ruby/ruby_parser/ChangeLog
index e3463960bc04..66a3bfa0cfbe 100644
--- a/dev-ruby/ruby_parser/ChangeLog
+++ b/dev-ruby/ruby_parser/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/ruby_parser
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby_parser/ChangeLog,v 1.19 2011/02/17 07:02:02 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby_parser/ChangeLog,v 1.20 2011/02/19 08:31:12 graaff Exp $
+
+*ruby_parser-2.0.6 (19 Feb 2011)
+
+ 19 Feb 2011; Hans de Graaff <graaff@gentoo.org> +ruby_parser-2.0.6.ebuild:
+ Version bump.
17 Feb 2011; Hans de Graaff <graaff@gentoo.org>
-ruby_parser-2.0.4-r1.ebuild:
diff --git a/dev-ruby/ruby_parser/ruby_parser-2.0.6.ebuild b/dev-ruby/ruby_parser/ruby_parser-2.0.6.ebuild
new file mode 100644
index 000000000000..000b7051065f
--- /dev/null
+++ b/dev-ruby/ruby_parser/ruby_parser-2.0.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby_parser/ruby_parser-2.0.6.ebuild,v 1.1 2011/02/19 08:31:12 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18"
+
+# Don't run tests, since they require the testcase from ParseTree;
+# ParseTree _is_ the testcase for ruby_parse
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.txt History.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A ruby parser written in pure ruby."
+HOMEPAGE="http://parsetree.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/sexp-processor-3.0.1"
+ruby_add_bdepend "doc? ( >=dev-ruby/hoe-2.9.1 )"
+
+all_ruby_prepare() {
+ # Remove reference to perforce method that is not in a released
+ # version of hoe-seattlerb.
+ sed -i -e '/perforce/d' Rakefile || die
+}