summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-09-14 18:58:10 +0000
committerHans de Graaff <graaff@gentoo.org>2010-09-14 18:58:10 +0000
commitfabbe84ecaff6239f801f68fb351771ecf0a9231 (patch)
treeb07ccfb18841955965282d8facf0c2e35c074097 /dev-ruby/rdiscount
parentpowerpc patch to not start event scan if scan rate is zero. Linux patch 2.6.34.7 (diff)
downloadhistorical-fabbe84ecaff6239f801f68fb351771ecf0a9231.tar.gz
historical-fabbe84ecaff6239f801f68fb351771ecf0a9231.tar.bz2
historical-fabbe84ecaff6239f801f68fb351771ecf0a9231.zip
Initial import. Dependency of app-text/ronn.
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/rdiscount')
-rw-r--r--dev-ruby/rdiscount/ChangeLog10
-rw-r--r--dev-ruby/rdiscount/metadata.xml5
-rw-r--r--dev-ruby/rdiscount/rdiscount-1.6.5.ebuild48
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-ruby/rdiscount/ChangeLog b/dev-ruby/rdiscount/ChangeLog
new file mode 100644
index 000000000000..639d3e01a7f7
--- /dev/null
+++ b/dev-ruby/rdiscount/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ruby/rdiscount
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rdiscount/ChangeLog,v 1.1 2010/09/14 18:58:10 graaff Exp $
+
+*rdiscount-1.6.5 (14 Sep 2010)
+
+ 14 Sep 2010; Hans de Graaff <graaff@gentoo.org> +rdiscount-1.6.5.ebuild,
+ +metadata.xml:
+ Initial import. Dependency of app-text/ronn.
+
diff --git a/dev-ruby/rdiscount/metadata.xml b/dev-ruby/rdiscount/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/rdiscount/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/rdiscount/rdiscount-1.6.5.ebuild b/dev-ruby/rdiscount/rdiscount-1.6.5.ebuild
new file mode 100644
index 000000000000..0064a4fc7328
--- /dev/null
+++ b/dev-ruby/rdiscount/rdiscount-1.6.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rdiscount/rdiscount-1.6.5.ebuild,v 1.1 2010/09/14 18:58:10 graaff Exp $
+
+EAPI=2
+
+# Has a native extension without jruby support.
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_TEST="test:unit"
+
+RUBY_FAKEGEM_TASK_DOC="doc man"
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Implementation of John Gruber's Markdown"
+HOMEPAGE="http://github.com/rtomayko/rdiscount"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "doc? ( app-text/ronn )"
+
+all_ruby_prepare() {
+ # Hanna is broken for us and therefore we don't have it in portage.
+ sed -i -e 's/hanna/rdoc/' Rakefile || die
+
+ # Remove rule that will force a rebuild when running tests.
+ sed -i -e "/task 'test:unit' => \[:build\]/d" Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext || die
+ cp ext/*$(get_modname) lib/ || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/rdiscount.1
+}