summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-02-20 14:42:37 +0000
committerHans de Graaff <graaff@gentoo.org>2011-02-20 14:42:37 +0000
commit41a8e820d7aefa20f4bdd274427fc697efc944c9 (patch)
tree8fb428d996d20c6aa9356d74d848d24d540ee49f /dev-ruby/i18n
parentMarked ~ppc/~ppc64 wrt #355353 (diff)
downloadhistorical-41a8e820d7aefa20f4bdd274427fc697efc944c9.tar.gz
historical-41a8e820d7aefa20f4bdd274427fc697efc944c9.tar.bz2
historical-41a8e820d7aefa20f4bdd274427fc697efc944c9.zip
Enable tests now that test_declarative is in the tree. Drop keywords due to new dependency, bug 355697.
Package-Manager: portage-2.1.9.25/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/i18n')
-rw-r--r--dev-ruby/i18n/ChangeLog8
-rw-r--r--dev-ruby/i18n/i18n-0.5.0-r1.ebuild75
2 files changed, 82 insertions, 1 deletions
diff --git a/dev-ruby/i18n/ChangeLog b/dev-ruby/i18n/ChangeLog
index d3f665f7bfb4..84ac7682ab4d 100644
--- a/dev-ruby/i18n/ChangeLog
+++ b/dev-ruby/i18n/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/i18n
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/i18n/ChangeLog,v 1.29 2011/01/23 08:40:38 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/i18n/ChangeLog,v 1.30 2011/02/20 14:42:37 graaff Exp $
+
+*i18n-0.5.0-r1 (20 Feb 2011)
+
+ 20 Feb 2011; Hans de Graaff <graaff@gentoo.org> +i18n-0.5.0-r1.ebuild:
+ Enable tests now that test_declarative is in the tree. Drop keywords due
+ to new dependency, bug 355697.
23 Jan 2011; Hans de Graaff <graaff@gentoo.org> i18n-0.4.2.ebuild:
Remove broken blocker on test-unit:2 since this no longer appears to be a
diff --git a/dev-ruby/i18n/i18n-0.5.0-r1.ebuild b/dev-ruby/i18n/i18n-0.5.0-r1.ebuild
new file mode 100644
index 000000000000..106c46eb18b1
--- /dev/null
+++ b/dev-ruby/i18n/i18n-0.5.0-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/i18n/i18n-0.5.0-r1.ebuild,v 1.1 2011/02/20 14:42:37 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 jruby ree18"
+
+# doc regeneration seem to need Jeweler, which is not currently
+# available
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.textile CHANGELOG.textile"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Add Internationalization support to your Ruby application."
+HOMEPAGE="http://rails-i18n.org/"
+
+SRC_URI="http://github.com/svenfuchs/${PN}/tarball/v${PV} -> ${PN}-git-${PV}.tgz"
+S="${WORKDIR}/svenfuchs-${PN}-*"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+# The testsuite uses the activerecord gem to run some tests; they
+# require sqlite3-ruby, and that is not available on JRuby.
+#USE_RUBY="${USE_RUBY/jruby/}" \
+# ruby_add_bdepend "
+# test? (
+# dev-ruby/activerecord
+# dev-ruby/sqlite3-ruby
+# dev-ruby/ruby2ruby
+# )"
+
+# mocha is optionally used by the testsuite, try to increase coverage
+# of testing by depending on it; when mocha is used, though,
+# test-unit:2 cannot be merged at the same time (mocha problem?)
+#
+# One further test dependency would be ruby-cldr
+# (http://rubygems.org/gems/ruby-cldr) but we don't have it in tree
+# yet.
+ruby_add_bdepend "
+ test? (
+ dev-ruby/mocha
+ dev-ruby/test_declarative
+ )"
+
+src_compile() {
+ # permissions need to be stricter for Ruby-Inline to work properly.
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+ ruby-ng_src_compile
+}
+
+src_test() {
+ # permissions need to be stricter for Ruby-Inline to work properly.
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+ ruby-ng_src_test
+}
+
+each_ruby_test() {
+ # Make sure the optional activerecord tests are not run for jruby
+ # because we don't ship a compatible sqlite3
+ case ${RUBY} in
+ *jruby)
+ ;;
+ *)
+ each_fakegem_test
+ esac
+}