summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-02-19 08:31:12 +0000
committerHans de Graaff <graaff@gentoo.org>2011-02-19 08:31:12 +0000
commitb116ad28dc0d2e194b9c52d9e51a18f2a59a5c84 (patch)
tree0452df37d93b66ec9e09a3823b6ec56fe169cd76 /dev-ruby/daemon_controller
parentVersion bump (diff)
downloadhistorical-b116ad28dc0d2e194b9c52d9e51a18f2a59a5c84.tar.gz
historical-b116ad28dc0d2e194b9c52d9e51a18f2a59a5c84.tar.bz2
historical-b116ad28dc0d2e194b9c52d9e51a18f2a59a5c84.zip
Version bump.
Package-Manager: portage-2.1.9.25/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/daemon_controller')
-rw-r--r--dev-ruby/daemon_controller/ChangeLog10
-rw-r--r--dev-ruby/daemon_controller/daemon_controller-0.2.6.ebuild27
2 files changed, 35 insertions, 2 deletions
diff --git a/dev-ruby/daemon_controller/ChangeLog b/dev-ruby/daemon_controller/ChangeLog
index 37a85cdd3969..0dd4aa1a1296 100644
--- a/dev-ruby/daemon_controller/ChangeLog
+++ b/dev-ruby/daemon_controller/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/daemon_controller
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/daemon_controller/ChangeLog,v 1.1 2010/10/25 19:57:19 graaff Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/daemon_controller/ChangeLog,v 1.2 2011/02/19 08:29:08 graaff Exp $
+
+*daemon_controller-0.2.6 (19 Feb 2011)
+
+ 19 Feb 2011; Hans de Graaff <graaff@gentoo.org>
+ +daemon_controller-0.2.6.ebuild:
+ Version bump.
*daemon_controller-0.2.5 (25 Oct 2010)
diff --git a/dev-ruby/daemon_controller/daemon_controller-0.2.6.ebuild b/dev-ruby/daemon_controller/daemon_controller-0.2.6.ebuild
new file mode 100644
index 000000000000..32ce8c5ccd2b
--- /dev/null
+++ b/dev-ruby/daemon_controller/daemon_controller-0.2.6.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/daemon_controller/daemon_controller-0.2.6.ebuild,v 1.1 2011/02/19 08:29:08 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A library for starting and stopping specific daemons programmatically in a robust, race-condition-free manner."
+HOMEPAGE="http://github.com/FooBarWidget/daemon_controller"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/rspec ) "
+
+each_ruby_test() {
+ ${RUBY} -S spec spec || die "Tests failed."
+}