summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-01-17 23:48:49 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-01-17 23:48:49 +0000
commit7c99b42c26b0feee9d12470c181ca7537c4057fb (patch)
tree3787d7871de523903691e8f50a562a3438368f27 /dev-ruby/best_in_place
parentLinux patch version 3.0.15 and 3.0.16 (diff)
downloadhistorical-7c99b42c26b0feee9d12470c181ca7537c4057fb.tar.gz
historical-7c99b42c26b0feee9d12470c181ca7537c4057fb.tar.bz2
historical-7c99b42c26b0feee9d12470c181ca7537c4057fb.zip
Import of best_in_place gem.
Package-Manager: portage-2.2.0_alpha84/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/best_in_place')
-rw-r--r--dev-ruby/best_in_place/ChangeLog11
-rw-r--r--dev-ruby/best_in_place/Manifest15
-rw-r--r--dev-ruby/best_in_place/best_in_place-1.0.4.ebuild61
-rw-r--r--dev-ruby/best_in_place/files/best_in_place-1.0.4-disable-some-tests.patch53
-rw-r--r--dev-ruby/best_in_place/metadata.xml5
5 files changed, 145 insertions, 0 deletions
diff --git a/dev-ruby/best_in_place/ChangeLog b/dev-ruby/best_in_place/ChangeLog
new file mode 100644
index 000000000000..87286d682d43
--- /dev/null
+++ b/dev-ruby/best_in_place/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-ruby/best_in_place
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/best_in_place/ChangeLog,v 1.1 2012/01/17 23:48:49 flameeyes Exp $
+
+*best_in_place-1.0.4 (17 Jan 2012)
+
+ 17 Jan 2012; Diego E. Pettenò <flameeyes@gentoo.org>
+ +best_in_place-1.0.4.ebuild,
+ +files/best_in_place-1.0.4-disable-some-tests.patch, +metadata.xml:
+ Import of best_in_place gem.
+
diff --git a/dev-ruby/best_in_place/Manifest b/dev-ruby/best_in_place/Manifest
new file mode 100644
index 000000000000..d0c0e316818d
--- /dev/null
+++ b/dev-ruby/best_in_place/Manifest
@@ -0,0 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+AUX best_in_place-1.0.4-disable-some-tests.patch 1530 RMD160 a3009b2b93ba55bea298a6c5717def807531e741 SHA1 dc482d0a2b6a54c43a0844d4057b45a301cc3519 SHA256 7e869ed4872a2adb73ffd7a0517b050f4bcf8ce7109dd1d02ad1188bbe1c4e1a
+DIST best_in_place-1.0.4.gem 56832 RMD160 ccb3c88bd989b73c731987d8dbcae6e224edfa56 SHA1 aba5a95e07513c0b75e5297d61a4fff257bae965 SHA256 9abb4c2e3713bb1a4ded74924fbb23ee48e5abcef21adb245b906453bb1b2acd
+EBUILD best_in_place-1.0.4.ebuild 1459 RMD160 aec194ef422aa3b439feaad101250ba99e296d74 SHA1 3a9bd9c4715cfafa28cbcc7bd466bf09279eaa04 SHA256 0e39772da963be661f7ccfdfa520bd958b1e8bdb2abe044400fe4357160e2d37
+MISC ChangeLog 445 RMD160 d47b51af5d485cf0c78ad730a84b5adcb20bf0ad SHA1 80675181d71b30255d8bd5c3c0a1fd1adf3b26e2 SHA256 65e04572f5ae46203af85b04524a243f1cc95990c88d505e5c2a2b8f89ec9abd
+MISC metadata.xml 157 RMD160 5d9e2c7ecba96ffebd936d38acedf859cdea84e1 SHA1 8ce15dcc608eeb5616aeec610dc695cbe6f93e02 SHA256 11fba03a217e2d996f5cd8895493a5692ece8ddac2c1a2dfc71d0e830555121c
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.18 (GNU/Linux)
+
+iEYEARECAAYFAk8WCM4ACgkQAiZjviIA2XjWTQCgsHWu1zI89QthN9f61o1a/6Uk
+DisAn3sJ8lFZ0UmnABsMT1lLLZ2m61DA
+=p3dQ
+-----END PGP SIGNATURE-----
diff --git a/dev-ruby/best_in_place/best_in_place-1.0.4.ebuild b/dev-ruby/best_in_place/best_in_place-1.0.4.ebuild
new file mode 100644
index 000000000000..e3b38367b7d8
--- /dev/null
+++ b/dev-ruby/best_in_place/best_in_place-1.0.4.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/best_in_place/best_in_place-1.0.4.ebuild,v 1.1 2012/01/17 23:48:49 flameeyes Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+# if ever needed
+#GITHUB_USER="bernat"
+#GITHUB_PROJECT="${PN}"
+#RUBY_S="${GITHUB_USER}-${GITHUB_PROJECT}-*"
+
+inherit virtualx ruby-fakegem
+
+DESCRIPTION="In-place editor helper for Rails 3o"
+HOMEPAGE="http://github.com/bernat/best_in_place"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ dev-ruby/rails:3.1
+ dev-ruby/jquery-rails
+"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/rspec-rails
+ >=dev-ruby/nokogiri-1.5.0
+ >=dev-ruby/capybara-1.0.1
+ >=dev-ruby/sqlite3-ruby-1.3.4-r1
+ dev-ruby/rdiscount
+ )"
+
+DEPEND+=" test? ( www-client/firefox )"
+
+all_ruby_prepare() {
+ sed -i \
+ -e '/git ls-files/d' \
+ -e '/rspec-rails/s:,.*::' \
+ ${RUBY_FAKEGEM_GEMSPEC} || die
+ rm test_app/Gemfile.lock
+
+ # this disables two tests that seem to be timing-related
+ # https://github.com/bernat/best_in_place/issues/87
+ epatch "${FILESDIR}"/${P}-disable-some-tests.patch
+}
+
+each_ruby_test() {
+ RAILS_ENV=test ${RUBY} -C test_app -S rake db:migrate || die "test_app migration failed"
+ VIRTUALX_COMMAND="${RUBY}" virtualmake -S rake spec || die "Specs failed"
+}
diff --git a/dev-ruby/best_in_place/files/best_in_place-1.0.4-disable-some-tests.patch b/dev-ruby/best_in_place/files/best_in_place-1.0.4-disable-some-tests.patch
new file mode 100644
index 000000000000..8db8554f4617
--- /dev/null
+++ b/dev-ruby/best_in_place/files/best_in_place-1.0.4-disable-some-tests.patch
@@ -0,0 +1,53 @@
+Index: best_in_place-1.0.4/spec/integration/js_spec.rb
+===================================================================
+--- best_in_place-1.0.4.orig/spec/integration/js_spec.rb
++++ best_in_place-1.0.4/spec/integration/js_spec.rb
+@@ -279,23 +279,6 @@ describe "JS behaviour", :js => true do
+ text.should == "Via Roma 99"
+ end
+ end
+-
+- it "should display the updated content after editing the field two consecutive times" do
+- @user.save!
+- retry_on_timeout do
+- visit user_path(@user)
+-
+- bip_text @user, :address, "New address"
+-
+- id = BestInPlace::Utils.build_best_in_place_id @user, :address
+- page.execute_script <<-JS
+- $("##{id}").click();
+- JS
+-
+- text = page.find("##{id} input").value
+- text.should == "New address"
+- end
+- end
+ end
+
+ describe "display_with" do
+@@ -347,24 +330,6 @@ describe "JS behaviour", :js => true do
+ end
+ end
+
+- it "should display the updated content after editing the field two consecutive times" do
+- @user.save!
+-
+- retry_on_timeout do
+- visit user_path(@user)
+-
+- bip_text @user, :money, "40"
+-
+- id = BestInPlace::Utils.build_best_in_place_id @user, :money
+- page.execute_script <<-JS
+- $("##{id}").click();
+- JS
+-
+- text = page.find("##{id} input").value
+- text.should == "40"
+- end
+- end
+-
+ it "should show the money in euros" do
+ @user.save!
+ visit double_init_user_path(@user)
diff --git a/dev-ruby/best_in_place/metadata.xml b/dev-ruby/best_in_place/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/best_in_place/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>