summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-28 22:12:45 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-28 22:12:45 +0000
commit9688a7eb81f9e337050af4e31f3cc23a11b2ed82 (patch)
tree596f16588a830bf6a129882fb42346cbcaac24e2 /dev-python
parentDelete older ebuilds. (diff)
downloadhistorical-9688a7eb81f9e337050af4e31f3cc23a11b2ed82.tar.gz
historical-9688a7eb81f9e337050af4e31f3cc23a11b2ed82.tar.bz2
historical-9688a7eb81f9e337050af4e31f3cc23a11b2ed82.zip
Delete older ebuild.
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/happydoc/happydoc-3.1.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-python/happydoc/happydoc-3.1.ebuild b/dev-python/happydoc/happydoc-3.1.ebuild
deleted file mode 100644
index 9aa148ee7e07..000000000000
--- a/dev-python/happydoc/happydoc-3.1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/happydoc/happydoc-3.1.ebuild,v 1.2 2010/07/28 21:50:19 arfrever Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit distutils versionator
-
-MY_PN="HappyDoc"
-MY_PV=$(replace_all_version_separators "_" ${PV})
-MY_V=$(get_major_version ${PV})
-
-DESCRIPTION="Tool for extracting documentation from Python source code"
-HOMEPAGE="http://happydoc.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_PN}_r${MY_PV}.tar.gz"
-
-LICENSE="as-is"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
-IUSE="doc"
-
-DEPEND=""
-RDEPEND=""
-
-# Tests need extra data not present in the release tarball.
-RESTRICT="test"
-
-S="${WORKDIR}/${MY_PN}${MY_V}-r${MY_PV}"
-
-PYTHON_MODNAME="happydoclib"
-
-src_prepare() {
- distutils_src_prepare
- cp "${FILESDIR}/${P}-setup.py" setup.py || die "Copying of setup.py failed"
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -r "srcdocs/${MY_PN}${MY_V}-r${MY_PV}"/* || die "Installation of documentation failed"
- fi
-}