summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLukasz Strzygowski <lucass@gentoo.org>2007-01-05 18:57:01 +0000
committerLukasz Strzygowski <lucass@gentoo.org>2007-01-05 18:57:01 +0000
commit839be26bb156dd1dde1da2cac9625dfac42100d7 (patch)
tree7609a8bc2fd02ecb184f9e4e26c421bab1b1f666 /dev-python
parentFix copyright header (diff)
downloadhistorical-839be26bb156dd1dde1da2cac9625dfac42100d7.tar.gz
historical-839be26bb156dd1dde1da2cac9625dfac42100d7.tar.bz2
historical-839be26bb156dd1dde1da2cac9625dfac42100d7.zip
Version bump. Removed older releases.
Package-Manager: portage-2.1.2_rc4
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/urwid/ChangeLog10
-rw-r--r--dev-python/urwid/files/digest-urwid-0.9.7.23
-rw-r--r--dev-python/urwid/urwid-0.9.7.2.ebuild37
3 files changed, 48 insertions, 2 deletions
diff --git a/dev-python/urwid/ChangeLog b/dev-python/urwid/ChangeLog
index 8c75712165b5..6179de89ece9 100644
--- a/dev-python/urwid/ChangeLog
+++ b/dev-python/urwid/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/urwid
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/urwid/ChangeLog,v 1.17 2006/10/04 19:43:51 lucass Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/urwid/ChangeLog,v 1.18 2007/01/05 18:57:01 lucass Exp $
+
+*urwid-0.9.7.2 (05 Jan 2007)
+
+ 05 Jan 2007; Lukasz Strzygowski <lucass@gentoo.org> -urwid-0.9.4.ebuild,
+ -urwid-0.9.5.ebuild, -urwid-0.9.6.ebuild, +urwid-0.9.7.2.ebuild:
+ Version bump. Removed older releases.
*urwid-0.9.7.1 (04 Oct 2006)
diff --git a/dev-python/urwid/files/digest-urwid-0.9.7.2 b/dev-python/urwid/files/digest-urwid-0.9.7.2
new file mode 100644
index 000000000000..e2f6ceaf611b
--- /dev/null
+++ b/dev-python/urwid/files/digest-urwid-0.9.7.2
@@ -0,0 +1,3 @@
+MD5 6e9a64c902389e3ddcfd28f876a383d3 urwid-0.9.7.2.tar.gz 154066
+RMD160 caffac1778b6b4ba6b69c9b83e66556fed91a007 urwid-0.9.7.2.tar.gz 154066
+SHA256 834cbcd01778789a74cbd7f5ac4b1e61dfd25bb760ea89c02448259e81f33b43 urwid-0.9.7.2.tar.gz 154066
diff --git a/dev-python/urwid/urwid-0.9.7.2.ebuild b/dev-python/urwid/urwid-0.9.7.2.ebuild
new file mode 100644
index 000000000000..3ce50c9d9a11
--- /dev/null
+++ b/dev-python/urwid/urwid-0.9.7.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/urwid/urwid-0.9.7.2.ebuild,v 1.1 2007/01/05 18:57:01 lucass Exp $
+
+inherit distutils eutils
+
+DESCRIPTION="Urwid is a curses-based user interface library for Python."
+HOMEPAGE="http://excess.org/urwid/"
+SRC_URI="http://excess.org/urwid/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+IUSE="examples"
+DEPEND="virtual/python"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-0.9.6-nosetuptools.diff"
+}
+
+src_test() {
+ ${python} test_urwid.py || die "unit tests failed"
+}
+
+src_install() {
+ distutils_src_install
+
+ dohtml tutorial.html reference.html
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins bigtext.py browse.py calc.py dialog.py edit.py
+ doins fib.py graph.py input_test.py tour.py
+ fi
+}