summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2006-02-13 23:08:28 +0000
committerMarien Zwart <marienz@gentoo.org>2006-02-13 23:08:28 +0000
commit6624edbeb1d9e6643d1debb252f76e645eb0c02b (patch)
tree6f1341acbd6c1d8c245c6c2155f9b434525353b5 /dev-python
parentDo not pass -R to trial (deprecated in 2.1, removed in 2.2). (diff)
downloadhistorical-6624edbeb1d9e6643d1debb252f76e645eb0c02b.tar.gz
historical-6624edbeb1d9e6643d1debb252f76e645eb0c02b.tar.bz2
historical-6624edbeb1d9e6643d1debb252f76e645eb0c02b.zip
Version bump.
Package-Manager: portage-2660-svn
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/twisted/ChangeLog7
-rw-r--r--dev-python/twisted/Manifest10
-rw-r--r--dev-python/twisted/files/digest-twisted-2.2.03
-rw-r--r--dev-python/twisted/twisted-2.2.0.ebuild102
4 files changed, 121 insertions, 1 deletions
diff --git a/dev-python/twisted/ChangeLog b/dev-python/twisted/ChangeLog
index a3239d594ec3..e8f3754a60d6 100644
--- a/dev-python/twisted/ChangeLog
+++ b/dev-python/twisted/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/twisted
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.59 2006/02/06 03:04:29 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.60 2006/02/13 23:08:28 marienz Exp $
+
+*twisted-2.2.0 (13 Feb 2006)
+
+ 13 Feb 2006; Marien Zwart <marienz@gentoo.org> +twisted-2.2.0.ebuild:
+ Version bump.
06 Feb 2006; Aron Griffis <agriffis@gentoo.org> twisted-1.3.0.ebuild:
Mark 1.3.0 stable on alpha
diff --git a/dev-python/twisted/Manifest b/dev-python/twisted/Manifest
index ca7323afd0bb..d6326c085c1e 100644
--- a/dev-python/twisted/Manifest
+++ b/dev-python/twisted/Manifest
@@ -1,3 +1,6 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 6435f88cf2c7b0f4ff0759033ed38d2b ChangeLog 11618
RMD160 3b748fe02b8a6d2c88cc88382176678b43677246 ChangeLog 11618
SHA256 a81f3ef9e6ffcd6c6b28d4f28e2318edf16e5e0d40505dfe6eaf1835506cab56 ChangeLog 11618
@@ -49,3 +52,10 @@ SHA256 46ad17bb5d27d534e9b5d5d43c24c4840e6e987dac5fbee4d2547f497e87582a twisted-
MD5 94b317c8c9eb5bce018d9fcc489da417 twisted-2.2.0.ebuild 2959
RMD160 fd9faa5358aa4aad026d191ff55966943dd2a47b twisted-2.2.0.ebuild 2959
SHA256 da5a068fb4372619a497953f3129b1b097b0cbf365cc3231e6549d23af0b7ee4 twisted-2.2.0.ebuild 2959
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFD8RF3W78445TWHXcRAqY4AKCP3M5fonsnp0Dwfiu9ZfPVbnGSuwCgm9BV
+jQcc982fEtozZ0VeOPPFjTk=
+=733h
+-----END PGP SIGNATURE-----
diff --git a/dev-python/twisted/files/digest-twisted-2.2.0 b/dev-python/twisted/files/digest-twisted-2.2.0
new file mode 100644
index 000000000000..12337b77cc2b
--- /dev/null
+++ b/dev-python/twisted/files/digest-twisted-2.2.0
@@ -0,0 +1,3 @@
+MD5 4a9305e69cdcf01a594c4fe1ea1efc05 Twisted-2.2.0.tar.bz2 1285316
+RMD160 c11353da93878721c8549a0594363b9d8ee38e12 Twisted-2.2.0.tar.bz2 1285316
+SHA256 537ec738c23ced2ec4a9b7f7124c2cd9bded1308331442ced0f3de7cd7562387 Twisted-2.2.0.tar.bz2 1285316
diff --git a/dev-python/twisted/twisted-2.2.0.ebuild b/dev-python/twisted/twisted-2.2.0.ebuild
new file mode 100644
index 000000000000..84f4f8debe94
--- /dev/null
+++ b/dev-python/twisted/twisted-2.2.0.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-2.2.0.ebuild,v 1.1 2006/02/13 23:08:28 marienz Exp $
+
+inherit eutils distutils versionator
+
+MY_P=Twisted-${PV}
+
+DESCRIPTION="An asynchronous networking framework written in Python"
+HOMEPAGE="http://www.twistedmatrix.com/"
+SRC_URI="http://tmrc.mit.edu/mirror/twisted/Twisted/$(get_version_component_range 1-2)/${MY_P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sh ~sparc ~x86"
+IUSE="gtk serial crypt"
+
+DEPEND=">=dev-lang/python-2.2
+ >=net-zope/zopeinterface-3.0.1
+ serial? ( dev-python/pyserial )
+ crypt? ( >=dev-python/pyopenssl-0.5.1 )
+ gtk? ( >=dev-python/pygtk-1.99 )"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="CREDITS INSTALL NEWS README"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-2.1.0-zsh-head.patch"
+}
+
+src_install() {
+ distutils_src_install
+
+ # get rid of this to prevent collision-protect from killing us. it
+ # is regenerated in pkg_postinst.
+ rm "${D}/usr/$(get_libdir)"/python*/site-packages/twisted/plugins/dropin.cache
+
+ # weird pattern to avoid installing the index.xhtml page
+ doman doc/man/*.?
+ insinto /usr/share/doc/${PF}
+ doins -r $(find doc -mindepth 1 -maxdepth 1 -not -name man)
+
+ # workaround for a possible portage bug
+ mkdir -p "${D}/etc/conf.d/"
+ newconfd "${FILESDIR}/twistd.conf" twistd
+ newinitd "${FILESDIR}/twistd.init" twistd
+
+ # zsh completion
+ insinto /usr/share/zsh/site-functions/
+ doins twisted/python/_twisted_zsh_stub
+}
+
+update_plugin_cache() {
+ python_version
+ local tpath="${ROOT}usr/$(get_libdir)/python${PYVER}/site-packages/twisted"
+ # we have to remove the cache or removed plugins won't be removed
+ # from the cache (http://twistedmatrix.com/bugs/issue926)
+ [[ -e "${tpath}/plugins/dropin.cache" ]] && rm -f "${tpath}/plugins/dropin.cache"
+ if [[ -e "${tpath}/plugin.py" ]]; then
+ # twisted is still installed, update.
+ # we have to use getPlugIns here for <=twisted-2.0.1 compatibility
+ einfo "Regenerating plugin cache"
+ python -c "from twisted.plugin import IPlugin, getPlugIns;list(getPlugIns(IPlugin))"
+ fi
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ update_plugin_cache
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+ update_plugin_cache
+}
+
+src_test() {
+ python_version
+
+ if has_version ">=dev-lang/python-2.3"; then
+ "${python}" setup.py install --root="${T}/tests" --no-compile || die
+ else
+ "${python}" setup.py install --root="${T}/tests" || die
+ fi
+
+ cd "${T}/tests/usr/$(get_libdir)/python${PYVER}/site-packages/" || die
+
+ # prevent it from pulling in plugins from already installed
+ # twisted packages
+ rm twisted/plugins/__init__.py || die
+
+ # an empty file doesn't work because the tests check for
+ # docstrings in all packages
+ echo "'''plugins stub'''" > twisted/plugins/__init__.py || die
+
+ "${T}"/tests/usr/bin/trial twisted || die "trial failed"
+ cd "${S}"
+ rm -rf "${T}/tests"
+}