summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-03 17:35:31 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-03 17:35:31 +0000
commit39014bd0c436abaa7fb66b73770b04633808622d (patch)
treea3e5d7ad2e11925aa3d3bef2dd4a37c77027ec35 /dev-python
parentFix use invocation (diff)
downloadhistorical-39014bd0c436abaa7fb66b73770b04633808622d.tar.gz
historical-39014bd0c436abaa7fb66b73770b04633808622d.tar.bz2
historical-39014bd0c436abaa7fb66b73770b04633808622d.zip
Fix use invocation
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/gnome-python/ChangeLog6
-rw-r--r--dev-python/gnome-python/gnome-python-1.4.2.ebuild6
-rw-r--r--dev-python/gnome-python/gnome-python-1.4.4.ebuild6
-rw-r--r--dev-python/pyOpenSSL/ChangeLog5
-rw-r--r--dev-python/pyOpenSSL/pyOpenSSL-0.5.1.ebuild6
-rw-r--r--dev-python/pythong/ChangeLog6
-rw-r--r--dev-python/pythong/pythong-2.1.2.ebuild4
-rw-r--r--dev-python/pythong/pythong-2.1.4.ebuild4
-rw-r--r--dev-python/pythong/pythong-2.1.5.ebuild4
-rw-r--r--dev-python/twisted/ChangeLog7
-rw-r--r--dev-python/twisted/twisted-1.1.0.ebuild4
-rw-r--r--dev-python/twisted/twisted-1.1.1.ebuild4
-rw-r--r--dev-python/twisted/twisted-1.2.0.ebuild4
-rw-r--r--dev-python/twisted/twisted-1.2.1_alpha2.ebuild4
-rw-r--r--dev-python/twisted/twisted-1.3.0.ebuild4
-rw-r--r--dev-python/wxPython/ChangeLog6
-rw-r--r--dev-python/wxPython/wxPython-2.4.0.7.ebuild12
-rw-r--r--dev-python/wxPython/wxPython-2.4.1.2.ebuild4
-rw-r--r--dev-python/wxPython/wxPython-2.4.2.4.ebuild6
19 files changed, 61 insertions, 41 deletions
diff --git a/dev-python/gnome-python/ChangeLog b/dev-python/gnome-python/ChangeLog
index 07c35826d891..0711fefbcb91 100644
--- a/dev-python/gnome-python/ChangeLog
+++ b/dev-python/gnome-python/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/gnome-python
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python/ChangeLog,v 1.32 2004/05/04 11:18:25 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python/ChangeLog,v 1.33 2004/06/03 17:26:48 agriffis Exp $
+
+ 03 Jun 2004; Aron Griffis <agriffis@gentoo.org> gnome-python-1.4.2.ebuild,
+ gnome-python-1.4.4.ebuild:
+ Fix use invocation
04 May 2004; Bryan Østergaard <kloeri@gentoo.org> gnome-python-1.4.2.ebuild,
gnome-python-1.4.4.ebuild:
diff --git a/dev-python/gnome-python/gnome-python-1.4.2.ebuild b/dev-python/gnome-python/gnome-python-1.4.2.ebuild
index d62b2a640491..fde20ca515b2 100644
--- a/dev-python/gnome-python/gnome-python-1.4.2.ebuild
+++ b/dev-python/gnome-python/gnome-python-1.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python/gnome-python-1.4.2.ebuild,v 1.15 2004/05/04 11:18:25 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python/gnome-python-1.4.2.ebuild,v 1.16 2004/06/03 17:26:48 agriffis Exp $
IUSE="gnome opengl"
@@ -21,7 +21,7 @@ KEYWORDS="x86 ppc sparc alpha"
LICENSE="GPL-2"
src_compile() {
- if [ -n "`use gnome`" ]
+ if use gnome
then
CFLAGS="${CFLAGS} `gnome-config capplet --cflags`" \
econf ${myopts} || die
@@ -34,7 +34,7 @@ src_compile() {
src_install() {
- if [ -n "`use gnome`" ]
+ if use gnome
then
cd ${S}/pygnome
make prefix=${D}/usr datadir=${D}/usr/share install || die
diff --git a/dev-python/gnome-python/gnome-python-1.4.4.ebuild b/dev-python/gnome-python/gnome-python-1.4.4.ebuild
index 1033d0b66315..66b482e9fcf4 100644
--- a/dev-python/gnome-python/gnome-python-1.4.4.ebuild
+++ b/dev-python/gnome-python/gnome-python-1.4.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python/gnome-python-1.4.4.ebuild,v 1.9 2004/05/04 11:18:25 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python/gnome-python-1.4.4.ebuild,v 1.10 2004/06/03 17:26:48 agriffis Exp $
inherit gnome.org
@@ -22,7 +22,7 @@ DEPEND="virtual/python
opengl? ( <x11-libs/gtkglarea-1.99.0 )"
src_compile() {
- if [ -n "`use gnome`" ]
+ if use gnome
then
CFLAGS="${CFLAGS} `gnome-config capplet --cflags`" \
econf ${myopts} || die
@@ -35,7 +35,7 @@ src_compile() {
src_install() {
- if [ -n "`use gnome`" ]
+ if use gnome
then
cd ${S}/pygnome
make prefix=${D}/usr datadir=${D}/usr/share install || die
diff --git a/dev-python/pyOpenSSL/ChangeLog b/dev-python/pyOpenSSL/ChangeLog
index 1a7347e3618b..3242b754fefb 100644
--- a/dev-python/pyOpenSSL/ChangeLog
+++ b/dev-python/pyOpenSSL/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/pyOpenSSL
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyOpenSSL/ChangeLog,v 1.9 2004/06/02 21:32:42 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyOpenSSL/ChangeLog,v 1.10 2004/06/03 17:27:55 agriffis Exp $
+
+ 03 Jun 2004; Aron Griffis <agriffis@gentoo.org> pyOpenSSL-0.5.1.ebuild:
+ Fix use invocation
02 Jun 2004; Bryan Østergaard <kloeri@gentoo.org> pyOpenSSL-0.5.1.ebuild:
Stable on alpha.
diff --git a/dev-python/pyOpenSSL/pyOpenSSL-0.5.1.ebuild b/dev-python/pyOpenSSL/pyOpenSSL-0.5.1.ebuild
index 63f33a70a592..29f5d9511590 100644
--- a/dev-python/pyOpenSSL/pyOpenSSL-0.5.1.ebuild
+++ b/dev-python/pyOpenSSL/pyOpenSSL-0.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyOpenSSL/pyOpenSSL-0.5.1.ebuild,v 1.15 2004/06/02 21:32:42 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyOpenSSL/pyOpenSSL-0.5.1.ebuild,v 1.16 2004/06/03 17:27:55 agriffis Exp $
inherit distutils
@@ -20,7 +20,7 @@ DEPEND="${RDEPEND}
src_compile() {
distutils_src_compile
- if [ "`use tetex`" ] ; then
+ if use tetex ; then
addwrite /var/cache/fonts
cd ${S}/doc
make html ps dvi
@@ -30,7 +30,7 @@ src_compile() {
src_install() {
distutils_src_install
- if [ "`use tetex`" ] ; then
+ if use tetex ; then
dohtml ${S}/doc/html/*
dodoc ${S}/doc/pyOpenSSL.*
fi
diff --git a/dev-python/pythong/ChangeLog b/dev-python/pythong/ChangeLog
index c12fa0c3757e..edb9decdbf1f 100644
--- a/dev-python/pythong/ChangeLog
+++ b/dev-python/pythong/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pythong
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pythong/ChangeLog,v 1.8 2004/03/28 11:55:22 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pythong/ChangeLog,v 1.9 2004/06/03 17:25:17 agriffis Exp $
+
+ 03 Jun 2004; Aron Griffis <agriffis@gentoo.org> pythong-2.1.2.ebuild,
+ pythong-2.1.4.ebuild, pythong-2.1.5.ebuild:
+ Fix use invocation
28 Mar 2004; Bryan Østergaard <kloeri@gentoo.org> pythong-2.1.2.ebuild,
pythong-2.1.4.ebuild:
diff --git a/dev-python/pythong/pythong-2.1.2.ebuild b/dev-python/pythong/pythong-2.1.2.ebuild
index 754ffdc7452c..97aba7527f2b 100644
--- a/dev-python/pythong/pythong-2.1.2.ebuild
+++ b/dev-python/pythong/pythong-2.1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pythong/pythong-2.1.2.ebuild,v 1.3 2004/03/28 11:55:22 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pythong/pythong-2.1.2.ebuild,v 1.4 2004/06/03 17:25:17 agriffis Exp $
inherit python distutils
@@ -51,7 +51,7 @@ src_install() {
cp -r ${S}/{LICENCIA,MANUAL,demos} ${D}/usr/share/doc/${PF}
rm -f ${D}/usr/share/doc/${PF}/demos/modulepythong.py
- if [ -n "`use doc`" ]; then
+ if use doc; then
insinto /usr/share/doc/${PF}
doins ${DISTDIR}/python.pdf
fi
diff --git a/dev-python/pythong/pythong-2.1.4.ebuild b/dev-python/pythong/pythong-2.1.4.ebuild
index 285f28d11abd..0f8b5476688e 100644
--- a/dev-python/pythong/pythong-2.1.4.ebuild
+++ b/dev-python/pythong/pythong-2.1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pythong/pythong-2.1.4.ebuild,v 1.2 2004/03/28 11:55:22 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pythong/pythong-2.1.4.ebuild,v 1.3 2004/06/03 17:25:17 agriffis Exp $
inherit python distutils
@@ -51,7 +51,7 @@ src_install() {
cp -r ${S}/{LICENCIA,MANUAL,demos} ${D}/usr/share/doc/${PF}
rm -f ${D}/usr/share/doc/${PF}/demos/modulepythong.py
- if [ -n "`use doc`" ]; then
+ if use doc; then
insinto /usr/share/doc/${PF}
doins ${DISTDIR}/python.pdf
fi
diff --git a/dev-python/pythong/pythong-2.1.5.ebuild b/dev-python/pythong/pythong-2.1.5.ebuild
index 0d6d3a9a8ced..a8e6b47369d0 100644
--- a/dev-python/pythong/pythong-2.1.5.ebuild
+++ b/dev-python/pythong/pythong-2.1.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pythong/pythong-2.1.5.ebuild,v 1.2 2004/01/25 02:31:43 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pythong/pythong-2.1.5.ebuild,v 1.3 2004/06/03 17:25:17 agriffis Exp $
inherit python distutils
@@ -56,7 +56,7 @@ src_install() {
cp -r ${S}/{LICENCIA,MANUAL,demos} ${D}/usr/share/doc/${PF}
rm -f ${D}/usr/share/doc/${PF}/demos/modulepythong.py
- if [ -n "`use doc`" ]; then
+ if use doc; then
insinto /usr/share/doc/${PF}
doins ${DISTDIR}/python.pdf
fi
diff --git a/dev-python/twisted/ChangeLog b/dev-python/twisted/ChangeLog
index a11fd87ba0f4..5d48ab5ed2af 100644
--- a/dev-python/twisted/ChangeLog
+++ b/dev-python/twisted/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/twisted
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.35 2004/05/19 20:39:26 lordvan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.36 2004/06/03 17:35:31 agriffis Exp $
+
+ 03 Jun 2004; Aron Griffis <agriffis@gentoo.org> twisted-1.1.0.ebuild,
+ twisted-1.1.1.ebuild, twisted-1.2.0.ebuild, twisted-1.2.1_alpha2.ebuild,
+ twisted-1.3.0.ebuild:
+ Fix use invocation
*twisted-1.3.0 (19 May 2004)
diff --git a/dev-python/twisted/twisted-1.1.0.ebuild b/dev-python/twisted/twisted-1.1.0.ebuild
index 07ca6153f4b8..6a177e2451e0 100644
--- a/dev-python/twisted/twisted-1.1.0.ebuild
+++ b/dev-python/twisted/twisted-1.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-1.1.0.ebuild,v 1.7 2004/03/06 08:38:11 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-1.1.0.ebuild,v 1.8 2004/06/03 17:35:31 agriffis Exp $
inherit distutils
@@ -24,7 +24,7 @@ src_install() {
distutils_src_install
# use gtk2 if they so wish
- if [ -n "`use gtk2`" ]; then
+ if use gtk2; then
sed -e 's/import manhole/import manhole2/' \
-e 's/manhole\.run()/manhole2.run()/' \
-i ${D}/usr/bin/manhole
diff --git a/dev-python/twisted/twisted-1.1.1.ebuild b/dev-python/twisted/twisted-1.1.1.ebuild
index b834271b3688..2727f112a0ea 100644
--- a/dev-python/twisted/twisted-1.1.1.ebuild
+++ b/dev-python/twisted/twisted-1.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-1.1.1.ebuild,v 1.5 2004/03/06 08:38:11 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-1.1.1.ebuild,v 1.6 2004/06/03 17:35:31 agriffis Exp $
inherit distutils
@@ -26,7 +26,7 @@ src_install() {
distutils_src_install
# use gtk2 if they so wish
- if [ -n "`use gtk2`" ]; then
+ if use gtk2; then
sed -e 's/import manhole/import manhole2/' \
-e 's/manhole\.run()/manhole2.run()/' \
-i ${D}/usr/bin/manhole
diff --git a/dev-python/twisted/twisted-1.2.0.ebuild b/dev-python/twisted/twisted-1.2.0.ebuild
index 12349a9a490c..1c2600dd4348 100644
--- a/dev-python/twisted/twisted-1.2.0.ebuild
+++ b/dev-python/twisted/twisted-1.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-1.2.0.ebuild,v 1.5 2004/05/06 17:50:37 lordvan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-1.2.0.ebuild,v 1.6 2004/06/03 17:35:31 agriffis Exp $
inherit distutils
@@ -26,7 +26,7 @@ src_install() {
distutils_src_install
# use gtk2 if they so wish
- if [ -n "`use gtk2`" ]; then
+ if use gtk2; then
sed -e 's/import manhole/import manhole2/' \
-e 's/manhole\.run()/manhole2.run()/' \
-i ${D}/usr/bin/manhole
diff --git a/dev-python/twisted/twisted-1.2.1_alpha2.ebuild b/dev-python/twisted/twisted-1.2.1_alpha2.ebuild
index 23447cb4dffc..b5ef54e01eca 100644
--- a/dev-python/twisted/twisted-1.2.1_alpha2.ebuild
+++ b/dev-python/twisted/twisted-1.2.1_alpha2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-1.2.1_alpha2.ebuild,v 1.1 2004/05/06 17:50:37 lordvan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-1.2.1_alpha2.ebuild,v 1.2 2004/06/03 17:35:31 agriffis Exp $
inherit distutils
@@ -28,7 +28,7 @@ src_install() {
distutils_src_install
# use gtk2 if they so wish
- if [ -n "`use gtk2`" ]; then
+ if use gtk2; then
sed -e 's/import manhole/import manhole2/' \
-e 's/manhole\.run()/manhole2.run()/' \
-i ${D}/usr/bin/manhole
diff --git a/dev-python/twisted/twisted-1.3.0.ebuild b/dev-python/twisted/twisted-1.3.0.ebuild
index 87b0a7db4e16..8520eebdbf66 100644
--- a/dev-python/twisted/twisted-1.3.0.ebuild
+++ b/dev-python/twisted/twisted-1.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-1.3.0.ebuild,v 1.1 2004/05/19 20:39:26 lordvan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-1.3.0.ebuild,v 1.2 2004/06/03 17:35:31 agriffis Exp $
inherit distutils
@@ -28,7 +28,7 @@ src_install() {
distutils_src_install
# use gtk2 if they so wish
- if [ -n "`use gtk2`" ]; then
+ if use gtk2; then
sed -e 's/import manhole/import manhole2/' \
-e 's/manhole\.run()/manhole2.run()/' \
-i ${D}/usr/bin/manhole
diff --git a/dev-python/wxPython/ChangeLog b/dev-python/wxPython/ChangeLog
index 48ba87adcf0a..1ba448167841 100644
--- a/dev-python/wxPython/ChangeLog
+++ b/dev-python/wxPython/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/wxPython
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxPython/ChangeLog,v 1.39 2004/03/25 08:17:19 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxPython/ChangeLog,v 1.40 2004/06/03 17:31:45 agriffis Exp $
+
+ 03 Jun 2004; Aron Griffis <agriffis@gentoo.org> wxPython-2.4.0.7.ebuild,
+ wxPython-2.4.1.2.ebuild, wxPython-2.4.2.4.ebuild:
+ Fix use invocation
25 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org>
wxPython-2.4.0.7.ebuild:
diff --git a/dev-python/wxPython/wxPython-2.4.0.7.ebuild b/dev-python/wxPython/wxPython-2.4.0.7.ebuild
index 267e6c8067e1..0f42def3c6e4 100644
--- a/dev-python/wxPython/wxPython-2.4.0.7.ebuild
+++ b/dev-python/wxPython/wxPython-2.4.0.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxPython/wxPython-2.4.0.7.ebuild,v 1.10 2004/03/25 08:17:19 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxPython/wxPython-2.4.0.7.ebuild,v 1.11 2004/06/03 17:31:45 agriffis Exp $
IUSE="opengl gtk2"
@@ -30,7 +30,7 @@ pkg_setup() {
rm -f /usr/X11R6/include/{zconf.h,zlib.h}
# make sure if you want gtk2, you have wxGTK with gtk2, and vice versa
- if [ -n "`use gtk2`" ]; then
+ if use gtk2; then
if [ ! -f "/usr/bin/wxgtk2u-2.4-config" -a ! -f "/usr/bin/wxgtk2-2.4-config" ]; then
eerror "You need x11-libs/wxGTK compiled with GTK+2 support."
eerror "Either emerge wxGTK with 'gtk2' in your USE flags or"
@@ -59,13 +59,13 @@ src_compile() {
#Both these variable are enabled by default. To disable them set equal to zero
#and add to myconf.
local myconf=""
- if [ `use opengl` ]; then
+ if use opengl; then
myconf="${myconf} BUILD_GLCANVAS=1"
else
myconf="${myconf} BUILD_GLCANVAS=0"
fi
- if [ `use gtk2` ]; then
+ if use gtk2; then
myconf="${myconf} WXPORT=gtk2"
else
myconf="${myconf} WXPORT=gtk"
@@ -81,12 +81,12 @@ src_install() {
#Both these variable are enabled by default. To disable them set equal to zero
#and add to myconf.
local myconf=""
- if [ `use opengl` ]; then
+ if use opengl; then
myconf="${myconf} BUILD_GLCANVAS=1"
else
myconf="${myconf} BUILD_GLCANVAS=0"
fi
- if [ `use gtk2` ]; then
+ if use gtk2; then
myconf="${myconf} WXPORT=gtk2"
else
myconf="${myconf} WXPORT=gtk"
diff --git a/dev-python/wxPython/wxPython-2.4.1.2.ebuild b/dev-python/wxPython/wxPython-2.4.1.2.ebuild
index 37d997191b79..d52b67f25ee5 100644
--- a/dev-python/wxPython/wxPython-2.4.1.2.ebuild
+++ b/dev-python/wxPython/wxPython-2.4.1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxPython/wxPython-2.4.1.2.ebuild,v 1.11 2004/02/17 22:02:26 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxPython/wxPython-2.4.1.2.ebuild,v 1.12 2004/06/03 17:31:45 agriffis Exp $
inherit eutils
@@ -34,7 +34,7 @@ DEPEND="${RDEPEND}
pkg_setup() {
# make sure if you want gtk2, you have wxGTK with gtk2, and vice versa
- if [ -n "`use gtk2`" ]; then
+ if use gtk2; then
if [ ! -f "/usr/bin/wxgtk2u-2.4-config" -a ! -f "/usr/bin/wxgtk2-2.4-config" ]; then
eerror "You need x11-libs/wxGTK compiled with GTK+2 support."
eerror "Either emerge wxGTK with 'gtk2' in your USE flags or"
diff --git a/dev-python/wxPython/wxPython-2.4.2.4.ebuild b/dev-python/wxPython/wxPython-2.4.2.4.ebuild
index 8192576b1b4e..58be7b5d2db9 100644
--- a/dev-python/wxPython/wxPython-2.4.2.4.ebuild
+++ b/dev-python/wxPython/wxPython-2.4.2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxPython/wxPython-2.4.2.4.ebuild,v 1.9 2004/02/17 22:02:26 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxPython/wxPython-2.4.2.4.ebuild,v 1.10 2004/06/03 17:31:45 agriffis Exp $
inherit eutils
@@ -34,7 +34,7 @@ DEPEND="${RDEPEND}
pkg_setup() {
# make sure if you want gtk2, you have wxGTK with gtk2, and vice versa
- if [ -n "`use gtk2`" ]; then
+ if use gtk2; then
if [ ! -f "/usr/bin/wxgtk2u-2.4-config" -a ! -f "/usr/bin/wxgtk2ud-2.4-config" -a ! -f "/usr/bin/wxgtk2-2.4-config" -a ! -f "/usr/bin/wxgtk2d-2.4-config" ]; then
eerror "You need x11-libs/wxGTK compiled with GTK+2 support."
eerror "Either emerge wxGTK with 'gtk2' in your USE flags or"
@@ -51,7 +51,7 @@ pkg_setup() {
fi
# make sure that wxPython and wxGTK have same unicode setting:
- if [ -n "`use unicode`" ]; then
+ if use unicode; then
if [ ! -f "/usr/bin/wxgtk2u-2.4-config" -a ! -f "/usr/bin/wxgtk2ud-2.4-config" ]; then
eerror "You need x11-libs/wxGTK compiled with Unicode support."
eerror "Either emerge wxGTK with 'unicode' in your USE flags or"