summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-08 20:23:27 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-08 20:23:27 +0000
commit3188d96dc25a1c8254b7bb56e62c3db5b78cf3e4 (patch)
tree0b2fa5dacece05dff92c80ffe28d33065a17970e /dev-python
parentppc stable #291689 (diff)
downloadhistorical-3188d96dc25a1c8254b7bb56e62c3db5b78cf3e4.tar.gz
historical-3188d96dc25a1c8254b7bb56e62c3db5b78cf3e4.tar.bz2
historical-3188d96dc25a1c8254b7bb56e62c3db5b78cf3e4.zip
Delete older ebuilds.
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/matplotlib/files/matplotlib-0.91.2-gcc43.patch10
-rw-r--r--dev-python/matplotlib/files/matplotlib-0.98.5.2-literal.patch11
-rw-r--r--dev-python/matplotlib/matplotlib-0.91.2.ebuild116
-rw-r--r--dev-python/matplotlib/matplotlib-0.91.4.ebuild117
-rw-r--r--dev-python/matplotlib/matplotlib-0.98.5.3.ebuild180
5 files changed, 0 insertions, 434 deletions
diff --git a/dev-python/matplotlib/files/matplotlib-0.91.2-gcc43.patch b/dev-python/matplotlib/files/matplotlib-0.91.2-gcc43.patch
deleted file mode 100644
index 042ec4c8aef0..000000000000
--- a/dev-python/matplotlib/files/matplotlib-0.91.2-gcc43.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- ttconv/pprdrv_tt2.cpp.orig 2008-05-24 08:58:22.000000000 +0100
-+++ ttconv/pprdrv_tt2.cpp 2008-05-24 08:59:34.000000000 +0100
-@@ -36,6 +36,7 @@
- #include <string.h>
- #include <memory.h>
- #include "pprdrv.h"
-+#include <cstdio>
- #include "truetype.h"
- #include <algorithm>
- #include <stack>
diff --git a/dev-python/matplotlib/files/matplotlib-0.98.5.2-literal.patch b/dev-python/matplotlib/files/matplotlib-0.98.5.2-literal.patch
deleted file mode 100644
index ef60e9b12ae4..000000000000
--- a/dev-python/matplotlib/files/matplotlib-0.98.5.2-literal.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/swig_runtime.h.old 2008-12-15 06:34:58.000000000 -0800
-+++ src/swig_runtime.h 2008-12-30 23:38:49.000000000 -0800
-@@ -856,7 +856,7 @@
- Py_DECREF(old_str);
- Py_DECREF(value);
- } else {
-- PyErr_Format(PyExc_RuntimeError, mesg);
-+ PyErr_Format(PyExc_RuntimeError, "%s", mesg);
- }
- }
-
diff --git a/dev-python/matplotlib/matplotlib-0.91.2.ebuild b/dev-python/matplotlib/matplotlib-0.91.2.ebuild
deleted file mode 100644
index 4fb5ba5b4948..000000000000
--- a/dev-python/matplotlib/matplotlib-0.91.2.ebuild
+++ /dev/null
@@ -1,116 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-0.91.2.ebuild,v 1.8 2009/03/30 15:32:32 loki_val Exp $
-
-NEED_PYTHON=2.3
-WX_GTK_VER=2.8
-EAPI=2
-inherit eutils distutils wxwidgets
-
-DOC_PV=${PV}svn
-
-DESCRIPTION="Pure python plotting library with matlab like syntax"
-HOMEPAGE="http://matplotlib.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
- doc? ( http://matplotlib.sourceforge.net/users_guide_${DOC_PV}.pdf )"
-
-IUSE="cairo doc examples fltk gtk latex qt3 qt4 tk wxwindows"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-LICENSE="PYTHON BSD stix bakoma"
-
-DEPEND="dev-python/numpy
- >=media-libs/freetype-2
- media-libs/libpng
- dev-python/pytz
- dev-python/python-dateutil
- gtk? ( dev-python/pygtk )
- tk? ( dev-lang/python[tk] )
- wxwindows? ( dev-python/wxpython:2.8 )"
-
-RDEPEND="${DEPEND}
- media-fonts/ttf-bitstream-vera
- latex? ( virtual/latex-base
- virtual/ghostscript
- app-text/dvipng
- virtual/poppler-utils )
- cairo? ( dev-python/pycairo )
- fltk? ( dev-python/pyfltk )
- qt3? ( dev-python/PyQt )
- qt4? ( dev-python/PyQt4 )"
-
-DOCS="INTERACTIVE API_CHANGES"
-
-use_setup() {
- local uword="${2}"
- [ -z "${2}" ] && uword="${1}"
- if use ${1}; then
- echo "${uword} = True"
- echo "${uword}agg = True"
- else
- echo "${uword} = False"
- echo "${uword}agg = False"
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-gcc43.patch
- # create setup.cfg (see setup.cfg.template for any changes)
- cat > setup.cfg <<-EOF
- [provide_packages]
- pytz = False
- dateutil = False
- configobj = False
- enthought.traits = False
- [gui_support]
- $(use_setup gtk)
- $(use_setup tk)
- $(use_setup wxwindows wx)
- $(use_setup qt3 qt)
- $(use_setup qt4)
- $(use_setup fltk)
- $(use_setup cairo)
- EOF
-
- # sed to avoid checks needing a X display
- sed -i \
- -e "s/check_for_gtk()/$(use gtk && echo True || echo False)/" \
- -e "s/check_for_tk()/$(use tk && echo True || echo False)/" \
- setup.py || die "sed setup.py failed"
-
- # respect FHS: put mpl-data in /usr/share/matplotlib
- # and config files in /etc/matplotlib
- sed -i \
- -e "/'mpl-data\/matplotlibrc',/d" \
- -e "/'mpl-data\/matplotlib.conf',/d" \
- -e "s:'lib/matplotlib/mpl-data/matplotlibrc':'matplotlibrc':" \
- -e "s:'lib/matplotlib/mpl-data/matplotlib.conf':'matplotlib.conf':" \
- setup.py \
- || die "sed setup.py for FHS failed"
-
- sed -i \
- -e "s:path = get_data_path():path = '/etc/matplotlib':" \
- -e "s:os.path.dirname(__file__):'/usr/share/${PN}':g" \
- lib/matplotlib/{__init__,config/cutils}.py \
- || die "sed init for FHS failed"
-
- # remove vera fonts (they are now a dependency)
- cd lib/matplotlib/mpl-data
- rm -f ttf/Vera*.ttf ttf/*.TXT ttf/local.conf pdfcorefonts/readme.txt
-}
-
-src_install() {
- distutils_src_install
-
- # respect FHS
- dodir /usr/share/${PN}
- mv "${D}"/usr/*/*/site-packages/${PN}/{mpl-data,backends/Matplotlib.nib} "${D}"/usr/share/${PN}
-
- insinto /etc/matplotlib
- doins matplotlibrc matplotlib.conf \
- || die "installing config files failed"
-
- insinto /usr/share/doc/${PF}
- use doc && newins "${DISTDIR}"/users_guide_${DOC_PV}.pdf ${P}-users-guide.pdf
- use examples && doins -r examples
-}
diff --git a/dev-python/matplotlib/matplotlib-0.91.4.ebuild b/dev-python/matplotlib/matplotlib-0.91.4.ebuild
deleted file mode 100644
index 215e58a8aa18..000000000000
--- a/dev-python/matplotlib/matplotlib-0.91.4.ebuild
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-0.91.4.ebuild,v 1.4 2009/03/30 15:32:32 loki_val Exp $
-
-NEED_PYTHON=2.3
-WX_GTK_VER=2.8
-EAPI=2
-inherit eutils distutils wxwidgets
-
-DOC_PV=0.91.2svn
-
-DESCRIPTION="Pure python plotting library with matlab like syntax"
-HOMEPAGE="http://matplotlib.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
- doc? ( http://matplotlib.sourceforge.net/users_guide_${DOC_PV}.pdf )"
-
-IUSE="cairo doc examples fltk gtk latex qt3 qt4 tk wxwindows"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-LICENSE="PYTHON BSD stix bakoma"
-
-DEPEND="dev-python/numpy
- >=media-libs/freetype-2
- media-libs/libpng
- dev-python/pytz
- dev-python/python-dateutil
- gtk? ( dev-python/pygtk )
- tk? ( dev-lang/python[tk] )
- wxwindows? ( dev-python/wxpython:2.8 )"
-
-RDEPEND="${DEPEND}
- || ( media-fonts/ttf-bitstream-vera media-fonts/dejavu )
- latex? ( virtual/latex-base
- virtual/ghostscript
- app-text/dvipng
- virtual/poppler-utils )
- cairo? ( dev-python/pycairo )
- fltk? ( dev-python/pyfltk )
- qt3? ( dev-python/PyQt )
- qt4? ( dev-python/PyQt4 )"
-
-DOCS="INTERACTIVE API_CHANGES"
-
-use_setup() {
- local uword="${2}"
- [ -z "${2}" ] && uword="${1}"
- if use ${1}; then
- echo "${uword} = True"
- echo "${uword}agg = True"
- else
- echo "${uword} = False"
- echo "${uword}agg = False"
- fi
-}
-
-src_prepare() {
- # create setup.cfg (see setup.cfg.template for any changes)
- cat > setup.cfg <<-EOF
- [provide_packages]
- pytz = False
- dateutil = False
- configobj = False
- enthought.traits = False
- [gui_support]
- $(use_setup gtk)
- $(use_setup tk)
- $(use_setup wxwindows wx)
- $(use_setup qt3 qt)
- $(use_setup qt4)
- $(use_setup fltk)
- $(use_setup cairo)
- EOF
-
- # sed to avoid checks needing a X display
- sed -i \
- -e "s/check_for_gtk()/$(use gtk && echo True || echo False)/" \
- -e "s/check_for_tk()/$(use tk && echo True || echo False)/" \
- setup.py || die "sed setup.py failed"
-
- # respect FHS: put mpl-data in /usr/share/matplotlib
- # and config files in /etc/matplotlib
- sed -i \
- -e "/'mpl-data\/matplotlibrc',/d" \
- -e "/'mpl-data\/matplotlib.conf',/d" \
- -e "s:'lib/matplotlib/mpl-data/matplotlibrc':'matplotlibrc':" \
- -e "s:'lib/matplotlib/mpl-data/matplotlib.conf':'matplotlib.conf':" \
- setup.py \
- || die "sed setup.py for FHS failed"
-
- sed -i \
- -e "s:path = get_data_path():path = '/etc/matplotlib':" \
- -e "s:os.path.dirname(__file__):'/usr/share/${PN}':g" \
- lib/matplotlib/{__init__,config/cutils}.py \
- || die "sed init for FHS failed"
-
- # remove vera fonts (they are now a dependency)
- cd lib/matplotlib/mpl-data
- rm -f ttf/Vera*.ttf ttf/*.TXT ttf/local.conf pdfcorefonts/readme.txt
-}
-
-src_install() {
- distutils_src_install
-
- # respect FHS
- dodir /usr/share/${PN}
- mv "${D}"/usr/*/*/site-packages/${PN}/{mpl-data,backends/Matplotlib.nib} \
- "${D}"/usr/share/${PN} || die "failed renaming"
-
- insinto /etc/matplotlib
- doins matplotlibrc matplotlib.conf \
- || die "installing config files failed"
-
- insinto /usr/share/doc/${PF}
- use doc && newins "${DISTDIR}"/users_guide_${DOC_PV}.pdf \
- ${P}-users-guide.pdf
- use examples && doins -r examples
-}
diff --git a/dev-python/matplotlib/matplotlib-0.98.5.3.ebuild b/dev-python/matplotlib/matplotlib-0.98.5.3.ebuild
deleted file mode 100644
index 5918c4b1938a..000000000000
--- a/dev-python/matplotlib/matplotlib-0.98.5.3.ebuild
+++ /dev/null
@@ -1,180 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-0.98.5.3.ebuild,v 1.4 2009/10/05 21:51:00 volkmar Exp $
-
-WX_GTK_VER=2.8
-EAPI=2
-inherit distutils wxwidgets
-
-PDOC="users_guide_${PV}"
-
-DESCRIPTION="Pure python plotting library with matlab like syntax"
-HOMEPAGE="http://matplotlib.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-IUSE="cairo doc excel examples fltk gtk latex qt3 qt4 traits tk wxwidgets"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-LICENSE="PYTHON BSD"
-
-CDEPEND=">=dev-python/numpy-1.1
- dev-python/python-dateutil
- dev-python/pytz
- media-libs/freetype:2
- media-libs/libpng
- gtk? ( dev-python/pygtk )
- tk? ( dev-lang/python[tk] )
- wxwidgets? ( dev-python/wxpython:2.8 )"
-
-DEPEND="${CDEPEND}
- dev-python/pycxx
- dev-util/pkgconfig
- doc? (
- >=dev-python/sphinx-0.5.1
- || (
- >=media-gfx/graphviz-2.24.0[cairo]
- <media-gfx/graphviz-2.24.0[cairo,png]
- )
- || ( ( dev-texlive/texlive-latexextra
- dev-texlive/texlive-latexrecommended )
- ( app-text/ptex dev-tex/latex-unicode ) )
- app-text/dvipng
- dev-python/ipython )"
-
-RDEPEND="${CDEPEND}
- || ( media-fonts/dejavu media-fonts/ttf-bitstream-vera )
- media-fonts/texcm-ttf
- cairo? ( dev-python/pycairo )
- excel? ( dev-python/xlwt )
- fltk? ( dev-python/pyfltk )
- qt3? ( dev-python/PyQt )
- qt4? ( dev-python/PyQt4[X] )
- traits? ( dev-python/traits dev-python/configobj )
- latex? (
- virtual/latex-base
- virtual/ghostscript
- app-text/dvipng
- virtual/poppler-utils
- || ( dev-texlive/texlive-fontsrecommended
- app-text/ptex ) )"
-
-DOCS="INTERACTIVE"
-
-use_setup() {
- local uword="${2}"
- [ -z "${2}" ] && uword="${1}"
- if use ${1}; then
- echo "${uword} = True"
- echo "${uword}agg = True"
- else
- echo "${uword} = False"
- echo "${uword}agg = False"
- fi
-}
-
-src_prepare() {
- # patch from mandriva
- epatch "${FILESDIR}"/${PN}-0.98.5.2-literal.patch
- # avoid to launch xv while building examples docs
- epatch "${FILESDIR}"/${PN}-0.98.5.2-no-xv.patch
-
- # create setup.cfg (see setup.cfg.template for any changes)
- cat > setup.cfg <<-EOF
- [provide_packages]
- pytz = False
- dateutil = False
- configobj = False
- enthought.traits = False
- [gui_support]
- $(use_setup gtk)
- $(use_setup tk)
- $(use_setup wxwidgets wx)
- $(use_setup qt3 qt)
- $(use_setup qt4)
- $(use_setup fltk)
- $(use_setup cairo)
- EOF
-
- # avoid checks needing a X display
- sed -i \
- -e "s/check_for_gtk()/$(use gtk && echo True || echo False)/" \
- -e "s/check_for_tk()/$(use tk && echo True || echo False)/" \
- setup.py || die "sed setup.py failed"
-
- # respect FHS:
- # - mpl-data in /usr/share/matplotlib
- # - config files in /etc/matplotlib
- sed -i \
- -e "/'mpl-data\/matplotlibrc',/d" \
- -e "/'mpl-data\/matplotlib.conf',/d" \
- -e "s:'lib/matplotlib/mpl-data/matplotlibrc':'matplotlibrc':" \
- -e "s:'lib/matplotlib/mpl-data/matplotlib.conf':'matplotlib.conf':" \
- setup.py \
- || die "sed setup.py for FHS failed"
-
- sed -i \
- -e "s:path = get_data_path():path = '/etc/matplotlib':" \
- -e "s:os.path.dirname(__file__):'/usr/share/${PN}':g" \
- lib/matplotlib/{__init__,config/cutils}.py \
- || die "sed init for FHS failed"
-
- # remove internal copies of fonts, pycxx, pyparsing
- rm -rf \
- CXX \
- lib/matplotlib/mpl-data/fonts/{afm,pdfcorefonts} \
- lib/matplotlib/mpl-data/fonts/ttf/{Vera*,cm*,*.TXT} \
- || die "removed internal copies failed"
- ln -s /usr/share/python*/CXX . || die
-
- # remove pyparsing only when upstream pyparsing included matplotlib
- # fixes. See bug #260025
- #rm -f lib/matplotlib/pyparsing.py
-}
-
-src_compile() {
- unset DISPLAY # bug #278524
- distutils_src_compile
- if use doc; then
- cd "${S}/doc"
- export VARTEXFONTS="${T}"/fonts
- # no die function here: broken compilation at the end, do it twice,
- # result ok.
- MATPLOTLIBDATA="${S}/lib/matplotlib/mpl-data" \
- PYTHONPATH=$(dir -d "${S}"/build/lib*) \
- ${python} make.py html
- MATPLOTLIBDATA="${S}/lib/matplotlib/mpl-data" \
- PYTHONPATH=$(dir -d "${S}"/build/lib*) \
- ${python} make.py
- fi
-}
-
-src_test() {
- einfo "Tests are quite long, be patient"
- cd "${S}/examples/tests"
- PYTHONPATH=$(dir -d "${S}"/build/lib*) ${python} backend_driver.py agg \
- || die "tests failed"
- PYTHONPATH=$(dir -d "${S}"/build/lib*) ${python} backend_driver.py \
- --clean
-}
-
-src_install() {
- distutils_src_install
-
- # respect FHS
- dodir /usr/share/${PN}
- mv "${D}"/usr/*/*/site-packages/${PN}/{mpl-data,backends/Matplotlib.nib} \
- "${D}"/usr/share/${PN} || die "failed renaming"
- insinto /etc/matplotlib
- doins matplotlibrc matplotlib.conf \
- || die "installing config files failed"
-
- # doc and examples
- insinto /usr/share/doc/${PF}
- if use doc; then
- doins doc/build/latex/Matplotlib.pdf || die
- doins -r doc/build/html || die
- fi
- if use examples; then
- doins -r examples || die
- fi
-}