summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-10-23 16:24:51 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-10-23 16:24:51 +0000
commit2158f44e6ecb33d4136533ec1c0fad706f2ea89c (patch)
tree829d07bb2f8adf59ecae7bb5d8d674eeab3298ec /dev-python
parentadded patch to compile with gcc-3.2 (diff)
downloadhistorical-2158f44e6ecb33d4136533ec1c0fad706f2ea89c.tar.gz
historical-2158f44e6ecb33d4136533ec1c0fad706f2ea89c.tar.bz2
historical-2158f44e6ecb33d4136533ec1c0fad706f2ea89c.zip
added the latest dev version from foser
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pygtk/ChangeLog11
-rw-r--r--dev-python/pygtk/files/digest-pygtk-1.99.131
-rw-r--r--dev-python/pygtk/pygtk-1.99.13.ebuild41
3 files changed, 52 insertions, 1 deletions
diff --git a/dev-python/pygtk/ChangeLog b/dev-python/pygtk/ChangeLog
index 4bfd4eca965f..305178396067 100644
--- a/dev-python/pygtk/ChangeLog
+++ b/dev-python/pygtk/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-python/pygtk
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/ChangeLog,v 1.6 2002/08/21 02:47:33 gerk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/ChangeLog,v 1.7 2002/10/23 16:24:51 spider Exp $
+
+
+*pygtk-1.99.13 (23 Oct 2002)
+
+ 23 Oct 2002; Spider <spider@gentoo.org> pygtk-1.99.13.ebuild :
+ finally got this in, closing bug #3700. thanks foser@gentoo.org for the actual work
+
+
+
*pygtk-0.6.9 (19 Jun 2002)
diff --git a/dev-python/pygtk/files/digest-pygtk-1.99.13 b/dev-python/pygtk/files/digest-pygtk-1.99.13
new file mode 100644
index 000000000000..1fdd8d3f3d19
--- /dev/null
+++ b/dev-python/pygtk/files/digest-pygtk-1.99.13
@@ -0,0 +1 @@
+MD5 351d1f76f106b24ac0c40b51232cf8f2 pygtk-1.99.13.tar.gz 523367
diff --git a/dev-python/pygtk/pygtk-1.99.13.ebuild b/dev-python/pygtk/pygtk-1.99.13.ebuild
new file mode 100644
index 000000000000..f762d7072ba1
--- /dev/null
+++ b/dev-python/pygtk/pygtk-1.99.13.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Karl Trygve Kalleberg <karltk@gentoo.org>
+# /space/gentoo/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-1.99.10.ebuild,v 1.1 2002/06/13 16:17:12 spider Exp
+
+# since its a development version
+inherit debug
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GTK+2 bindings for Python"
+SRC_URI="ftp://ftp.gtk.org/pub/gtk/python/v2.0/${P}.tar.gz"
+HOMEPAGE="http://www.daa.com.au/~james/pygtk/"
+LICENSE="LGPL-2.1"
+
+KEYWORDS="x86 ppc sparc sparc64 alpha"
+
+
+DEPEND=">=dev-lang/python-2.2
+ >=x11-libs/pango-1.0.0
+ >=gnome-base/libglade-2.0.0
+ opengl? ( >=x11-libs/gtkglarea-1.99.0 )"
+
+SLOT="2.0"
+
+src_compile() {
+
+ ./configure --prefix=/usr/ \
+ --host=${CHOST} || die
+ emake || die
+}
+
+src_install () {
+ make prefix=${D}/usr install || die
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL MAPPING NEWS README THREADS TODO
+}
+
+pkg_postinst() {
+ einfo 'If you built pygtk with OpenGL support you still need to emerge'
+ einfo 'PyOpenGL to actually be able to use it. '
+}