summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLukasz Strzygowski <lucass@gentoo.org>2004-06-17 21:39:22 +0000
committerLukasz Strzygowski <lucass@gentoo.org>2004-06-17 21:39:22 +0000
commit1fd3bae03984f1f14ae5e9615f49ccfeac3d8cf5 (patch)
tree0513b6bbb0e9ec23b6452d3df4c6048a57fac376 /dev-python
parentRemoved old digests. (diff)
downloadhistorical-1fd3bae03984f1f14ae5e9615f49ccfeac3d8cf5.tar.gz
historical-1fd3bae03984f1f14ae5e9615f49ccfeac3d8cf5.tar.bz2
historical-1fd3bae03984f1f14ae5e9615f49ccfeac3d8cf5.zip
Fixing bug 54174. Thanks for Roger Luethi. Now it install also tests, demos, all docs and man pages. Marking testing on all archs.
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyxml/ChangeLog8
-rw-r--r--dev-python/pyxml/Manifest4
-rw-r--r--dev-python/pyxml/files/digest-pyxml-0.8.3-r11
-rw-r--r--dev-python/pyxml/pyxml-0.8.3-r1.ebuild44
4 files changed, 55 insertions, 2 deletions
diff --git a/dev-python/pyxml/ChangeLog b/dev-python/pyxml/ChangeLog
index de6723a1ff5c..0f65fdded92f 100644
--- a/dev-python/pyxml/ChangeLog
+++ b/dev-python/pyxml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pyxml
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxml/ChangeLog,v 1.13 2004/05/14 01:34:58 geoman Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxml/ChangeLog,v 1.14 2004/06/17 21:39:22 lucass Exp $
+
+*pyxml-0.8.3-r1 (17 Jun 2004)
+
+ 17 Jun 2004; Lukasz Strzygowski <lucass@gentoo.org> pyxml-0.8.3-r1.ebuild:
+ Fixing bug 54174. Thanks for Roger Luethi. Now it install also
+ tests, demos, all docs and man pages. Marking testing on all archs.
13 May 2004; Stephen P. Becker <geoman@gentoo.org> pyxml-0.8.3.ebuild:
Stable on mips.
diff --git a/dev-python/pyxml/Manifest b/dev-python/pyxml/Manifest
index 580be13a369c..dd24c846e963 100644
--- a/dev-python/pyxml/Manifest
+++ b/dev-python/pyxml/Manifest
@@ -1,8 +1,10 @@
MD5 ad74b67552cfcb435124861584c16667 pyxml-0.8.3.ebuild 935
MD5 42cbc4c1736269f63d12a39dc80344c8 pyxml-0.8.2.ebuild 924
-MD5 9ee34e28b8ee870e5672e30fa73142a2 ChangeLog 3196
+MD5 6fc9699165b1718a17a5a218c6d3e223 ChangeLog 3440
MD5 71c4638c9c88af75b58e5f5cb54fe008 metadata.xml 159
MD5 9cdc8d813fa306001298fd1694aa50d0 pyxml-0.8.1.ebuild 648
+MD5 f298468c1d79f6ad9d22d6a1f46fe749 pyxml-0.8.3-r1.ebuild 1145
MD5 b83e36b4dc90c3ce5840f0d2e432b7b2 files/digest-pyxml-0.8.1 63
MD5 6a14eefbf90c139b1f9b058131cb211f files/digest-pyxml-0.8.2 63
MD5 7d09f52601eefbf60eb70af6516bd302 files/digest-pyxml-0.8.3 63
+MD5 7d09f52601eefbf60eb70af6516bd302 files/digest-pyxml-0.8.3-r1 63
diff --git a/dev-python/pyxml/files/digest-pyxml-0.8.3-r1 b/dev-python/pyxml/files/digest-pyxml-0.8.3-r1
new file mode 100644
index 000000000000..717f318fde57
--- /dev/null
+++ b/dev-python/pyxml/files/digest-pyxml-0.8.3-r1
@@ -0,0 +1 @@
+MD5 7083d950064ce90840d9ed48c818dc85 PyXML-0.8.3.tar.gz 729172
diff --git a/dev-python/pyxml/pyxml-0.8.3-r1.ebuild b/dev-python/pyxml/pyxml-0.8.3-r1.ebuild
new file mode 100644
index 000000000000..cbbfd7d76c5d
--- /dev/null
+++ b/dev-python/pyxml/pyxml-0.8.3-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxml/pyxml-0.8.3-r1.ebuild,v 1.1 2004/06/17 21:39:22 lucass Exp $
+
+inherit python distutils
+
+MY_P=${P/pyxml/PyXML}
+
+DESCRIPTION="A collection of libraries to process XML with Python."
+SRC_URI="mirror://sourceforge/pyxml/${MY_P}.tar.gz"
+HOMEPAGE="http://pyxml.sourceforge.net/"
+
+DEPEND="virtual/python
+ >=dev-libs/expat-1.95.6"
+
+IUSE=""
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~amd64 ~ppc64 ~ia64 ~mips"
+LICENSE="PYTHON"
+DOCS="ANNOUNCE CREDITS PKG-INFO LICENCE TODO doc/*.txt"
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ local myconf
+
+ # if you want to use 4Suite, then their XSLT/XPATH is
+ # better according to the docs
+ if has_version "dev-python/4suite"; then
+ myconf="--without-xslt --without-xpath"
+ fi
+
+ distutils_src_compile ${myconf}
+}
+
+src_install() {
+ distutils_src_install
+
+ doman doc/man/*
+ dohtml -A api,web -r doc/*
+ insinto /usr/share/doc/${PF} && doins doc/*.tex
+ cp -r demo ${D}/usr/share/doc/${PF}
+ dodir /usr/share/${PN} && cp -r test ${D}/usr/share/${PN}
+}
+