summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-01-06 21:25:12 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-01-06 21:25:12 +0000
commitf90ac8f05f345961fb6b4d44797033df5cc996f0 (patch)
treea2c71c639fe97a867ab9e4ff3bb20f6932e1768c /dev-python/wxpython
parentFix dependencies. Restrict PyPy ABIs. Add doc USE flag. Call distutils_src_pr... (diff)
downloadhistorical-f90ac8f05f345961fb6b4d44797033df5cc996f0.tar.gz
historical-f90ac8f05f345961fb6b4d44797033df5cc996f0.tar.bz2
historical-f90ac8f05f345961fb6b4d44797033df5cc996f0.zip
Don't inherit unused eclass. Properly set local variables. Patch by Arfrever.
Package-Manager: portage-2.2.0_alpha84/cvs/Linux x86_64
Diffstat (limited to 'dev-python/wxpython')
-rw-r--r--dev-python/wxpython/ChangeLog8
-rw-r--r--dev-python/wxpython/wxpython-2.8.12.1.ebuild11
-rw-r--r--dev-python/wxpython/wxpython-2.9.1.1.ebuild11
3 files changed, 16 insertions, 14 deletions
diff --git a/dev-python/wxpython/ChangeLog b/dev-python/wxpython/ChangeLog
index fe70ba429429..3735c330eb87 100644
--- a/dev-python/wxpython/ChangeLog
+++ b/dev-python/wxpython/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/wxpython
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.153 2011/12/09 15:34:23 ssuominen Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.154 2012/01/06 21:25:12 hwoarang Exp $
+
+ 06 Jan 2012; Markos Chandras <hwoarang@gentoo.org> wxpython-2.8.12.1.ebuild,
+ wxpython-2.9.1.1.ebuild:
+ Don't inherit unused eclass. Properly set local variables. Patch by Arfrever.
09 Dec 2011; Samuli Suominen <ssuominen@gentoo.org>
-files/scripts-multiver-2.6.1.0.diff, -wxpython-2.6.4.0-r2.ebuild:
diff --git a/dev-python/wxpython/wxpython-2.8.12.1.ebuild b/dev-python/wxpython/wxpython-2.8.12.1.ebuild
index e9505c3eadbc..929a022501b5 100644
--- a/dev-python/wxpython/wxpython-2.8.12.1.ebuild
+++ b/dev-python/wxpython/wxpython-2.8.12.1.ebuild
@@ -1,13 +1,14 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.8.12.1.ebuild,v 1.1 2011/12/09 05:04:54 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.8.12.1.ebuild,v 1.2 2012/01/06 21:25:12 hwoarang Exp $
EAPI="4"
PYTHON_DEPEND="2"
WX_GTK_VER="2.8"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
-inherit alternatives eutils fdo-mime flag-o-matic multilib python wxwidgets
+inherit alternatives eutils fdo-mime flag-o-matic python wxwidgets
MY_P="${P/wxpython-/wxPython-src-}"
@@ -38,8 +39,6 @@ RDEPEND="
DEPEND="${RDEPEND}
dev-util/pkgconfig"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
-
S="${WORKDIR}/${MY_P}/wxPython"
DOC_S="${WORKDIR}/wxPython-${PV}"
@@ -84,7 +83,7 @@ src_compile() {
}
src_install() {
- local docdir mypyconf
+ local docdir file mypyconf
mypyconf="${mypyconf} WX_CONFIG=${WX_CONFIG}"
use opengl \
diff --git a/dev-python/wxpython/wxpython-2.9.1.1.ebuild b/dev-python/wxpython/wxpython-2.9.1.1.ebuild
index 5cb866a5482a..87ffceb9b515 100644
--- a/dev-python/wxpython/wxpython-2.9.1.1.ebuild
+++ b/dev-python/wxpython/wxpython-2.9.1.1.ebuild
@@ -1,13 +1,14 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.9.1.1.ebuild,v 1.3 2011/04/21 01:20:09 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.9.1.1.ebuild,v 1.4 2012/01/06 21:25:12 hwoarang Exp $
EAPI="3"
PYTHON_DEPEND="2"
WX_GTK_VER="2.9"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
-inherit alternatives eutils fdo-mime flag-o-matic multilib python wxwidgets
+inherit alternatives eutils fdo-mime flag-o-matic python wxwidgets
MY_P="${P/wxpython-/wxPython-src-}"
@@ -36,8 +37,6 @@ RDEPEND="
DEPEND="${RDEPEND}
dev-util/pkgconfig"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
-
S="${WORKDIR}/${MY_P}/wxPython"
DOC_S="${WORKDIR}/wxPython-${PV}"
@@ -77,7 +76,7 @@ src_compile() {
}
src_install() {
- local mypyconf
+ local file mypyconf
mypyconf="${mypyconf} WX_CONFIG=${WX_CONFIG}"
use opengl \