summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2003-05-09 15:47:04 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2003-05-09 15:47:04 +0000
commitc0de6534123159c87f7c046e09e68d286adf1d31 (patch)
tree7af345786f20b36fc21e335f1c33b8cc47ad02d7 /dev-python/twisted
parentupdated src_uri (diff)
downloadhistorical-c0de6534123159c87f7c046e09e68d286adf1d31.tar.gz
historical-c0de6534123159c87f7c046e09e68d286adf1d31.tar.bz2
historical-c0de6534123159c87f7c046e09e68d286adf1d31.zip
1.0.5 (requires python 2.2 now)
Diffstat (limited to 'dev-python/twisted')
-rw-r--r--dev-python/twisted/ChangeLog6
-rw-r--r--dev-python/twisted/files/digest-twisted-1.0.51
-rw-r--r--dev-python/twisted/twisted-1.0.5.ebuild43
3 files changed, 49 insertions, 1 deletions
diff --git a/dev-python/twisted/ChangeLog b/dev-python/twisted/ChangeLog
index 3e6a5b1786a7..4fb63e1f5f4c 100644
--- a/dev-python/twisted/ChangeLog
+++ b/dev-python/twisted/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for dev-python/twisted
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.17 2003/04/18 15:45:23 lordvan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.18 2003/05/09 15:47:04 lordvan Exp $
+*twisted-1.0.5 (09 May 2003)
+ 09 May 2003; Thomas Raschbacher <lordvan@gentoo.org> twisted-1.0.5.ebuild:
+ new ebuild (does not support python-2.1 anymore!
+
*twisted-1.0.4 (18 Apr 2003)
18 Apr 2003; Thomas Raschbacher <lordvan@gentoo.org> twisted-1.0.4.ebuild
new version
diff --git a/dev-python/twisted/files/digest-twisted-1.0.5 b/dev-python/twisted/files/digest-twisted-1.0.5
new file mode 100644
index 000000000000..8a9c15127117
--- /dev/null
+++ b/dev-python/twisted/files/digest-twisted-1.0.5
@@ -0,0 +1 @@
+MD5 33d0cf733174ff131dd7f21ba0719782 Twisted-1.0.5.tar.bz2 4782566
diff --git a/dev-python/twisted/twisted-1.0.5.ebuild b/dev-python/twisted/twisted-1.0.5.ebuild
new file mode 100644
index 000000000000..05209644a6d3
--- /dev/null
+++ b/dev-python/twisted/twisted-1.0.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-1.0.5.ebuild,v 1.1 2003/05/09 15:47:04 lordvan Exp $
+
+IUSE="gtk2 doc"
+
+S=${WORKDIR}/Twisted-${PV}
+DESCRIPTION="Twisted is a collection of servers and clients, which can be used either by developers of new applications or directly. Documentation included."
+SRC_URI="http://twisted.sourceforge.net/Twisted-${PV}.tar.bz2"
+HOMEPAGE="http://www.twistedmatrix.com/"
+LICENSE="LGPL-2.1"
+SLOT="0"
+DEPEND=">=dev-lang/python-2.2*
+ >=dev-python/pycrypto-1.9_alpha4
+ gtk? ( =dev-python/pygtk-0.6* )
+ gtk2? ( >=dev-python/pygtk-1.99* )"
+KEYWORDS="~x86 ~alpha ~sparc "
+
+inherit distutils
+
+src_install() {
+ distutils_src_install
+
+ # of course it's documentation!
+ doman doc/man/*.[0-9n]
+ rm -rf doc/man # don't dupe the man pages
+
+ # next few lines will install docs: 9.4 megs!
+ if [ -n "`use doc`" ]; then
+ cd ${S}/doc
+ dodir /usr/share/doc/${PF}
+ cp -r . ${D}/usr/share/doc/${PF}
+ fi
+
+ # use gtk2 if they so wish
+ if [ -n "`use gtk2`" ]; then
+ sed -e 's/import manhole/import manhole2/' \
+ -e 's/manhole\.run()/manhole2.run()/' \
+ -i ${D}/usr/bin/manhole
+ fi
+
+}
+