summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-11-04 22:24:35 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-11-04 22:24:35 +0000
commit1e3f2ca664c26abd448cadee71102e7ee22bdc7b (patch)
treef8736e4ba3bb47340e70e34a522674e76346e165 /dev-python/sphinx
parentUpdate LICENSE. Patch by Arfrever. (diff)
downloadhistorical-1e3f2ca664c26abd448cadee71102e7ee22bdc7b.tar.gz
historical-1e3f2ca664c26abd448cadee71102e7ee22bdc7b.tar.bz2
historical-1e3f2ca664c26abd448cadee71102e7ee22bdc7b.zip
Fix dependencies. Simplify ebuilds. Patch by Arfrever.
Package-Manager: portage-2.2.0_alpha71/cvs/Linux x86_64
Diffstat (limited to 'dev-python/sphinx')
-rw-r--r--dev-python/sphinx/ChangeLog6
-rw-r--r--dev-python/sphinx/sphinx-1.0.7.ebuild18
-rw-r--r--dev-python/sphinx/sphinx-1.1.ebuild18
3 files changed, 23 insertions, 19 deletions
diff --git a/dev-python/sphinx/ChangeLog b/dev-python/sphinx/ChangeLog
index 56a9a02c912e..cd13f7fe39ed 100644
--- a/dev-python/sphinx/ChangeLog
+++ b/dev-python/sphinx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/sphinx
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/ChangeLog,v 1.93 2011/10/10 07:06:50 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/ChangeLog,v 1.94 2011/11/04 22:24:35 hwoarang Exp $
+
+ 04 Nov 2011; Markos Chandras <hwoarang@gentoo.org> sphinx-1.0.7.ebuild,
+ sphinx-1.1.ebuild:
+ Fix dependencies. Simplify ebuilds. Patch by Arfrever.
*sphinx-1.1 (10 Oct 2011)
diff --git a/dev-python/sphinx/sphinx-1.0.7.ebuild b/dev-python/sphinx/sphinx-1.0.7.ebuild
index 5e883a588e94..913f9da2487c 100644
--- a/dev-python/sphinx/sphinx-1.0.7.ebuild
+++ b/dev-python/sphinx/sphinx-1.0.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/sphinx-1.0.7.ebuild,v 1.7 2011/03/23 21:05:31 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/sphinx-1.0.7.ebuild,v 1.8 2011/11/04 22:24:34 hwoarang Exp $
EAPI="3"
PYTHON_DEPEND="2"
@@ -22,12 +22,12 @@ SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="doc latex"
-RDEPEND=">=dev-python/docutils-0.5
+DEPEND=">=dev-python/docutils-0.5
>=dev-python/jinja-2.2
>=dev-python/pygments-0.8
+ dev-python/setuptools
latex? ( dev-texlive/texlive-latexextra )"
-DEPEND="${RDEPEND}
- dev-python/setuptools"
+RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
@@ -39,7 +39,7 @@ src_compile() {
if use doc; then
pushd doc > /dev/null
einfo "Generation of documentation"
- PYTHONPATH="../" emake SPHINXBUILD="$(PYTHON -f) ../sphinx-build.py" html || die "Generation of documentation failed"
+ PYTHONPATH=".." emake SPHINXBUILD="$(PYTHON -f) ../sphinx-build.py" html || die "Generation of documentation failed"
popd > /dev/null
fi
}
@@ -60,8 +60,8 @@ pkg_postinst() {
"$(PYTHON)" -c "import sys; sys.path.insert(0, '${EROOT}$(python_get_sitedir -b)'); from sphinx.pycode.pgen2.driver import load_grammar; load_grammar('${EROOT}$(python_get_sitedir -b)/sphinx/pycode/Grammar.txt')"
}
python_execute_function \
- --action-message 'Generation of Grammar pickle with $(python_get_implementation) $(python_get_version)...' \
- --failure-message 'Generation of Grammar pickle with $(python_get_implementation) $(python_get_version) failed' \
+ --action-message 'Generation of Grammar pickle with $(python_get_implementation_and_version)...' \
+ --failure-message 'Generation of Grammar pickle with $(python_get_implementation_and_version) failed' \
generation_of_grammar_pickle
}
@@ -79,7 +79,7 @@ pkg_postrm() {
done
}
python_execute_function \
- --action-message 'Deletion of Grammar pickle with $(python_get_implementation) $(python_get_version)...' \
- --failure-message 'Deletion of Grammar pickle with $(python_get_implementation) $(python_get_version) failed' \
+ --action-message 'Deletion of Grammar pickle with $(python_get_implementation_and_version)...' \
+ --failure-message 'Deletion of Grammar pickle with $(python_get_implementation_and_version) failed' \
deletion_of_grammar_pickle
}
diff --git a/dev-python/sphinx/sphinx-1.1.ebuild b/dev-python/sphinx/sphinx-1.1.ebuild
index 75fcefa32c17..4b38e038a93d 100644
--- a/dev-python/sphinx/sphinx-1.1.ebuild
+++ b/dev-python/sphinx/sphinx-1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/sphinx-1.1.ebuild,v 1.1 2011/10/10 07:06:50 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/sphinx-1.1.ebuild,v 1.2 2011/11/04 22:24:34 hwoarang Exp $
EAPI="3"
PYTHON_DEPEND="2"
@@ -22,12 +22,12 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="doc latex"
-RDEPEND=">=dev-python/docutils-0.7
+DEPEND=">=dev-python/docutils-0.7
>=dev-python/jinja-2.3
>=dev-python/pygments-1.2
+ dev-python/setuptools
latex? ( dev-texlive/texlive-latexextra )"
-DEPEND="${RDEPEND}
- dev-python/setuptools"
+RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
@@ -39,7 +39,7 @@ src_compile() {
if use doc; then
pushd doc > /dev/null
einfo "Generation of documentation"
- PYTHONPATH="../" emake SPHINXBUILD="$(PYTHON -f) ../sphinx-build.py" html || die "Generation of documentation failed"
+ PYTHONPATH=".." emake SPHINXBUILD="$(PYTHON -f) ../sphinx-build.py" html || die "Generation of documentation failed"
popd > /dev/null
fi
}
@@ -60,8 +60,8 @@ pkg_postinst() {
"$(PYTHON)" -c "import sys; sys.path.insert(0, '${EROOT}$(python_get_sitedir -b)'); from sphinx.pycode.pgen2.driver import load_grammar; load_grammar('${EROOT}$(python_get_sitedir -b)/sphinx/pycode/Grammar.txt')"
}
python_execute_function \
- --action-message 'Generation of Grammar pickle with $(python_get_implementation) $(python_get_version)...' \
- --failure-message 'Generation of Grammar pickle with $(python_get_implementation) $(python_get_version) failed' \
+ --action-message 'Generation of Grammar pickle with $(python_get_implementation_and_version)...' \
+ --failure-message 'Generation of Grammar pickle with $(python_get_implementation_and_version) failed' \
generation_of_grammar_pickle
}
@@ -79,7 +79,7 @@ pkg_postrm() {
done
}
python_execute_function \
- --action-message 'Deletion of Grammar pickle with $(python_get_implementation) $(python_get_version)...' \
- --failure-message 'Deletion of Grammar pickle with $(python_get_implementation) $(python_get_version) failed' \
+ --action-message 'Deletion of Grammar pickle with $(python_get_implementation_and_version)...' \
+ --failure-message 'Deletion of Grammar pickle with $(python_get_implementation_and_version) failed' \
deletion_of_grammar_pickle
}