summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2004-09-24 22:50:51 +0000
committerCarsten Lohrke <carlo@gentoo.org>2004-09-24 22:50:51 +0000
commit6ad6e040f3889fb2517e04c3f8c2f19eb3ea9b86 (patch)
treecdb08094f82435f05d904a639054201e88c8a4ae /dev-python/sip/sip-3.11.1.ebuild
parentppc stable profile update (diff)
downloadhistorical-6ad6e040f3889fb2517e04c3f8c2f19eb3ea9b86.tar.gz
historical-6ad6e040f3889fb2517e04c3f8c2f19eb3ea9b86.tar.bz2
historical-6ad6e040f3889fb2517e04c3f8c2f19eb3ea9b86.zip
version bump
Diffstat (limited to 'dev-python/sip/sip-3.11.1.ebuild')
-rw-r--r--dev-python/sip/sip-3.11.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/sip/sip-3.11.1.ebuild b/dev-python/sip/sip-3.11.1.ebuild
new file mode 100644
index 000000000000..d12db285ff70
--- /dev/null
+++ b/dev-python/sip/sip-3.11.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-3.11.1.ebuild,v 1.1 2004/09/24 22:50:51 carlo Exp $
+
+inherit distutils
+
+DESCRIPTION="SIP is a tool for generating bindings for C++ classes so that they can be used by Python."
+HOMEPAGE="http://www.riverbankcomputing.co.uk/sip/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+IUSE=""
+
+DEPEND="virtual/libc
+ x11-libs/qt
+ virtual/python"
+
+src_compile(){
+ distutils_python_version
+ python configure.py -l qt-mt \
+ -b /usr/bin \
+ -d /usr/lib/python${PYVER}/site-packages \
+ -e /usr/include/python${PYVER} \
+ "CXXFLAGS+=${CXXFLAGS}"
+ emake || die
+}
+
+src_install() {
+ einstall DESTDIR=${D} || die
+ dodoc ChangeLog LICENSE NEWS README THANKS TODO
+}
+
+pkg_postinst() {
+ einfo "Please note, that you have to emerge PyQt again, when upgrading from an earlier sip-3.x version."
+}