summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-29 02:18:37 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-29 02:18:37 +0000
commit33b4e676c574071c59b62aa99fde1953a271433e (patch)
tree9f87a285989edea411d70a4485985f04a88496c9 /dev-python/sexy-python
parentEnsure that defined functions are passed to python_execute_function(). Add PY... (diff)
downloadhistorical-33b4e676c574071c59b62aa99fde1953a271433e.tar.gz
historical-33b4e676c574071c59b62aa99fde1953a271433e.tar.bz2
historical-33b4e676c574071c59b62aa99fde1953a271433e.zip
Set SUPPORT_PYTHON_ABIS.
Package-Manager: portage-14166-svn/cvs/Linux x86_64
Diffstat (limited to 'dev-python/sexy-python')
-rw-r--r--dev-python/sexy-python/ChangeLog8
-rw-r--r--dev-python/sexy-python/Manifest3
-rw-r--r--dev-python/sexy-python/sexy-python-0.1.9-r1.ebuild31
3 files changed, 40 insertions, 2 deletions
diff --git a/dev-python/sexy-python/ChangeLog b/dev-python/sexy-python/ChangeLog
index 19fefb9c55bd..a4ba5b454f82 100644
--- a/dev-python/sexy-python/ChangeLog
+++ b/dev-python/sexy-python/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/sexy-python
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sexy-python/ChangeLog,v 1.16 2009/05/31 23:23:04 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sexy-python/ChangeLog,v 1.17 2009/08/29 02:18:37 arfrever Exp $
+
+*sexy-python-0.1.9-r1 (29 Aug 2009)
+
+ 29 Aug 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +sexy-python-0.1.9-r1.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
31 May 2009; Brent Baude <ranger@gentoo.org> sexy-python-0.1.9.ebuild:
Marking sexy-python-0.1.9 ppc64 for bug 267709
diff --git a/dev-python/sexy-python/Manifest b/dev-python/sexy-python/Manifest
index 7c7a27e7a223..c868ab715de6 100644
--- a/dev-python/sexy-python/Manifest
+++ b/dev-python/sexy-python/Manifest
@@ -1,4 +1,5 @@
DIST sexy-python-0.1.9.tar.gz 322261 RMD160 2f8c31b92c9fcceae95dc07567ee8a70ed943a12 SHA1 9fe24366512258cd6254f42e51dbb71f9f6bb6cb SHA256 2d8d257bbfa498a89792e0405ed8cf70396648b3df3c8e32cdc3dcc9bb666f15
+EBUILD sexy-python-0.1.9-r1.ebuild 814 RMD160 2d444b231d349b13112e9d46101ee195ef5c3aca SHA1 d2c71cdc670e7c6e939c7ee84c101b512aea2b6c SHA256 ab128f8767c31ec36652f7e2e4e0ae04a649eb5df44a4d7053c964aa8eb9ec24
EBUILD sexy-python-0.1.9.ebuild 738 RMD160 d952c4963785bca70dad4c11a5dd51f0b8dcdde0 SHA1 8ad60f0f070cd58a33e6d2fa7f046c69201f45d7 SHA256 35a7927453ef1ca31a5978ac29c7355fd3a9790aed509aeecb70001477b6786b
-MISC ChangeLog 2001 RMD160 815cc919cfdbd318f61ebba2de2574556797a830 SHA1 7df30d325eb549d499c6adf6267bab52fbd96643 SHA256 34519d809f769032652683e2c65702d6e6246c5fc30e312b437a65242032a0cb
+MISC ChangeLog 2173 RMD160 792ace2801ad87c371c41da0f13cf14a985f1cf6 SHA1 45baf5b8f51044b1176b5038e8dfd9fa40eb285a SHA256 61504538973ff47ef03a02bcad1788d026498109a6203e8eb7b964a58af50b71
MISC metadata.xml 160 RMD160 e730f96ab97c5be577a6d6d05f04990374a0dffb SHA1 2aa5e6be9c265c0e7bceb78ee9fd20df5f818e36 SHA256 6cd954a9de2307c57d32b25fa3599dee2908a4ddc6a98594f593d53577307a3a
diff --git a/dev-python/sexy-python/sexy-python-0.1.9-r1.ebuild b/dev-python/sexy-python/sexy-python-0.1.9-r1.ebuild
new file mode 100644
index 000000000000..a5ebbd972fd0
--- /dev/null
+++ b/dev-python/sexy-python/sexy-python-0.1.9-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sexy-python/sexy-python-0.1.9-r1.ebuild,v 1.1 2009/08/29 02:18:37 arfrever Exp $
+
+EAPI="2"
+PYTHON_DEFINE_DEFAULT_FUNCTIONS="1"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit python
+
+DESCRIPTION="Python bindings for libsexy."
+HOMEPAGE="http://www.chipx86.com/wiki/Libsexy"
+SRC_URI="http://releases.chipx86.com/libsexy/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=x11-libs/libsexy-${PV}
+ >=dev-python/pygtk-2.6.2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+RESTRICT_PYTHON_ABIS="3*"
+
+src_install() {
+ python_need_rebuild
+ python_execute_function -d -s
+ dodoc AUTHORS ChangeLog NEWS README
+}