summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-03-23 05:20:06 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-03-23 05:20:06 +0000
commit97bf22aaf1790bae1450f09a9fd8a2b9f9e78f89 (patch)
tree53bb530c50b4eb5a4221b7a60345ae6e2c6ea665 /dev-python/setupdocs
parentVersion bump (diff)
downloadhistorical-97bf22aaf1790bae1450f09a9fd8a2b9f9e78f89.tar.gz
historical-97bf22aaf1790bae1450f09a9fd8a2b9f9e78f89.tar.bz2
historical-97bf22aaf1790bae1450f09a9fd8a2b9f9e78f89.zip
Version bump
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'dev-python/setupdocs')
-rw-r--r--dev-python/setupdocs/ChangeLog10
-rw-r--r--dev-python/setupdocs/setupdocs-1.0.4.ebuild29
2 files changed, 37 insertions, 2 deletions
diff --git a/dev-python/setupdocs/ChangeLog b/dev-python/setupdocs/ChangeLog
index c6ca17b613ff..cfddb65b481a 100644
--- a/dev-python/setupdocs/ChangeLog
+++ b/dev-python/setupdocs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/setupdocs
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/setupdocs/ChangeLog,v 1.9 2009/11/08 19:53:13 nixnut Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/setupdocs/ChangeLog,v 1.10 2010/03/23 05:07:59 bicatali Exp $
+
+*setupdocs-1.0.4 (20 Mar 2010)
+
+ 20 Mar 2010; SĂ©bastien Fabbro <bicatali@gentoo.org>
+ +setupdocs-1.0.4.ebuild:
+ Version bump
08 Nov 2009; nixnut <nixnut@gentoo.org> setupdocs-1.0.3.ebuild:
ppc stable #290607
diff --git a/dev-python/setupdocs/setupdocs-1.0.4.ebuild b/dev-python/setupdocs/setupdocs-1.0.4.ebuild
new file mode 100644
index 000000000000..f2a6d470bfa1
--- /dev/null
+++ b/dev-python/setupdocs/setupdocs-1.0.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/setupdocs/setupdocs-1.0.4.ebuild,v 1.1 2010/03/23 05:07:59 bicatali Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+MY_PN="SetupDocs"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="setuptools plugin to automate building of docs from ReST source"
+HOMEPAGE="http://pypi.python.org/pypi/SetupDocs http://code.enthought.com/projects/"
+SRC_URI="http://www.enthought.com/repo/ETS/${MY_P}.tar.gz"
+
+IUSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+LICENSE="BSD"
+DEPEND="dev-python/setuptools
+ dev-python/sphinx"
+
+RDEPEND="dev-python/sphinx
+ virtual/latex-base
+ || ( dev-texlive/texlive-latexextra app-text/ptex )"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"