summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-09-18 12:19:53 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-09-18 12:19:53 +0000
commit84f8569efb689b8544bf1da7126624d8d0112a91 (patch)
treeb5ba36eba9b2e1b70fc892bb42b21d4ebeca99e7 /dev-python/python-ptrace
parentversion bump (diff)
downloadhistorical-84f8569efb689b8544bf1da7126624d8d0112a91.tar.gz
historical-84f8569efb689b8544bf1da7126624d8d0112a91.tar.bz2
historical-84f8569efb689b8544bf1da7126624d8d0112a91.zip
Set SUPPORT_PYTHON_ABIS.
Package-Manager: portage-14278-svn/cvs/Linux x86_64
Diffstat (limited to 'dev-python/python-ptrace')
-rw-r--r--dev-python/python-ptrace/ChangeLog6
-rw-r--r--dev-python/python-ptrace/Manifest4
-rw-r--r--dev-python/python-ptrace/python-ptrace-0.6.ebuild30
3 files changed, 31 insertions, 9 deletions
diff --git a/dev-python/python-ptrace/ChangeLog b/dev-python/python-ptrace/ChangeLog
index 0ad7349c3237..06d1f34785c8 100644
--- a/dev-python/python-ptrace/ChangeLog
+++ b/dev-python/python-ptrace/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/python-ptrace
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ptrace/ChangeLog,v 1.3 2009/09/04 18:09:41 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ptrace/ChangeLog,v 1.4 2009/09/18 12:19:53 arfrever Exp $
+
+ 18 Sep 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ python-ptrace-0.6.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
04 Sep 2009; Patrick Lauer <patrick@gentoo.org> -python-ptrace-0.5.ebuild:
Remove old
diff --git a/dev-python/python-ptrace/Manifest b/dev-python/python-ptrace/Manifest
index ca6899369aa2..8304633b5715 100644
--- a/dev-python/python-ptrace/Manifest
+++ b/dev-python/python-ptrace/Manifest
@@ -1,4 +1,4 @@
DIST python-ptrace-0.6.tar.gz 79530 RMD160 548a6c82b4e3bf1f938039cd0b9481714b224324 SHA1 ebc871cfd179c25a03c1ff5007c2b9fb68d73e2d SHA256 767e55b4469ca5ac2e5ee046d8168b9fc79bd11505428e2cd877c9bf32c64c16
-EBUILD python-ptrace-0.6.ebuild 696 RMD160 7ee5786bc358c50de9196a1f52b6d7b3bdeaf63f SHA1 769e3235df4e72c9a05a4f7f80e4ab9d393620b8 SHA256 428c4003e0e206019ea91e58726feb2479f8c4872ac6f0df8b4df82f759abc37
-MISC ChangeLog 663 RMD160 ba97352faea87ccfe14479be076dcddba43e8466 SHA1 999bcf01d1a5ce248620fb2e2308e941345e5ee3 SHA256 0d54a22641c7c137479a00c92742c3ff0e0ce63357aca4505cf8f31864f23e9d
+EBUILD python-ptrace-0.6.ebuild 1218 RMD160 467c408a91ff2c15a9851d8ad599ac874e999b97 SHA1 1e4abe1011b51b85a8931c708a17fa978cc14320 SHA256 8b5f1e5920daf5ff939e3807f08b0f127b2904e5e8103cade6ae208a0e6dd9d1
+MISC ChangeLog 793 RMD160 01e05be05bb3371e8341fdbd035497f939b075d2 SHA1 2d0c9b97685a86005e545045b69c2831b81b251a SHA256 6c613916f57783207ad2179e7bdf5664e83233695f052f03e25d7418b9c4aa34
MISC metadata.xml 295 RMD160 2d0d74511d9948a5a9c40446bcb28c9268b4fb56 SHA1 471e08e1b94c6ab1cecaef9842eacaac847ceba1 SHA256 4da348dee3ad8dabd6d9d2aa47be39545e10fe2efd04766bd6a2dffdac43455c
diff --git a/dev-python/python-ptrace/python-ptrace-0.6.ebuild b/dev-python/python-ptrace/python-ptrace-0.6.ebuild
index 48ce4d0d9969..a97dc96f634f 100644
--- a/dev-python/python-ptrace/python-ptrace-0.6.ebuild
+++ b/dev-python/python-ptrace/python-ptrace-0.6.ebuild
@@ -1,21 +1,39 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ptrace/python-ptrace-0.6.ebuild,v 1.1 2009/02/28 19:31:22 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ptrace/python-ptrace-0.6.ebuild,v 1.2 2009/09/18 12:19:53 arfrever Exp $
-NEED_PYTHON=2.4
+EAPI="2"
+
+NEED_PYTHON="2.5"
+SUPPORT_PYTHON_ABIS="1"
inherit distutils
DESCRIPTION="python-ptrace is a debugger using ptrace (Linux, BSD and Darwin system call to trace processes)."
-HOMEPAGE="http://python-ptrace.hachoir.org/"
-SRC_URI="http://pypi.python.org/packages/source/p/python-ptrace/${P}.tar.gz"
+HOMEPAGE="http://bitbucket.org/haypo/python-ptrace/wiki/Home http://pypi.python.org/pypi/python-ptrace"
+SRC_URI="http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~amd64"
+KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND="|| ( ( =dev-lang/python-2.4* dev-python/ctypes ) >=dev-lang/python-2.5 )"
+DEPEND=""
RDEPEND="dev-libs/distorm64"
+RESTRICT_PYTHON_ABIS="2.4"
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
PYTHON_MODNAME="ptrace"
+
+src_prepare() {
+ python_copy_sources --no-link
+
+ conversion() {
+ [[ "${PYTHON_ABI}" == 2.* ]] && return
+
+ 2to3-${PYTHON_ABI} -w . > /dev/null || die "2to3 failed"
+ 2to3-${PYTHON_ABI} -dw . > /dev/null || die "2to3 failed"
+ epatch python3.0.patch
+ }
+ python_execute_function --action-message 'Applying patches for Python ${PYTHON_ABI}' --failure-message 'Applying patches for Python ${PYTHON_ABI} failed' -s conversion
+}