summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJ Robert Ray <jrray@gentoo.org>2002-12-20 10:13:33 +0000
committerJ Robert Ray <jrray@gentoo.org>2002-12-20 10:13:33 +0000
commitfe30b84eee03c0202fca1c795312cdd99263f7ca (patch)
treee99cf8a9d473f00264309f4dd587a9d9839c0430 /dev-python/python-docs
parentnew ebuild (diff)
downloadhistorical-fe30b84eee03c0202fca1c795312cdd99263f7ca.tar.gz
historical-fe30b84eee03c0202fca1c795312cdd99263f7ca.tar.bz2
historical-fe30b84eee03c0202fca1c795312cdd99263f7ca.zip
Create PYTHONDOCS env var, closes bug 12139.
Diffstat (limited to 'dev-python/python-docs')
-rw-r--r--dev-python/python-docs/ChangeLog9
-rw-r--r--dev-python/python-docs/files/digest-python-docs-2.2.1-r11
-rw-r--r--dev-python/python-docs/python-docs-2.2.1-r1.ebuild30
3 files changed, 39 insertions, 1 deletions
diff --git a/dev-python/python-docs/ChangeLog b/dev-python/python-docs/ChangeLog
index 3e2092f12559..3df289c5846c 100644
--- a/dev-python/python-docs/ChangeLog
+++ b/dev-python/python-docs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/python-docs
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/ChangeLog,v 1.6 2002/12/13 10:56:45 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/ChangeLog,v 1.7 2002/12/20 10:13:33 jrray Exp $
+
+*python-docs-2.2.1-r1 (20 Dec 2002)
+
+ 20 Dec 2002; J Robert Ray <jrray@gentoo.org> python-docs-2.2.1-r1.ebuild :
+ Create an env variable PYTHONDOCS pointing to the installation path of the
+ docs, fixing bug 12139. Also, changed ${P} to ${PF} in the destination path,
+ to match the actual location created by docinto().
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
diff --git a/dev-python/python-docs/files/digest-python-docs-2.2.1-r1 b/dev-python/python-docs/files/digest-python-docs-2.2.1-r1
new file mode 100644
index 000000000000..1a027d8de1c1
--- /dev/null
+++ b/dev-python/python-docs/files/digest-python-docs-2.2.1-r1
@@ -0,0 +1 @@
+MD5 4c04d71113914c7e4619ff7dc732dbbd html-2.2.1.tar.bz2 944676
diff --git a/dev-python/python-docs/python-docs-2.2.1-r1.ebuild b/dev-python/python-docs/python-docs-2.2.1-r1.ebuild
new file mode 100644
index 000000000000..d85343aa6f8a
--- /dev/null
+++ b/dev-python/python-docs/python-docs-2.2.1-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-2.2.1-r1.ebuild,v 1.1 2002/12/20 10:13:33 jrray Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="HTML documentation for Python"
+SRC_URI="http://www.python.org/ftp/python/doc/${PV}/html-${PV}.tar.bz2"
+HOMEPAGE="http://www.python.org/doc/2.2/"
+DEPEND=""
+RDEPEND=""
+SLOT="2.2"
+LICENSE="PSF-2.2"
+KEYWORDS="x86 ppc sparc alpha"
+
+src_unpack() {
+ mkdir ${S}
+ cd ${S}
+ unpack ${A}
+}
+
+
+src_install() {
+ docinto html
+ cp -R ${S}/* ${D}/usr/share/doc/${PF}/html
+ chown -R root.root ${D}/usr/share/doc/${PF}/html
+ find ${D}/usr/share/doc/${PF}/html -type d -exec chmod 0755 \{\} \;
+ find ${D}/usr/share/doc/${PF}/html -type f -exec chmod 0644 \{\} \;
+ dodir /etc/env.d
+ echo "PYTHONDOCS=/usr/share/doc/${PF}/html" > ${D}/etc/env.d/50python-docs
+}