summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2008-02-23 13:21:09 +0000
committerTiziano Müller <dev-zero@gentoo.org>2008-02-23 13:21:09 +0000
commitbcd5962fda712c4f4c0f34eae39b849b84173be9 (patch)
treeb8fe660558ff501ba41b6fb004ca0e6a53ef841e /dev-python/pytables
parentmedia-video/mplayer: drop unused dvdnav, add color-console (diff)
downloadhistorical-bcd5962fda712c4f4c0f34eae39b849b84173be9.tar.gz
historical-bcd5962fda712c4f4c0f34eae39b849b84173be9.tar.bz2
historical-bcd5962fda712c4f4c0f34eae39b849b84173be9.zip
Version bump (bug #196062). Fixed dependency in 1.4 (bug #211106, thanks to Chris Kerr). Added tests for both. Note: 1.4 is deprecated and 3 tests fail on x86_64 ant won't be fixed. Since 1.4 and 2.x are not compatible, 1.4 hasn't been dropped for now. Fixed wrong license.
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'dev-python/pytables')
-rw-r--r--dev-python/pytables/ChangeLog13
-rw-r--r--dev-python/pytables/pytables-1.4.ebuild26
-rw-r--r--dev-python/pytables/pytables-2.0.2.ebuild52
3 files changed, 79 insertions, 12 deletions
diff --git a/dev-python/pytables/ChangeLog b/dev-python/pytables/ChangeLog
index 52e393e77103..4591894504f7 100644
--- a/dev-python/pytables/ChangeLog
+++ b/dev-python/pytables/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-python/pytables
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytables/ChangeLog,v 1.24 2007/05/05 08:53:44 lucass Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytables/ChangeLog,v 1.25 2008/02/23 13:21:09 dev-zero Exp $
+
+*pytables-2.0.2 (23 Feb 2008)
+
+ 23 Feb 2008; Tiziano Müller <dev-zero@gentoo.org> pytables-1.4.ebuild,
+ +pytables-2.0.2.ebuild:
+ Version bump (bug #196062). Fixed dependency in 1.4 (bug #211106, thanks to
+ Chris Kerr). Added tests for both. Note: 1.4 is deprecated and 3 tests fail
+ on x86_64 ant won't be fixed. Since 1.4 and 2.x are not compatible, 1.4
+ hasn't been dropped for now. Fixed wrong license.
05 May 2007; Lukasz Strzygowski <lucass@gentoo.org>
-pytables-0.7.2.ebuild, -pytables-0.8.1.ebuild, -pytables-0.9.1.ebuild,
diff --git a/dev-python/pytables/pytables-1.4.ebuild b/dev-python/pytables/pytables-1.4.ebuild
index 25b2e3254e42..eda544f584fe 100644
--- a/dev-python/pytables/pytables-1.4.ebuild
+++ b/dev-python/pytables/pytables-1.4.ebuild
@@ -1,26 +1,26 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytables/pytables-1.4.ebuild,v 1.2 2007/05/05 08:53:44 lucass Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytables/pytables-1.4.ebuild,v 1.3 2008/02/23 13:21:09 dev-zero Exp $
-NEED_PYTHON=2.2
+NEED_PYTHON="2.2"
inherit distutils
DESCRIPTION="Module for Python that use HDF5"
SRC_URI="mirror://sourceforge/pytables/${P}.tar.gz"
HOMEPAGE="http://pytables.sourceforge.net/"
-
-DEPEND=">=sys-devel/gcc-3.2
- sci-libs/hdf5
- >=dev-python/numarray-1.0"
-
SLOT="0"
KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
-LICENSE="as-is"
+LICENSE="BSD"
IUSE="doc examples"
-DOCS="ANNOUNCE.txt RELEASE-NOTES.txt THANKS TODO.txt VERSION"
+
+DEPEND="sci-libs/hdf5
+ >=dev-python/numarray-1.5.2"
+RDEPEND="${DEPEND}"
src_install() {
+ DOCS="ANNOUNCE.txt RELEASE-NOTES.txt THANKS TODO.txt VERSION"
+
distutils_src_install
if use examples; then
@@ -40,3 +40,9 @@ src_install() {
doins -r usersguide.pdf scripts/
fi
}
+
+src_test() {
+ python_version
+ "${python}" setup.py install --root="${T}" --no-compile "$@" || die "temporary install failed"
+ PYTHONPATH="${T}/usr/$(get_libdir)/python${PYVER}/site-packages" "${python}" tables/tests/test_all.py || die "tests failed"
+}
diff --git a/dev-python/pytables/pytables-2.0.2.ebuild b/dev-python/pytables/pytables-2.0.2.ebuild
new file mode 100644
index 000000000000..ec23216a27a4
--- /dev/null
+++ b/dev-python/pytables/pytables-2.0.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytables/pytables-2.0.2.ebuild,v 1.1 2008/02/23 13:21:09 dev-zero Exp $
+
+EAPI="1"
+NEED_PYTHON="2.2"
+
+inherit distutils multilib
+
+DESCRIPTION="A package for managing hierarchical datasets built on top of the HDF5 library."
+SRC_URI="http://www.pytables.org/download/stable/${P}.tar.gz"
+HOMEPAGE="http://www.pytables.org/"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+LICENSE="BSD"
+IUSE="doc examples"
+
+DEPEND="sci-libs/hdf5
+ >=dev-python/numpy-1.0.3
+ dev-libs/lzo:2
+ app-arch/bzip2"
+RDEPEND="${DEPEND}"
+
+
+src_install() {
+ DOCS="ANNOUNCE.txt MIGRATING_TO_2.x.txt RELEASE_NOTES.txt THANKS TODO.txt VERSION"
+
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+
+ if use doc; then
+ cd doc
+
+ dohtml -r html/*
+
+ docinto text
+ dodoc text/*
+
+ insinto /usr/share/doc/${PF}
+ doins -r usersguide.pdf scripts/
+ fi
+}
+
+src_test() {
+ python_version
+ "${python}" setup.py install --root="${T}" --no-compile "$@" || die "temporary install failed"
+ PYTHONPATH="${T}/usr/$(get_libdir)/python${PYVER}/site-packages" "${python}" tables/tests/test_all.py || die "tests failed"
+}