summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-07-30 08:32:24 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-07-30 08:32:24 +0000
commit67c71ebe45df1471baedcae34bf35559c93bf5ee (patch)
treebab3121923fcde4042dafa5cdf0297b48eedf21d /dev-python/pysqlite
parentnew license (diff)
downloadhistorical-67c71ebe45df1471baedcae34bf35559c93bf5ee.tar.gz
historical-67c71ebe45df1471baedcae34bf35559c93bf5ee.tar.bz2
historical-67c71ebe45df1471baedcae34bf35559c93bf5ee.zip
new package.
Diffstat (limited to 'dev-python/pysqlite')
-rw-r--r--dev-python/pysqlite/ChangeLog7
-rw-r--r--dev-python/pysqlite/files/digest-pysqlite-0.2.01
-rw-r--r--dev-python/pysqlite/pysqlite-0.2.0.ebuild24
3 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pysqlite/ChangeLog b/dev-python/pysqlite/ChangeLog
new file mode 100644
index 000000000000..8b648e2a2032
--- /dev/null
+++ b/dev-python/pysqlite/ChangeLog
@@ -0,0 +1,7 @@
+# ChangeLog for dev-python/pysqlite
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysqlite/ChangeLog,v 1.1 2002/07/30 08:32:24 rphillips Exp $
+
+*pysqlite-0.2.0 (30 Jul 2002)
+
+ 30 Jul 2002; Ryan Phillips <rphillips@gentoo.org> pysqlite-0.2.0.ebuild : Initial. Submitted by me.
diff --git a/dev-python/pysqlite/files/digest-pysqlite-0.2.0 b/dev-python/pysqlite/files/digest-pysqlite-0.2.0
new file mode 100644
index 000000000000..44ec3655afdb
--- /dev/null
+++ b/dev-python/pysqlite/files/digest-pysqlite-0.2.0
@@ -0,0 +1 @@
+MD5 c6d454a907f0351501c19feb9765443b pysqlite-0.2.0.tar.gz 73916
diff --git a/dev-python/pysqlite/pysqlite-0.2.0.ebuild b/dev-python/pysqlite/pysqlite-0.2.0.ebuild
new file mode 100644
index 000000000000..e96075b6c80e
--- /dev/null
+++ b/dev-python/pysqlite/pysqlite-0.2.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysqlite/pysqlite-0.2.0.ebuild,v 1.1 2002/07/30 08:32:24 rphillips Exp $
+
+S="${WORKDIR}/${P}"
+
+DESCRIPTION="Python wrapper for the local database Sqlite"
+SRC_URI="mirror://sourceforge/pysqlite/pysqlite-${PV}.tar.gz"
+HOMEPAGE="http://www.hwaci.com/sw/sqlite/"
+DEPEND="virtual/python
+ dev-db/sqlite"
+RDEPEND="${DEPEND}"
+KEYWORDS="x86"
+LICENSE="pysqlite"
+SLOT="0"
+
+src_compile() {
+ python setup.py build || die
+}
+
+src_install () {
+ python setup.py install --root=${D} --prefix=/usr || die
+ dodoc *.txt examples/*
+}