summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2004-07-07 02:34:39 +0000
committerAlastair Tse <liquidx@gentoo.org>2004-07-07 02:34:39 +0000
commitcffd1a7a518a99e6840fa5ecf62bbf78791d4554 (patch)
tree83e435db637d188041d9724add889e412e613b17 /dev-python/pyro
parentStable on alpha. (diff)
downloadhistorical-cffd1a7a518a99e6840fa5ecf62bbf78791d4554.tar.gz
historical-cffd1a7a518a99e6840fa5ecf62bbf78791d4554.tar.bz2
historical-cffd1a7a518a99e6840fa5ecf62bbf78791d4554.zip
fix overwriting /usr/bin/esd temporarily be renaming esd to pyroesd. (#56096)
Diffstat (limited to 'dev-python/pyro')
-rw-r--r--dev-python/pyro/ChangeLog8
-rw-r--r--dev-python/pyro/Manifest6
-rw-r--r--dev-python/pyro/files/digest-pyro-3.3-r11
-rw-r--r--dev-python/pyro/pyro-3.3-r1.ebuild39
-rw-r--r--dev-python/pyro/pyro-3.3.ebuild4
5 files changed, 54 insertions, 4 deletions
diff --git a/dev-python/pyro/ChangeLog b/dev-python/pyro/ChangeLog
index c8507c48e813..ce4fa8ddec00 100644
--- a/dev-python/pyro/ChangeLog
+++ b/dev-python/pyro/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pyro
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/ChangeLog,v 1.3 2004/06/25 01:43:10 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/ChangeLog,v 1.4 2004/07/07 02:34:39 liquidx Exp $
+
+*pyro-3.3-r1 (07 Jul 2004)
+
+ 07 Jul 2004; Alastair Tse <liquidx@gentoo.org> +pyro-3.3-r1.ebuild,
+ pyro-3.3.ebuild:
+ fix overwriting /usr/bin/esd temporarily be renaming esd to pyroesd. (#56096)
17 Feb 2004; <kloeri@gentoo.org> pyro-3.3.ebuild:
Add missing SLOT.
diff --git a/dev-python/pyro/Manifest b/dev-python/pyro/Manifest
index af28b14fe758..2996a67f3696 100644
--- a/dev-python/pyro/Manifest
+++ b/dev-python/pyro/Manifest
@@ -1,5 +1,7 @@
-MD5 52d0cc9463e84081720e8d91cf295ecd pyro-3.3.ebuild 761
-MD5 382fabd2d8aef7dffaa4c12c3313ad08 ChangeLog 407
+MD5 66a693ae24cb65138f5e09ecb4188bb5 ChangeLog 604
MD5 71c4638c9c88af75b58e5f5cb54fe008 metadata.xml 159
+MD5 db1b122d710e2c26d2e774ffc03ec5d9 pyro-3.3.ebuild 795
+MD5 8d79bb4a9aae8d06dd1396553a3963b5 pyro-3.3-r1.ebuild 966
MD5 cdae824e917caf8378aaa36510f771b5 files/digest-pyro-3.3 60
MD5 8415324a478ba3479fe4422e81739853 files/pyro-3.3-unattend.patch 419
+MD5 cdae824e917caf8378aaa36510f771b5 files/digest-pyro-3.3-r1 60
diff --git a/dev-python/pyro/files/digest-pyro-3.3-r1 b/dev-python/pyro/files/digest-pyro-3.3-r1
new file mode 100644
index 000000000000..117f50467f1a
--- /dev/null
+++ b/dev-python/pyro/files/digest-pyro-3.3-r1
@@ -0,0 +1 @@
+MD5 09faeec7aa07e88187902f42d74a4514 Pyro-3.3.tar.gz 199251
diff --git a/dev-python/pyro/pyro-3.3-r1.ebuild b/dev-python/pyro/pyro-3.3-r1.ebuild
new file mode 100644
index 000000000000..7f60d37bbd99
--- /dev/null
+++ b/dev-python/pyro/pyro-3.3-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/pyro-3.3-r1.ebuild,v 1.1 2004/07/07 02:34:39 liquidx Exp $
+
+inherit distutils eutils
+
+MY_P="Pyro-${PV}"
+DESCRIPTION="advanced and powerful Distributed Object Technology system written entirely in Python"
+HOMEPAGE="http://pyro.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pyro/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="virtual/python"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-unattend.patch
+}
+
+src_install() {
+ distutils_src_install
+
+ dodir /usr/share/doc/${PF}/examples
+ cp -r ${S}/examples ${D}/usr/share/doc/${PF}
+ dohtml -r docs/*
+
+ mv ${D}/usr/bin/esd ${D}/usr/bin/pyroesd
+}
+
+pkg_postinst() {
+ einfo "Pyro's Event Service Daemon, /usr/bin/esd has been renamed to"
+ einfo " /usr/bin/pyroesd to avoid conflict with media-sound/esound."
+} \ No newline at end of file
diff --git a/dev-python/pyro/pyro-3.3.ebuild b/dev-python/pyro/pyro-3.3.ebuild
index 4f43523da096..0dc88ed718b6 100644
--- a/dev-python/pyro/pyro-3.3.ebuild
+++ b/dev-python/pyro/pyro-3.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/pyro-3.3.ebuild,v 1.4 2004/06/25 01:43:10 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/pyro-3.3.ebuild,v 1.5 2004/07/07 02:34:39 liquidx Exp $
inherit distutils eutils
@@ -29,4 +29,6 @@ src_install() {
dodir /usr/share/doc/${PF}/examples
cp -r ${S}/examples ${D}/usr/share/doc/${PF}
dohtml -r docs/*
+
+ mv /usr/bin/esd /usr/bin/pyroesd
}