summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-06-01 14:44:46 +0000
committerJeroen Roovers <jer@gentoo.org>2010-06-01 14:44:46 +0000
commita2fd73064169b7357d4715f73b5be6aa61a7ae1c (patch)
tree132babbd8270be306df4b46f8a12b8f75fd372e8 /dev-python/pyparted/pyparted-3.4.ebuild
parentDelete older ebuild. (diff)
downloadhistorical-a2fd73064169b7357d4715f73b5be6aa61a7ae1c.tar.gz
historical-a2fd73064169b7357d4715f73b5be6aa61a7ae1c.tar.bz2
historical-a2fd73064169b7357d4715f73b5be6aa61a7ae1c.zip
Version bump.
Package-Manager: portage-2.2_rc67/cvs/Linux i686
Diffstat (limited to 'dev-python/pyparted/pyparted-3.4.ebuild')
-rw-r--r--dev-python/pyparted/pyparted-3.4.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pyparted/pyparted-3.4.ebuild b/dev-python/pyparted/pyparted-3.4.ebuild
new file mode 100644
index 000000000000..c36876aaacff
--- /dev/null
+++ b/dev-python/pyparted/pyparted-3.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/pyparted-3.4.ebuild,v 1.1 2010/06/01 14:44:46 jer Exp $
+
+EAPI="2"
+
+inherit autotools multilib python
+
+DESCRIPTION="Python bindings for sys-apps/parted"
+HOMEPAGE="https://fedorahosted.org/pyparted/"
+SRC_URI="https://fedorahosted.org/releases/p/y/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="
+ sys-libs/ncurses
+ >=dev-lang/python-2.4
+ >=sys-apps/parted-2.1
+ dev-python/decorator
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e 's/-avoid-version/& -shared /' src/Makefile.am || die "sed failed"
+ eautoreconf
+}
+
+src_install() {
+ python_need_rebuild
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog NEWS README TODO
+ # remove pointless libtool archive
+ python_version
+ rm -f "${D}"/usr/$(get_libdir)/python${PYVER}/site-packages/_pedmodule.la
+
+}