summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-02-16 19:36:32 +0000
committerJustin Lecher <jlec@gentoo.org>2012-02-16 19:36:32 +0000
commitd78c756bf722600a681faa08e385bcbec23db7c2 (patch)
tree0a2f30f93f7c2226cc5513b0d8e1e905d6fac9a6 /dev-python/pympler
parentx86 stable wrt bug #397279 (diff)
downloadhistorical-d78c756bf722600a681faa08e385bcbec23db7c2.tar.gz
historical-d78c756bf722600a681faa08e385bcbec23db7c2.tar.bz2
historical-d78c756bf722600a681faa08e385bcbec23db7c2.zip
Initial commit written by me
Package-Manager: portage-2.2.0_alpha86/cvs/Linux x86_64
Diffstat (limited to 'dev-python/pympler')
-rw-r--r--dev-python/pympler/ChangeLog10
-rw-r--r--dev-python/pympler/Manifest14
-rw-r--r--dev-python/pympler/metadata.xml15
-rw-r--r--dev-python/pympler/pympler-0.2.0.ebuild27
4 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/pympler/ChangeLog b/dev-python/pympler/ChangeLog
new file mode 100644
index 000000000000..4d87ab1edca4
--- /dev/null
+++ b/dev-python/pympler/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/pympler
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pympler/ChangeLog,v 1.1 2012/02/16 19:36:32 jlec Exp $
+
+*pympler-0.2.0 (16 Feb 2012)
+
+ 16 Feb 2012; Justin Lecher <jlec@gentoo.org> +pympler-0.2.0.ebuild,
+ +metadata.xml:
+ Initial commit written by me
+
diff --git a/dev-python/pympler/Manifest b/dev-python/pympler/Manifest
new file mode 100644
index 000000000000..4c7c09333b3b
--- /dev/null
+++ b/dev-python/pympler/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA512
+
+DIST pympler-0.2.0.tar.xz 206996 RMD160 165eebbd110c5efeef1d2643c4db42c77ceb002f SHA1 3d6936549b0196fd9a03221d5fc0ea9dc00e767b SHA256 c2c52a7f6126a11b982d4fb6096f261c4aea6a1f38e4ab36329d025d3eeac56e
+EBUILD pympler-0.2.0.ebuild 739 RMD160 ba827369a73d8b52d60397d183ed0c2d83eab539 SHA1 bd99fb371bd7a02296c5ad670434973f6551124c SHA256 c2f2a22b1fea3811ea4303953eb50f1aff56287232b86064f27b53e4fe8584e3
+MISC ChangeLog 356 RMD160 dd2a093eeaff9f341b075cc881d77e0b35cf8e95 SHA1 acbbf72d93f32a3abe975eff0098185766de792e SHA256 77382b1185212096857b264bf721bdaa67932d1ce4db72d5f8f496e50f9271ca
+MISC metadata.xml 619 RMD160 35a55730633fb10a6e86acfdd572271e81162e90 SHA1 240d07d3cc218661e04262334996ca32af346f3c SHA256 a1420ea0d9131fb6a619769e6bb18adeff76870a506e09db220fe1df738198e2
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.18 (GNU/Linux)
+
+iEYEAREKAAYFAk89WsUACgkQgAnW8HDreRZSYwCeIHVN9yu7ER5PwlhmdpdEJt6K
+dlYAoM3rUpLUIuAtsH1RKZHZ0v+syxWk
+=sy0S
+-----END PGP SIGNATURE-----
diff --git a/dev-python/pympler/metadata.xml b/dev-python/pympler/metadata.xml
new file mode 100644
index 000000000000..29586bc1dc24
--- /dev/null
+++ b/dev-python/pympler/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+Pympler is a development tool to measure, monitor and analyze the memory
+behavior of Python objects in a running Python application. By pympling a
+Python application, detailed insight in the size and the lifetime of Python
+objects can be obtained. Undesirable or unexpected runtime behavior like
+memory bloat and other "pymples" can easily be identified.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-python/pympler/pympler-0.2.0.ebuild b/dev-python/pympler/pympler-0.2.0.ebuild
new file mode 100644
index 000000000000..0813eb40e71e
--- /dev/null
+++ b/dev-python/pympler/pympler-0.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pympler/pympler-0.2.0.ebuild,v 1.1 2012/02/16 19:36:32 jlec Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="memory profiling for Python applications"
+HOMEPAGE="http://code.google.com/p/pympler/"
+SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="Apache-2.0"
+IUSE=""
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" setup.py test
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" run.py --test --clean
+ }
+ python_execute_function testing
+}