summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2011-12-24 15:41:51 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2011-12-24 15:41:51 +0000
commit14f76387b5957a989e8defa749970595ab6f1e9f (patch)
treed1d03e5217a2f41659fc7715ca0e780ac5374262 /dev-python/pydb
parentVersion bump; tests are enabled, but there is a failure still, which needs to... (diff)
downloadhistorical-14f76387b5957a989e8defa749970595ab6f1e9f.tar.gz
historical-14f76387b5957a989e8defa749970595ab6f1e9f.tar.bz2
historical-14f76387b5957a989e8defa749970595ab6f1e9f.zip
Pythonize ebuild, add support for multiple python ABIs
Package-Manager: portage-2.1.10.41/cvs/Linux x86_64
Diffstat (limited to 'dev-python/pydb')
-rw-r--r--dev-python/pydb/ChangeLog7
-rw-r--r--dev-python/pydb/Manifest3
-rw-r--r--dev-python/pydb/pydb-1.26-r1.ebuild49
3 files changed, 57 insertions, 2 deletions
diff --git a/dev-python/pydb/ChangeLog b/dev-python/pydb/ChangeLog
index 36a32f1bd62d..2e26d09113b0 100644
--- a/dev-python/pydb/ChangeLog
+++ b/dev-python/pydb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pydb
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pydb/ChangeLog,v 1.5 2011/12/24 13:21:05 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pydb/ChangeLog,v 1.6 2011/12/24 15:41:51 maksbotan Exp $
+
+*pydb-1.26-r1 (24 Dec 2011)
+
+ 24 Dec 2011; Maxim Koltsov <maksbotan@gentoo.org> +pydb-1.26-r1.ebuild:
+ Pythonize ebuild, add support for multiple python ABIs
24 Dec 2011; Andrey Grozin <grozin@gentoo.org> pydb-1.26.ebuild:
Bug #379193 fixed, thanks to Ulrich Müller <ulm@gentoo.org>
diff --git a/dev-python/pydb/Manifest b/dev-python/pydb/Manifest
index 61343fb55e4b..0e3e265be5dc 100644
--- a/dev-python/pydb/Manifest
+++ b/dev-python/pydb/Manifest
@@ -1,4 +1,5 @@
DIST pydb-1.26.tar.bz2 572184 RMD160 ecefe104f58b0857ec2e17d6d0421e28030d6160 SHA1 7f2de4530c3399cfb380fccdc440f5a8e14cc989 SHA256 01131848a58fce6a529766488884848c06068aa9ec4f39e19f8fb4d260f893f2
+EBUILD pydb-1.26-r1.ebuild 1338 RMD160 b78e392c4b1d87cffc966fa2a680011f0fa4705d SHA1 ab0dbccb27106bee767c1bca338c958cc2308e98 SHA256 f9fda38645c879729b0a3078419848a345e1aa8bb79d7bac0e61ecaf3c18d192
EBUILD pydb-1.26.ebuild 873 RMD160 689b638bfab9044fc76e8d4b38017b142c5d5ba3 SHA1 a57ee242aa10183bc262269bd33aee2f28a17526 SHA256 46c48307d5b721f41c469599e7017e6b67911c9764e567eaa009cf8c0df43bf6
-MISC ChangeLog 742 RMD160 9bbe97e2fe4371bdf5c6c7b87051f246f79d11e5 SHA1 cca525e5a309e5d0840f953ed51e565b12b03e71 SHA256 5dbaf587ac539a5c7f6cd8e28617b14c9d41092f1cf75ba6a634c5e9f1047e19
+MISC ChangeLog 906 RMD160 33c52d8e49643e30e0849e06f0e69a65d214acb0 SHA1 0781c376c23dbbe2338df07e460bb038a731fcbd SHA256 a610db7dcbced155f40f8aa770f88498180fc043de4179a651f9a285ba134120
MISC metadata.xml 314 RMD160 122a3f09eb67c552d6aafe5104afaa7758204ebe SHA1 07a94cc27a901bc6aa6a9f357dc056254507f7ef SHA256 39e7e6e79a87600d9098557feda0da997fb238adc03130e52eef4b7c4f250c86
diff --git a/dev-python/pydb/pydb-1.26-r1.ebuild b/dev-python/pydb/pydb-1.26-r1.ebuild
new file mode 100644
index 000000000000..a2af8c36f32a
--- /dev/null
+++ b/dev-python/pydb/pydb-1.26-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pydb/pydb-1.26-r1.ebuild,v 1.1 2011/12/24 15:41:51 maksbotan Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.4"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+PYTHON_EXPORT_PHASE_FUNCTIONS="1"
+
+inherit elisp-common python
+
+DESCRIPTION="Extended python debugger"
+HOMEPAGE="http://bashdb.sourceforge.net/pydb/"
+SRC_URI="mirror://sourceforge/bashdb/${P}.tar.bz2"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="emacs"
+
+DEPEND="
+ emacs? ( virtual/emacs )"
+RDEPEND="${DEPEND}"
+
+# This package uses not distutils but the usual
+# ./configure; make; make install
+# The default src_compile is OK
+
+src_configure() {
+ configuration() {
+ econf --with-lispdir="${SITELISP}/${PN}" \
+ EMACS="$(use emacs && echo "${EMACS}" || echo no)" \
+ --with-site-packages=$(python_get_sitedir) \
+ --with-python=$(PYTHON -a)
+ }
+ python_execute_function -s configuration
+}
+
+src_install() {
+ installation(){
+ emake DESTDIR="${D}" install || die "emake install failed"
+ mv "${ED}"/usr/bin/${PN} "${ED}"/usr/bin/${PN}-${PYTHON_ABI} || die
+ }
+ python_execute_function -s installation
+ python_generate_wrapper_scripts "${ED}"/usr/bin/${PN}
+
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO || die "dodoc failed"
+}