summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-08-05 22:54:34 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-08-05 22:54:34 +0000
commit94ce351ad80d4874c5e09db02d5bec4fbf619b59 (patch)
treec99d3bca7ef8bd8d75af363d009baf6d5dab053f /dev-python/pip
parentadded autotools eclass (diff)
downloadhistorical-94ce351ad80d4874c5e09db02d5bec4fbf619b59.tar.gz
historical-94ce351ad80d4874c5e09db02d5bec4fbf619b59.tar.bz2
historical-94ce351ad80d4874c5e09db02d5bec4fbf619b59.zip
Remove old ebuild. Requested by Arfrever
Package-Manager: portage-2.2.0_alpha50/cvs/Linux x86_64
Diffstat (limited to 'dev-python/pip')
-rw-r--r--dev-python/pip/ChangeLog5
-rw-r--r--dev-python/pip/pip-1.0.1.ebuild49
2 files changed, 4 insertions, 50 deletions
diff --git a/dev-python/pip/ChangeLog b/dev-python/pip/ChangeLog
index f4cd28a519e0..005194826d77 100644
--- a/dev-python/pip/ChangeLog
+++ b/dev-python/pip/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/pip
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/ChangeLog,v 1.2 2011/07/20 05:44:45 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/ChangeLog,v 1.3 2011/08/05 22:44:16 hwoarang Exp $
+
+ 05 Aug 2011; Markos Chandras <hwoarang@gentoo.org> -pip-1.0.1.ebuild:
+ Remove old ebuild. Requested by Arfrever
*pip-1.0.2 (20 Jul 2011)
diff --git a/dev-python/pip/pip-1.0.1.ebuild b/dev-python/pip/pip-1.0.1.ebuild
deleted file mode 100644
index 58fb35512ac8..000000000000
--- a/dev-python/pip/pip-1.0.1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/pip-1.0.1.ebuild,v 1.1 2011/05/31 11:45:36 radhermit Exp $
-
-EAPI="3"
-PYTHON_DEPEND="*"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit bash-completion distutils eutils
-
-DESCRIPTION="Installs python packages -- replacement for easy_install"
-HOMEPAGE="http://www.pip-installer.org/ http://pypi.python.org/pypi/pip/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-IUSE="bash-completion zsh-completion"
-
-RDEPEND="dev-python/setuptools"
-DEPEND="${RDEPEND}"
-
-# Tests require a couple libraries not yet in the tree, aren't bundled with
-# the default tarball from pypi, and have a couple failures anyway
-RESTRICT="test"
-
-DOCS="docs/configuration.txt docs/how-to-contribute.txt docs/index.txt
- docs/news.txt docs/requirement-format.txt"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-unversioned.patch
- distutils_src_prepare
-}
-
-src_install() {
- distutils_src_install
- COMPLETION="${T}/completion.tmp"
-
- if use bash-completion ; then
- "$(PYTHON -f)" pip/runner.py completion --bash > "${COMPLETION}" || die
- dobashcompletion "${COMPLETION}" ${PN}
- fi
-
- if use zsh-completion ; then
- "$(PYTHON -f)" pip/runner.py completion --zsh > "${COMPLETION}" || die
- insinto /usr/share/zsh/site-functions
- newins "${COMPLETION}" _pip || die
- fi
-}