summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-04-26 09:53:29 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-04-26 09:53:29 +0000
commitb724e5dcf6da7f5f0a8fa89ad90b696c83dede8b (patch)
treeddb28f48f4382ddb6521dbe91d1d958b6a170669 /dev-python/pastescript
parentBump to 0.9.6.1, dep for bug #260168 (diff)
downloadhistorical-b724e5dcf6da7f5f0a8fa89ad90b696c83dede8b.tar.gz
historical-b724e5dcf6da7f5f0a8fa89ad90b696c83dede8b.tar.bz2
historical-b724e5dcf6da7f5f0a8fa89ad90b696c83dede8b.zip
Bump to 1.7.3, dep for bug #260168
Package-Manager: portage-2.2_rc31/cvs/Linux x86_64
Diffstat (limited to 'dev-python/pastescript')
-rw-r--r--dev-python/pastescript/ChangeLog9
-rw-r--r--dev-python/pastescript/pastescript-1.7.3.ebuild57
2 files changed, 64 insertions, 2 deletions
diff --git a/dev-python/pastescript/ChangeLog b/dev-python/pastescript/ChangeLog
index ab3bc64914be..3cf74a81b413 100644
--- a/dev-python/pastescript/ChangeLog
+++ b/dev-python/pastescript/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pastescript
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pastescript/ChangeLog,v 1.5 2008/05/13 16:01:15 hawking Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pastescript/ChangeLog,v 1.6 2009/04/26 09:53:29 patrick Exp $
+
+*pastescript-1.7.3 (26 Apr 2009)
+
+ 26 Apr 2009; Patrick Lauer <patrick@gentoo.org> +pastescript-1.7.3.ebuild:
+ Bump to 1.7.3, dep for bug #260168
13 May 2008; Ali Polatel <hawking@gentoo.org> pastescript-1.6.2.ebuild:
USE=doc needs pygments. Thanks to Jack Lloyd, #221949.
diff --git a/dev-python/pastescript/pastescript-1.7.3.ebuild b/dev-python/pastescript/pastescript-1.7.3.ebuild
new file mode 100644
index 000000000000..6c1fe7bb7bb4
--- /dev/null
+++ b/dev-python/pastescript/pastescript-1.7.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pastescript/pastescript-1.7.3.ebuild,v 1.1 2009/04/26 09:53:29 patrick Exp $
+
+NEED_PYTHON=2.4
+
+inherit distutils
+
+KEYWORDS="~amd64 ~x86"
+
+MY_PN=PasteScript
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="A pluggable command-line frontend, including commands to setup package file layouts"
+HOMEPAGE="http://pythonpaste.org/script/"
+SRC_URI="http://cheeseshop.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc test"
+
+RDEPEND="dev-python/paste
+ dev-python/pastedeploy
+ dev-python/cheetah"
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+ doc? ( dev-python/buildutils dev-python/pygments dev-python/pudge )
+ test? ( dev-python/nose )"
+
+# The tests are currently broken, needs further investigation
+RESTRICT=test
+
+S="${WORKDIR}/${MY_P}"
+PYTHON_MODNAME="paste/script"
+
+src_compile() {
+ distutils_src_compile
+ if use doc ; then
+ einfo "Generating docs as requested..."
+ PYTHONPATH=. "${python}" setup.py pudge || die "generating docs failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+ use doc && dohtml -r docs/html/*
+}
+
+src_test() {
+ # Tests can't import paste from site-packages
+ # so we copy them over.
+ # The files that will be installed are already copied to build/lib
+ # so this shouldn't generate any collisions.
+ distutils_python_version
+ cp -pPR /usr/$(get_libdir)/python${PYVER}/site-packages/paste/* paste/
+
+ PYTHONPATH=. "${python}" setup.py nosetests || die "tests failed"
+}