summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-22 20:32:15 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-22 20:32:15 +0000
commitcab8048911b2449b1883bc0beed4a87cbb178548 (patch)
tree2b4bf0d59f52dd09f43a91ae557a1f5a54ca46f8 /dev-python/paste
parentVersion bump. (diff)
downloadhistorical-cab8048911b2449b1883bc0beed4a87cbb178548.tar.gz
historical-cab8048911b2449b1883bc0beed4a87cbb178548.tar.bz2
historical-cab8048911b2449b1883bc0beed4a87cbb178548.zip
Delete older ebuild.
Diffstat (limited to 'dev-python/paste')
-rw-r--r--dev-python/paste/paste-1.7.5.ebuild68
1 files changed, 0 insertions, 68 deletions
diff --git a/dev-python/paste/paste-1.7.5.ebuild b/dev-python/paste/paste-1.7.5.ebuild
deleted file mode 100644
index 82a3e9aa779a..000000000000
--- a/dev-python/paste/paste-1.7.5.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/paste/paste-1.7.5.ebuild,v 1.1 2010/09/14 21:38:27 arfrever Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-DISTUTILS_SRC_TEST="nosetests"
-
-inherit distutils
-
-MY_PN="Paste"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Tools for using a Web Server Gateway Interface stack"
-HOMEPAGE="http://pythonpaste.org http://pypi.python.org/pypi/Paste"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~x86-interix ~amd64-linux ~x86-linux ~x86-macos ~sparc-solaris"
-IUSE="doc flup openid"
-
-RDEPEND="dev-python/setuptools
- flup? ( dev-python/flup )
- openid? ( dev-python/python-openid )"
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx )"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- distutils_src_prepare
-
- # Disable failing tests.
- rm -f tests/test_cgiapp.py
- sed \
- -e "s/test_find_file/_&/" \
- -e "s/test_deep/_&/" \
- -e "s/test_static_parser/_&/" \
- -i tests/test_urlparser.py || die "sed failed"
-}
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- PYTHONPATH="." "$(PYTHON -f)" setup.py build_sphinx || die "Generation of documentation failed"
- fi
-}
-
-# Define custom src_test() due to requirement of PYTHONPATH=".".
-src_test() {
- python_execute_nosetests -P .
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- pushd build/sphinx/html > /dev/null
- docinto html
- cp -R [a-z]* _static "${ED}usr/share/doc/${PF}/html" || die "Installation of documentation failed"
- popd > /dev/null
- fi
-}