summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-27 23:15:35 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-27 23:15:35 +0000
commit0ccb12b477070af8c80d5ab9dc4267a062ed7b9b (patch)
tree593a9eae3a3f064e15d9c99e803c4cf7473d8407 /dev-python/paste
parentFix dependencies. (diff)
downloadhistorical-0ccb12b477070af8c80d5ab9dc4267a062ed7b9b.tar.gz
historical-0ccb12b477070af8c80d5ab9dc4267a062ed7b9b.tar.bz2
historical-0ccb12b477070af8c80d5ab9dc4267a062ed7b9b.zip
Delete older ebuild.
Diffstat (limited to 'dev-python/paste')
-rw-r--r--dev-python/paste/paste-1.7.2.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/dev-python/paste/paste-1.7.2.ebuild b/dev-python/paste/paste-1.7.2.ebuild
deleted file mode 100644
index b16066311286..000000000000
--- a/dev-python/paste/paste-1.7.2.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/paste/paste-1.7.2.ebuild,v 1.7 2010/06/26 03:38:16 sping Exp $
-
-EAPI="2"
-PYTHON_DEPEND="2"
-DISTUTILS_SRC_TEST="py.test"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils
-
-MY_PN="Paste"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Tools for using a Web Server Gateway Interface stack"
-HOMEPAGE="http://pythonpaste.org http://pypi.python.org/pypi/Paste"
-SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~x86-interix ~amd64-linux ~x86-linux ~x86-macos ~sparc-solaris"
-IUSE="doc flup openid"
-
-RDEPEND="flup? ( dev-python/flup )
- openid? ( dev-python/python-openid )"
-DEPEND="${RDEPEND}
- dev-python/setuptools
- doc? ( dev-python/pudge dev-python/buildutils )"
-RESTRICT_PYTHON_ABIS="3.*"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- distutils_src_prepare
-
- sed -i \
- -e '/highlighter/d' \
- setup.cfg || die "sed failed"
-
- # Disable failing tests.
- sed -e "s/test_logger/_&/" -i tests/test_exceptions/test_reporter.py || die "sed failed"
- sed -e "s/test_paste_website/_&/" -i tests/test_proxy.py || die "sed failed"
-}
-
-src_compile() {
- distutils_src_compile
- if use doc; then
- einfo "Generation of documentation"
- PYTHONPATH=. "$(PYTHON -f)" setup.py pudge || die "Generation of documentation failed"
- fi
-}
-
-src_install() {
- distutils_src_install
- use doc && dohtml -r docs/html/*
-}