summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2007-11-02 19:01:56 +0000
committerAli Polatel <hawking@gentoo.org>2007-11-02 19:01:56 +0000
commit9d2bdf54045904e22221504ee4675d52be7de6a9 (patch)
tree0d972fc3c74352c8ee0132c2b4d47f48ec056d1a /dev-python/nevow/nevow-0.9.18.ebuild
parentamd64 stable, bug 195113 (diff)
downloadhistorical-9d2bdf54045904e22221504ee4675d52be7de6a9.tar.gz
historical-9d2bdf54045904e22221504ee4675d52be7de6a9.tar.bz2
historical-9d2bdf54045904e22221504ee4675d52be7de6a9.zip
Version bump. Drop old.
Package-Manager: portage-2.1.3.16
Diffstat (limited to 'dev-python/nevow/nevow-0.9.18.ebuild')
-rw-r--r--dev-python/nevow/nevow-0.9.18.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/nevow/nevow-0.9.18.ebuild b/dev-python/nevow/nevow-0.9.18.ebuild
new file mode 100644
index 000000000000..975c5208bd88
--- /dev/null
+++ b/dev-python/nevow/nevow-0.9.18.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nevow/nevow-0.9.18.ebuild,v 1.1 2007/11/02 19:01:56 hawking Exp $
+
+inherit distutils multilib
+
+DESCRIPTION="A web templating framework that provides LivePage, an automatic AJAX toolkit."
+HOMEPAGE="http://divmod.org/trac/wiki/DivmodNevow"
+SRC_URI="mirror://gentoo/Nevow-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="doc"
+
+DEPEND=">=dev-lang/python-2.4
+ >=dev-python/twisted-2.4
+ dev-python/twisted-web
+ doc? ( dev-python/docutils )"
+
+S=${WORKDIR}/Nevow-${PV}
+
+PYTHON_MODNAME="nevow formless"
+
+src_test() {
+ PYTHONPATH=. trial nevow || die "nevow trial failed"
+ PYTHONPATH=. trial formless || die "formless trial failed"
+}
+
+src_compile() {
+ distutils_src_compile
+ if use doc; then
+ cd doc
+ ${python} make.py || die "documentation building failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+ # mantisia expects js to be under site-packages/
+ # but setup.py doesn't install it
+ python_version
+ insinto /usr/$(get_libdir)/python${PYVER}/site-packages/${PN}
+ doins ${PN}/*.js || die "doins failed"
+ doins -r ${PN}/js || die "doins failed"
+ if use doc; then
+ insinto /usr/share/doc/${PF}/
+ doins -r doc/txt doc/html examples
+ fi
+}