summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando Serboncini <fserb@gentoo.org>2005-03-22 15:51:44 +0000
committerFernando Serboncini <fserb@gentoo.org>2005-03-22 15:51:44 +0000
commit5ecd3cf1c46606d32f969b18ff17784b8606876e (patch)
tree3ffb6a5b8a1965eb32cfbe12e220a55038218b02 /dev-python/matplotlib
parentStable on alpha. (diff)
downloadhistorical-5ecd3cf1c46606d32f969b18ff17784b8606876e.tar.gz
historical-5ecd3cf1c46606d32f969b18ff17784b8606876e.tar.bz2
historical-5ecd3cf1c46606d32f969b18ff17784b8606876e.zip
Version bump 0.73.1
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'dev-python/matplotlib')
-rw-r--r--dev-python/matplotlib/ChangeLog8
-rw-r--r--dev-python/matplotlib/files/digest-matplotlib-0.73.11
-rw-r--r--dev-python/matplotlib/matplotlib-0.71.ebuild3
-rw-r--r--dev-python/matplotlib/matplotlib-0.73.1.ebuild37
4 files changed, 46 insertions, 3 deletions
diff --git a/dev-python/matplotlib/ChangeLog b/dev-python/matplotlib/ChangeLog
index 28a33082da95..3eb3938c8df1 100644
--- a/dev-python/matplotlib/ChangeLog
+++ b/dev-python/matplotlib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/matplotlib
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/ChangeLog,v 1.4 2005/02/11 22:05:23 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/ChangeLog,v 1.5 2005/03/22 15:51:44 fserb Exp $
+
+*matplotlib-0.73.1 (22 Mar 2005)
+
+ 22 Mar 2005; Fernando Serboncini <fserb@gentoo.org>
+ matplotlib-0.71.ebuild, +matplotlib-0.73.1.ebuild:
+ Version bump. Removed nomirror restriction from newer ebuilds.
*matplotlib-0.64 (11 Feb 2005)
diff --git a/dev-python/matplotlib/files/digest-matplotlib-0.73.1 b/dev-python/matplotlib/files/digest-matplotlib-0.73.1
new file mode 100644
index 000000000000..1dc8730776e4
--- /dev/null
+++ b/dev-python/matplotlib/files/digest-matplotlib-0.73.1
@@ -0,0 +1 @@
+MD5 32cd50e6b381c7761d9e20cc97e5841d matplotlib-0.73.1.tar.gz 2299223
diff --git a/dev-python/matplotlib/matplotlib-0.71.ebuild b/dev-python/matplotlib/matplotlib-0.71.ebuild
index 8ae938f86bb8..cd6f6e68aec8 100644
--- a/dev-python/matplotlib/matplotlib-0.71.ebuild
+++ b/dev-python/matplotlib/matplotlib-0.71.ebuild
@@ -1,13 +1,12 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-0.71.ebuild,v 1.2 2005/02/11 22:05:23 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-0.71.ebuild,v 1.3 2005/03/22 15:51:44 fserb Exp $
inherit distutils virtualx
DESCRIPTION="matplotlib is a pure python plotting library designed to bring publication quality plotting to python with a syntax familiar to matlab users."
HOMEPAGE="http://matplotlib.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-RESTRICT="nomirror"
IUSE="doc gtk"
SLOT="0"
diff --git a/dev-python/matplotlib/matplotlib-0.73.1.ebuild b/dev-python/matplotlib/matplotlib-0.73.1.ebuild
new file mode 100644
index 000000000000..4dcbc12162ee
--- /dev/null
+++ b/dev-python/matplotlib/matplotlib-0.73.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-0.73.1.ebuild,v 1.1 2005/03/22 15:51:44 fserb Exp $
+
+inherit distutils virtualx
+
+DESCRIPTION="matplotlib is a pure python plotting library designed to bring publication quality plotting to python with a syntax familiar to matlab users."
+HOMEPAGE="http://matplotlib.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+IUSE="doc gtk"
+SLOT="0"
+KEYWORDS="~x86"
+LICENSE="as-is"
+
+DEPEND="virtual/python
+ >=dev-python/numeric-22
+ gtk? ( >=dev-python/pygtk-1.99.16 )"
+
+src_compile() {
+ export maketype="distutils_src_compile"
+ virtualmake "$*"
+}
+
+src_install() {
+ export maketype="distutils_src_install"
+ virtualmake "$*"
+ distutils_python_version
+
+ if use doc ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.py examples/README
+ insinfo /usr/share/doc/${PF}/examples/data
+ doins examples/data/*.dat
+ fi
+}
+