summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-06-25 08:44:47 +0000
committerIan Delaney <idella4@gentoo.org>2013-06-25 08:44:47 +0000
commit8b7b893ca8349e739c8d623803540b9b596ed344 (patch)
tree2b3d90b141a0f5b5947e17b088d00b048166397e /dev-python/jonpy/jonpy-0.10-r1.ebuild
parentVersion bump, wrt bug #472842, thanks to Eric F. GARIOUD <eric-f.garioud AT w... (diff)
downloadhistorical-8b7b893ca8349e739c8d623803540b9b596ed344.tar.gz
historical-8b7b893ca8349e739c8d623803540b9b596ed344.tar.bz2
historical-8b7b893ca8349e739c8d623803540b9b596ed344.zip
revbump; migrate -> distutils-r1, remove old
Package-Manager: portage-2.1.11.63/cvs/Linux x86_64 Manifest-Sign-Key: 0xB8072B0D
Diffstat (limited to 'dev-python/jonpy/jonpy-0.10-r1.ebuild')
-rw-r--r--dev-python/jonpy/jonpy-0.10-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/jonpy/jonpy-0.10-r1.ebuild b/dev-python/jonpy/jonpy-0.10-r1.ebuild
new file mode 100644
index 000000000000..5b8f6dfec129
--- /dev/null
+++ b/dev-python/jonpy/jonpy-0.10-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/jonpy/jonpy-0.10-r1.ebuild,v 1.1 2013/06/25 08:44:17 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7} pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="Powerful multi-threaded object-oriented CGI/FastCGI/mod_python/html-templating facilities"
+HOMEPAGE="http://jonpy.sourceforge.net/ http://pypi.python.org/pypi/jonpy"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+DEPEND=""
+RDEPEND=""
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/. )
+ use examples && local EXAMPLES=( example/. )
+ distutils-r1_python_install_all
+}