summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-10-27 01:21:31 +0000
committerAli Polatel <hawking@gentoo.org>2008-10-27 01:21:31 +0000
commit6150c7cf8d9d2e37f209cd1312dcce68b7d2c7d8 (patch)
tree23941a817b02607ed51cd168e87ce7d33e57b2a7 /dev-python/gconf-python
parentAdded compiz-0.7.8 to the tree (diff)
downloadhistorical-6150c7cf8d9d2e37f209cd1312dcce68b7d2c7d8.tar.gz
historical-6150c7cf8d9d2e37f209cd1312dcce68b7d2c7d8.tar.bz2
historical-6150c7cf8d9d2e37f209cd1312dcce68b7d2c7d8.zip
Use python_need_rebuild.
Package-Manager: portage--svn/cvs/Linux 2.6.26-gentoo x86_64
Diffstat (limited to 'dev-python/gconf-python')
-rw-r--r--dev-python/gconf-python/ChangeLog6
-rw-r--r--dev-python/gconf-python/gconf-python-2.22.1.ebuild9
-rw-r--r--dev-python/gconf-python/gconf-python-2.22.3.ebuild9
3 files changed, 19 insertions, 5 deletions
diff --git a/dev-python/gconf-python/ChangeLog b/dev-python/gconf-python/ChangeLog
index 5e3573576fe7..371ce22d71a3 100644
--- a/dev-python/gconf-python/ChangeLog
+++ b/dev-python/gconf-python/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/gconf-python
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gconf-python/ChangeLog,v 1.2 2008/09/26 09:59:25 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gconf-python/ChangeLog,v 1.3 2008/10/27 01:18:18 hawking Exp $
+
+ 27 Oct 2008; Ali Polatel <hawking@gentoo.org> gconf-python-2.22.1.ebuild,
+ gconf-python-2.22.3.ebuild:
+ Use python_need_rebuild.
*gconf-python-2.22.3 (26 Sep 2008)
diff --git a/dev-python/gconf-python/gconf-python-2.22.1.ebuild b/dev-python/gconf-python/gconf-python-2.22.1.ebuild
index 4c38a21f918d..902e1799a9f6 100644
--- a/dev-python/gconf-python/gconf-python-2.22.1.ebuild
+++ b/dev-python/gconf-python/gconf-python-2.22.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gconf-python/gconf-python-2.22.1.ebuild,v 1.1 2008/08/24 07:24:41 ford_prefect Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gconf-python/gconf-python-2.22.1.ebuild,v 1.2 2008/10/27 01:18:18 hawking Exp $
G_PY_PN="gnome-python"
-inherit gnome-python-common
+inherit gnome-python-common python
DESCRIPTION="Python bindings for the GConf library"
LICENSE="LGPL-2.1"
@@ -17,3 +17,8 @@ RDEPEND=">=gnome-base/gconf-2.11.1
DEPEND="${RDEPEND}"
EXAMPLES="examples/gconf/*"
+
+src_install() {
+ python_need_rebuild
+ gnome-python-common_src_install
+}
diff --git a/dev-python/gconf-python/gconf-python-2.22.3.ebuild b/dev-python/gconf-python/gconf-python-2.22.3.ebuild
index d36ad3c4c666..e433b903ae87 100644
--- a/dev-python/gconf-python/gconf-python-2.22.3.ebuild
+++ b/dev-python/gconf-python/gconf-python-2.22.3.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gconf-python/gconf-python-2.22.3.ebuild,v 1.1 2008/09/26 09:59:25 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gconf-python/gconf-python-2.22.3.ebuild,v 1.2 2008/10/27 01:18:18 hawking Exp $
G_PY_PN="gnome-python"
-inherit gnome-python-common
+inherit gnome-python-common python
DESCRIPTION="Python bindings for the GConf library"
LICENSE="LGPL-2.1"
@@ -17,3 +17,8 @@ RDEPEND=">=gnome-base/gconf-2.11.1
DEPEND="${RDEPEND}"
EXAMPLES="examples/gconf/*"
+
+src_install() {
+ python_need_rebuild
+ gnome-python-common_src_install
+}