summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2012-04-10 12:47:21 +0000
committerRafael Martins <rafaelmartins@gentoo.org>2012-04-10 12:47:21 +0000
commitb521089d65b0c4cd61daab30467b41c1be9841e0 (patch)
treea5ca9a82408993e2863d0b2aa765236e500bfa03 /dev-python/flask
parentcleaned mirror: from SRC_URIs (diff)
downloadhistorical-b521089d65b0c4cd61daab30467b41c1be9841e0.tar.gz
historical-b521089d65b0c4cd61daab30467b41c1be9841e0.tar.bz2
historical-b521089d65b0c4cd61daab30467b41c1be9841e0.zip
Added live ebuild.
Package-Manager: portage-2.2.0_alpha90/cvs/Linux x86_64
Diffstat (limited to 'dev-python/flask')
-rw-r--r--dev-python/flask/ChangeLog9
-rw-r--r--dev-python/flask/flask-9999.ebuild64
2 files changed, 71 insertions, 2 deletions
diff --git a/dev-python/flask/ChangeLog b/dev-python/flask/ChangeLog
index 48e1d09eb26b..1c44045b4a49 100644
--- a/dev-python/flask/ChangeLog
+++ b/dev-python/flask/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/flask
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask/ChangeLog,v 1.11 2011/10/08 19:13:50 floppym Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask/ChangeLog,v 1.12 2012/04/10 12:47:21 rafaelmartins Exp $
+
+*flask-9999 (10 Apr 2012)
+
+ 10 Apr 2012; Rafael Martins <rafael@gentoo.org> +flask-9999.ebuild:
+ Added live ebuild.
08 Oct 2011; Mike Gilbert <floppym@gentoo.org> flask-0.8.ebuild:
Fix compilation with py2.5; thanks to Arfrever catching this.
diff --git a/dev-python/flask/flask-9999.ebuild b/dev-python/flask/flask-9999.ebuild
new file mode 100644
index 000000000000..9c69e153b035
--- /dev/null
+++ b/dev-python/flask/flask-9999.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask/flask-9999.ebuild,v 1.1 2012/04/10 12:47:21 rafaelmartins Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+
+EGIT_REPO_URI="git://github.com/mitsuhiko/flask.git
+ https://github.com/mitsuhiko/flask.git"
+
+inherit distutils git-2
+
+MY_PN="Flask"
+
+DESCRIPTION="A microframework based on Werkzeug, Jinja2 and good intentions"
+HOMEPAGE="http://pypi.python.org/pypi/Flask"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE="doc examples test"
+
+RDEPEND="dev-python/blinker
+ >=dev-python/jinja-2.4
+ dev-python/setuptools
+ >=dev-python/werkzeug-0.6.1"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-python/sphinx-0.6 )"
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ pushd docs > /dev/null
+ PYTHONPATH=".." emake html || die "Generation of documentation failed"
+ popd > /dev/null
+ fi
+}
+
+src_test() {
+ testing() {
+ PYTHONPATH="." "$(PYTHON)" run-tests.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ pushd docs/_build/html > /dev/null
+ insinto /usr/share/doc/${PF}/html
+ doins -r [a-z]* _images _static || die "Installation of documentation failed"
+ popd > /dev/null
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples || die "Installation of examples failed"
+ fi
+}