summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-03-27 10:56:01 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-03-27 10:56:01 +0000
commit9ad759c13ae7a651797bd523d8211002e8be7fc4 (patch)
treecb7e2622398bb1a445fc03e2f6d7a16fd5ab63e6 /dev-python/enthoughtbase
parentVersion bump and fixed wxwindows dependencies (diff)
downloadhistorical-9ad759c13ae7a651797bd523d8211002e8be7fc4.tar.gz
historical-9ad759c13ae7a651797bd523d8211002e8be7fc4.tar.bz2
historical-9ad759c13ae7a651797bd523d8211002e8be7fc4.zip
Version bump
Package-Manager: portage-2.2_rc26/cvs/Linux x86_64
Diffstat (limited to 'dev-python/enthoughtbase')
-rw-r--r--dev-python/enthoughtbase/ChangeLog8
-rw-r--r--dev-python/enthoughtbase/enthoughtbase-3.0.2.ebuild60
2 files changed, 67 insertions, 1 deletions
diff --git a/dev-python/enthoughtbase/ChangeLog b/dev-python/enthoughtbase/ChangeLog
index 6008defcd685..f27f7fef3fd3 100644
--- a/dev-python/enthoughtbase/ChangeLog
+++ b/dev-python/enthoughtbase/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/enthoughtbase
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/enthoughtbase/ChangeLog,v 1.2 2009/02/12 11:55:30 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/enthoughtbase/ChangeLog,v 1.3 2009/03/27 10:38:36 bicatali Exp $
+
+*enthoughtbase-3.0.2 (27 Mar 2009)
+
+ 27 Mar 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ +enthoughtbase-3.0.2.ebuild:
+ Version bump
12 Feb 2009; Sébastien Fabbro <bicatali@gentoo.org> ChangeLog:
Export fonts cache locally to avoid sandbox failures, closing bug #258649
diff --git a/dev-python/enthoughtbase/enthoughtbase-3.0.2.ebuild b/dev-python/enthoughtbase/enthoughtbase-3.0.2.ebuild
new file mode 100644
index 000000000000..c8a099ac1204
--- /dev/null
+++ b/dev-python/enthoughtbase/enthoughtbase-3.0.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/enthoughtbase/enthoughtbase-3.0.2.ebuild,v 1.1 2009/03/27 10:38:36 bicatali Exp $
+
+EAPI=2
+inherit distutils
+
+MY_PN="EnthoughtBase"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Core packages for the Enthought Tool Suite"
+HOMEPAGE="http://code.enthought.com/projects/enthought_base.php"
+SRC_URI="http://www.enthought.com/repo/ETS/${MY_P}.tar.gz"
+
+IUSE="doc examples"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="BSD LGPL-2"
+RDEPEND=""
+DEPEND="dev-python/setuptools
+ doc? ( dev-python/setupdocs )"
+# tests would require circular deps
+# test? ( >=dev-python/nose-0.10.3
+# dev-python/traits
+# dev-python/etsdevtools )"
+RESTRICT=test
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="enthought"
+
+src_prepare() {
+ sed -i -e "/self.run_command('build_docs')/d" setup.py || die
+}
+
+src_compile() {
+ distutils_src_compile
+ if use doc; then
+ export VARTEXFONTS="${T}/fonts"
+ ${python} setup.py build_docs --formats=html,pdf \
+ || die "doc building failed"
+ fi
+}
+
+src_test() {
+ PYTHONPATH=build/lib "${python}" setup.py test || die "tests failed"
+}
+
+src_install() {
+ find "${S}" -name \*LICENSE.txt -delete
+ distutils_src_install
+ dodoc docs/*.txt
+ insinto /usr/share/doc/${PF}
+ if use doc; then
+ doins -r build/docs/html || die
+ doins build/docs/latex/*.pdf || die
+ fi
+ if use examples; then
+ doins -r examples || die
+ fi
+}