summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-31 17:31:39 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-31 17:31:39 +0000
commit8e8699fa67c5befe6b754b5a683532e793b6a88c (patch)
tree5a00f25a4a277204df5407b2100b20567176fb4b /dev-python/cython
parentMarked ~hppa (bug #358401). (diff)
downloadhistorical-8e8699fa67c5befe6b754b5a683532e793b6a88c.tar.gz
historical-8e8699fa67c5befe6b754b5a683532e793b6a88c.tar.bz2
historical-8e8699fa67c5befe6b754b5a683532e793b6a88c.zip
Delete older ebuild.
Package-Manager: portage-2.2.0_alpha29_p4/cvs/Linux x86_64
Diffstat (limited to 'dev-python/cython')
-rw-r--r--dev-python/cython/cython-0.13.ebuild58
-rw-r--r--dev-python/cython/files/cython-0.13-python-3.1.3.patch25
2 files changed, 0 insertions, 83 deletions
diff --git a/dev-python/cython/cython-0.13.ebuild b/dev-python/cython/cython-0.13.ebuild
deleted file mode 100644
index 3dd6bee84ce3..000000000000
--- a/dev-python/cython/cython-0.13.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cython/cython-0.13.ebuild,v 1.7 2010/11/15 02:17:14 arfrever Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils eutils
-
-MY_PN="Cython"
-MY_P="${MY_PN}-${PV/_/.}"
-
-DESCRIPTION="The Cython compiler for writing C extensions for the Python language"
-HOMEPAGE="http://www.cython.org/ http://pypi.python.org/pypi/Cython"
-SRC_URI="mirror://pypi/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz
- http://www.cython.org/release/${MY_P}.tar.gz"
-
-LICENSE="PSF-2.4"
-SLOT="0"
-KEYWORDS="amd64 ~arm hppa ~ia64 ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE="doc examples"
-
-DEPEND=""
-RDEPEND=""
-
-S="${WORKDIR}/${MY_P}"
-
-PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
-
-DOCS="ToDo.txt USAGE.txt"
-PYTHON_MODNAME="Cython pyximport"
-
-src_prepare() {
- distutils_src_prepare
- epatch "${FILESDIR}/${P}-python-3.1.3.patch"
-}
-
-src_test() {
- testing() {
- rm -fr BUILD
- "$(PYTHON)" runtests.py -vv
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- # "-A c" is for ignoring of "Doc/primes.c".
- dohtml -A c -r Doc/* || die "Installation of documentation failed"
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r Demos/* || die "Installation of examples failed"
- fi
-}
diff --git a/dev-python/cython/files/cython-0.13-python-3.1.3.patch b/dev-python/cython/files/cython-0.13-python-3.1.3.patch
deleted file mode 100644
index 19e30bef11e1..000000000000
--- a/dev-python/cython/files/cython-0.13-python-3.1.3.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-http://hg.cython.org/cython-devel/rev/66db6308e5be
-
---- setup.py
-+++ setup.py
-@@ -106,12 +106,19 @@
- )
-
- class build_ext(build_ext_orig):
-+ # we must keep the original modules alive to make sure
-+ # their code keeps working when we remove them from
-+ # sys.modules
-+ dead_modules = []
-+
- def build_extensions(self):
- # add path where 2to3 installed the transformed sources
- # and make sure Python (re-)imports them from there
- already_imported = [ module for module in sys.modules
- if module == 'Cython' or module.startswith('Cython.') ]
-+ keep_alive = self.dead_modules.append
- for module in already_imported:
-+ keep_alive(sys.modules[module])
- del sys.modules[module]
- sys.path.insert(0, os.path.join(source_root, self.build_lib))
-
-