summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-08-19 09:38:08 +0000
committerAli Polatel <hawking@gentoo.org>2008-08-19 09:38:08 +0000
commit4fc99ed6edd79fc4f64cec277a4a378441fa81eb (patch)
treece6bf87aeec07896f4dd3147b169b3a6690a27b2 /dev-python/cython/cython-0.9.8.1.ebuild
parentamd64 stable, bug #231723 (diff)
downloadhistorical-4fc99ed6edd79fc4f64cec277a4a378441fa81eb.tar.gz
historical-4fc99ed6edd79fc4f64cec277a4a378441fa81eb.tar.bz2
historical-4fc99ed6edd79fc4f64cec277a4a378441fa81eb.zip
Version bump. Use tarball instead of zip, drop unzip DEPEND.
Package-Manager: portage--svn.wrabbit
Diffstat (limited to 'dev-python/cython/cython-0.9.8.1.ebuild')
-rw-r--r--dev-python/cython/cython-0.9.8.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/cython/cython-0.9.8.1.ebuild b/dev-python/cython/cython-0.9.8.1.ebuild
new file mode 100644
index 000000000000..e9c5991820f3
--- /dev/null
+++ b/dev-python/cython/cython-0.9.8.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cython/cython-0.9.8.1.ebuild,v 1.1 2008/08/19 09:38:08 hawking Exp $
+
+NEED_PYTHON=2.2
+
+inherit distutils eutils
+
+MY_PN="Cython"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A language for writing Python extension modules based on pyrex"
+HOMEPAGE="http://www.cython.org/"
+SRC_URI="http://www.cython.org/${MY_P}.tar.gz"
+
+LICENSE="PSF-2.4"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc examples"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="${MY_PN}"
+DOCS="ToDo.txt USAGE.txt"
+
+src_install() {
+ distutils_src_install
+
+ # -A c switch is for Doc/primes.c
+ use doc && dohtml -A c -r Doc/*
+
+ if use examples; then
+ # Demos/ has files with .so,~ suffixes.
+ # So we have to specify precisely what to install.
+ insinto /usr/share/doc/${PF}/examples
+ doins Demos/Makefile* Demos/Setup.py Demos/*.{py,pyx,pxd}
+ fi
+}